À propos du contenu sécuritaire de QuickTime 7.1.6

Ce document décrit Security Update 2007-004 v1.1, qui peut être téléchargé et installé via les préférences Mise à jour de logiciels ou les Téléchargements Apple.

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête approfondie n’a pas été menée et que des correctifs ou mises à jour ne sont pas mis à disposition. Pour en savoir plus sur la sécurité des produits Apple, consultez la page Sécurité produit d’Apple.

Pour plus d’informations sur la clé PGP de sécurité des produits Apple, consultez l’article « Comment utiliser la clé PGP de sécurité des produits Apple ».

Lorsque cela est possible, des références CVE sont utilisées afin de référencer les vulnérabilités pour plus d’informations.

Pour connaître les autres mises à jour de sécurité, consultez l’article « Mises à jour de sécurité Apple ».

Mise à jour de QuickTime 7.1.6

  • QuickTime

    Références CVE : CVE-2007-2175

    Disponible pour : Mac OS X v10.3.9, Mac OS X v10.4.9, Windows XP SP2, Windows 2000 SP4

    Conséquences : la consultation d’un site web construit de manière malveillante peut conduire à l’exécution de code quelconque

    Description: QuickTime pour Java présente un problème d’implémentation susceptible d’autoriser la lecture ou l’écriture hors des limites de la mémoire tampon allouée. En poussant un utilisateur à une page web contenant une applet Java construite de manière malveillante, un attaquant peut déclencher le problème, qui peut conduire à l’exécution de code quelconque. Cette mise à jour résout le problème en effectuant des contrôles supplémentaires de limitation des zones adressables lors de la création d’objets QTPointerRef. Nous remercions Dino Dai Zovi, qui travaille avec TippingPoint et Zero Day Initiative pour avoir signalé ce problème.

Date de publication: