À propos des correctifs de sécurité de macOS Sierra 10.12.3

Ce document décrit les correctifs de sécurité de macOS Sierra 10.12.3.

À propos des mises à jour de sécurité Apple

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Les mises à jour récentes sont répertoriées sur la page Mises à jour de sécurité Apple.

Pour obtenir plus d’informations en matière de sécurité, consultez la page Sécurité produit Apple. Vous pouvez chiffrer les communications avec Apple à l’aide de la Clé PGP du groupe de sécurité produit d’Apple.

Les documents de sécurité Apple répertorient les vulnérabilités par référence CVE dans la mesure du possible.

macOS Sierra 10.12.3

Publié le 23 janvier 2017

Serveur des notifications Push Apple

Disponible pour : macOS Sierra 10.12.2

Conséquence : un attaquant profitant d’une position privilégiée sur le réseau peut traquer les activités d’un utilisateur.

Description : un certificat client a été envoyé au format texte. Ce problème a été résolu par une meilleure gestion des certificats.

CVE-2017-2383 : Matthias Wachs et Quirin Scheitle de l’université technique de Munich (TUM)

Entrée ajoutée le 28 mars 2017

apache_mod_php

Disponible pour : macOS Sierra 10.12.2

Conséquence : PHP présente plusieurs problèmes

Description : de nombreux problèmes ont été résolus par la mise à jour de PHP vers la version 5.6.28.

CVE-2016-8670

CVE-2016-9933

CVE-2016-9934

Bluetooth

Disponible pour : macOS Sierra 10.12.2

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème d’utilisation ultérieure libre a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2353 : Ian Beer de Google Project Zero

Gestionnaires de graphiques

Disponible pour : macOS Sierra 10.12.2

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2358 : équipe Pangu et lokihardt lors du PwnFest 2016

Visualiseur d’aide

Disponible pour : macOS Sierra 10.12.2

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de scriptage intersites a été résolu par une meilleure validation des URL.

CVE-2017-2361 : lokihardt de Google Project Zero

IOAudioFamily

Disponible pour : macOS Sierra 10.12.2

Conséquence : une application peut déterminer la structure de la mémoire du noyau.

Description : un problème de mémoire non initialisée a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2357 : équipe Pangu et lokihardt lors du PwnFest 2016

Noyau

Disponible pour : macOS Sierra 10.12.2

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de dépassement de la mémoire tampon a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2370 : Ian Beer de Google Project Zero

Noyau

Disponible pour : macOS Sierra 10.12.2

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème d’utilisation ultérieure libre a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2360 : Ian Beer de Google Project Zero

libarchive

Disponible pour : macOS Sierra 10.12.2

Conséquence : la décompression d’une archive malveillante peut entraîner l’exécution arbitraire de code.

Description : un problème de dépassement de la mémoire tampon a été résolu par une meilleure gestion de la mémoire.

CVE-2016-8687 : Agostino Sarubbo de Gentoo

Vim

Disponible pour : macOS Sierra 10.12.2

Conséquence : l’ouverture d’un fichier malveillant peut entraîner la fermeture inopinée d’une application ou l’exécution arbitraire de code.

Description : les modelines présentaient un problème de validation d’entrée. Ce problème a été résolu par une meilleure validation des entrées.

CVE-2016-1248 : Florian Larysch

macOS Sierra 10.12.3 comprend les correctifs de sécurité de Safari 10.0.3.

Les informations se rapportant à des produits non fabriqués par Apple, ou à des sites Web indépendants qui ne sont ni contrôlés ni testés par Apple, sont fournies uniquement à titre indicatif et ne constituent aucune recommandation. Apple ne saurait être tenu pour responsable de tout problème lié à l’utilisation de tels sites ou produits tiers, ou à leurs performances. Apple ne garantit en aucune façon la fiabilité d’un site Web, ou l’exactitude des informations que ce dernier propose. L’utilisation d’Internet induit en effet des risques. Contactez le fournisseur pour obtenir des informations supplémentaires. Les autres noms de société et de produit peuvent constituer des marques déposées de leurs détenteurs respectifs.

Date de publication: