À propos des correctifs de sécurité de Xcode 7.0

Ce document décrit les correctifs de sécurité de Xcode 7.0.

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête approfondie n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Pour obtenir des informations supplémentaires sur la sécurité produit d’Apple, consultez le site Web Sécurité produit d’Apple.

Pour en savoir plus sur la clé PGP du groupe de sécurité produit d’Apple, consultez l’article Comment utiliser la clé PGP du groupe de sécurité produit d’Apple.

Des références CVE sont utilisées, le cas échéant, pour répertorier les vulnérabilités et fournir des informations supplémentaires.

Pour obtenir des informations sur les autres mises à jour de sécurité, consultez l’article Mises à jour de sécurité Apple.

Xcode 7.0

  • DevTools

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : un attaquant peut être en mesure d’ignorer les restrictions applicables aux accès.

    Description : un problème d’API existait au niveau de la configuration Apache. Ce problème a été résolu par la mise à jour, à l’aide de la dernière version, des fichiers d’en-tête.

    Référence CVE

    CVE-2015-3185 : Branko Äibej de l’Apache Software Foundation.

  • Serveur Xcode IDE

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : un attaquant peut être en mesure d’accéder à des sections protégées du système de fichier.

    Description : un problème de comparaison existait au niveau du module d’envoi node.js, si sa version était antérieure à la version 0.8.4. Ce problème a été résolu par l’installation de la version 0.12.3.

    Référence CVE

    CVE-2014-6394 : Ilya Kantor.

  • Serveur Xcode IDE

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : plusieurs vulnérabilités affectent OpenSSL.

    Description : plusieurs vulnérabilités affectaient le module OpenSSL node.js, si sa version était antérieure à la version 1.0.1j. Ces problèmes ont été résolus par l’installation de la version 1.0.1j d’OpenSSL.

    Référence CVE

    CVE-2014-3513

    CVE-2014-3566

    CVE-2014-3567

    CVE-2014-3568

  • Serveur Xcode IDE

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : un attaquant bénéficiant d’une position privilégiée sur le réseau peut être en mesure de surveiller le trafic utilisateur vers le serveur Xcode.

    Description : des connexions non chiffrées pouvaient être établies en direction du serveur Xcode. Ce problème a été résolu par l’application d’une logique de connexion réseau améliorée.

    Référence CVE

    CVE-2015-5910 : un chercheur anonyme.

  • Serveur Xcode IDE

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : des notifications relatives aux builds peuvent être envoyées aux mauvais destinataires.

    Description : des problèmes d’accès existaient au niveau de la gestion des listes d’adresses e-mail. Ce problème a été résolu par une meilleure validation.

    Référence CVE

    CVE-2015-5909 : Daniel Tomlinson de Rocket Apps, David Gatwood d’Anchorfree.

  • Subversion

    Disponible pour : OS X Yosemite 10.10.4 ou version ultérieure.

    Conséquence : plusieurs vulnérabilités affectent les versions de svn antérieures à la version 1.7.19.

    Description : plusieurs vulnérabilités affectaient les versions de svn antérieures à la version 1.7.19. Elles ont été corrigées par une mise à jour de ce logiciel vers la version 1.7.20.

    Référence CVE

    CVE-2015-0248

    CVE-2015-0251

Les informations se rapportant à des produits non fabriqués par Apple, ou à des sites Web indépendants qui ne sont ni contrôlés ni testés par Apple, sont fournies uniquement à titre indicatif et ne constituent aucune recommandation. Apple ne saurait être tenu pour responsable de tout problème lié à l’utilisation de tels sites ou produits tiers, ou à leurs performances. Apple ne garantit en aucune façon la fiabilité d’un site Web, ou l’exactitude des informations que ce dernier propose. L’utilisation d’Internet induit en effet des risques. Contactez le fournisseur pour obtenir des informations supplémentaires. Les autres noms de société et de produit peuvent constituer des marques déposées de leurs détenteurs respectifs.

Date de publication:Fri Oct 09 00:31:08 GMT 2015