Logic Pro/Express 8 et 9 : conseils de dépannage applicables aux fichiers de projet

Dans de rares cas, un fichier de projet peut fonctionner de manière inattendue. Découvrez comment éviter les problèmes potentiels liés à vos projets, et y remédier lorsque ceux-ci se produisent.
Cet article a été archivé et ne sera plus mis à jour par Apple.

Précautions d’usage

Pour vous prémunir de tout problème avec vos projets, il est recommandé d’enregistrer des versions pendant votre travail. Démarrez chaque session en enregistrant une version du projet et en indiquant la date du jour dans le nom. Vous pouvez ensuite enregistrer ces versions du projet dans le même dossier de projet, afin d’éviter la duplication des divers composants. Par exemple, si vous travaillez sur le projet MonProjet, et que la date du jour est le 1er mars 2012 (01-03-2012), vous pouvez démarrer votre session en choisissant Fichier > Enregistrer sous, puis en nommant le nouveau fichier MonProjet 01_03_12. Dès que vous travaillez sur le projet, enregistrez une nouvelle version du projet en remplaçant la date par celle du jour.

Par ailleurs, Logic conserve un historique des sauvegardes des 10 dernières versions enregistrées d’un fichier. Ces sauvegardes sont enregistrées dans le dossier « Project File backups » de votre dossier de projet. Toutefois, pour rechercher plus facilement une version du projet antérieure à un problème, enregistrez manuellement les nouvelles versions comme décrit ci-dessus. Logic crée un ensemble de 10 versions pour chaque nom de projet dans le dossier de projet. Ainsi, lorsque vous choisissez Fichier > Enregistrer sous..., un nouvel ensemble de sauvegardes est créé, comme illustré ici :

Utilisation de modules audio validés uniquement

Pour empêcher la survenue de problèmes liés à vos fichiers de projet, évitez d’utiliser des modules Audio Unit n’étant pas validés par le gestionnaire Audio Units. De tels modules sont automatiquement désactivés dans Logic. Dans certains cas, il est possible de forcer Logic à les utiliser, bien que ceci ne soit pas conseillé.

Pour vous assurer d’utiliser uniquement des modules validés, choisissez Logic Pro < (ou Logic Express) > Préférences > Gestionnaire Audio Units, puis cliquez sur « Désactiver les Audio Units ne fonctionnant pas correctement » dans la partie inférieure gauche de la fenêtre. Si vous disposez de modules n’ayant pas pu être validés, consultez le site Web du fabricant pour obtenir des versions mises à jour.

Dépannage

Si vous rencontrez des problèmes liés à un projet, procédez comme suit :

  1. Ouvrez Logic sans gestionnaire audio, en maintenant la touche Contrôle enfoncée dès l’ouverture de Logic. Une boîte de dialogue s’affiche et vous invite à lancer le pilote Core Audio. Cliquez sur Non.
  2. Ouvrez le fichier de projet.
  3. Choisissez Édition > Supprimer l’historique d’annulation.
    Remarque : cette opération entraîne la suppression de toutes les étapes d’annulation enregistrées.
  4. Choisissez Options > Informations sur le projet...

    Cliquez sur Réorganiser la mémoire. Si un message d’avertissement relatif à des blocs inutilisés s’affiche, cliquez sur Supprimer dans la boîte de dialogue, puis cliquez à nouveau sur Réorganiser la mémoire jusqu’à ce que plus aucun message ne s’affiche.

  5. Enregistrez le projet sous un autre nom.

Les informations se rapportant à des produits non fabriqués par Apple, ou à des sites Web indépendants qui ne sont ni contrôlés ni testés par Apple, sont fournies uniquement à titre indicatif et ne constituent aucune recommandation. Apple ne saurait être tenu pour responsable de tout problème lié à l’utilisation de tels sites ou produits tiers, ou à leurs performances. Apple ne garantit en aucune façon la fiabilité d’un site Web, ou l’exactitude des informations que ce dernier propose. L’utilisation d’Internet induit en effet des risques. Contactez le fournisseur pour obtenir des informations supplémentaires. Les autres noms de société et de produit peuvent constituer des marques déposées de leurs détenteurs respectifs.

Date de publication: