Tietoja Safari 8.0.1:n, Safari 7.1.1:n ja Safari 6.2.1:n turvallisuussisällöstä

Tässä asiakirjassa kerrotaan Safari 8.0.1:n, Safari 7.1.1:n ja Safari 6.2.1:n turvallisuussisällöstä.

Suojellakseen asiakkaitaan Apple ei paljasta tietoturvaongelmia eikä anna niistä tietoja tai vahvista niitä, ennen kuin täydellinen tutkinta on tehty ja tarpeelliset korjauspäivitykset tai uudet versiot ovat saatavilla. Lisätietoja Applen tuoteturvallisuudesta on Applen tuoteturvallisuussivustolla.

Lisätietoja Applen tuoteturvallisuuden PGP-avaimesta on artikkelissa Applen tuoteturvallisuuden PGP-avaimen käyttäminen.

CVE-tunnuksia käytetään mahdollisuuksien mukaan viittaamaan lisätietoihin haavoittuvuuksista.

Tietoja muista suojauspäivityksistä on artikkelissa Applen suojauspäivitykset.

Safari 8.0.1, Safari 7.1.1 ja Safari 6.2.1

  • WebKit

    Saatavuus: OS X Mountain Lion 10.8.5, OS X Mavericks 10.9.5 ja OS X Yosemite 10.10.1.

    Vaikutus: Tyylisivut ladattiin eri alkuperistä, mikä saattoi aiheuttaa tietojen vuotamisen.

    Kuvaus: Img-elementissä ladattu SVG saattoi ladata CSS-tiedoston eri alkuperistä. Ongelma on ratkaistu parantamalla ulkoisten CSS-viitteiden estämistä SVG:eissä.

    CVE-ID

    CVE-2014-4465: iSEC Partnersin Rennie deGraaf

  • WebKit

    Saatavuus: OS X Mountain Lion 10.8.5, OS X Mavericks 10.9.5 ja OS X Yosemite 10.10.1.

    Vaikutus: Haitallista sisältöä kehyksissä näyttävän sivuston avaaminen saattoi aiheuttaa käyttöliittymän väärentämisen.

    Kuvaus: Vierityspalkin rajojen käsittelyssä oli käyttöliittymän väärennysongelma. Ongelma on ratkaistu parantamalla rajojen tarkistusta.

    CVE-ID

    CVE-2014-1748: Jordan Milne

  • WebKit

    Saatavuus: OS X Mountain Lion 10.8.5, OS X Mavericks 10.9.5 ja OS X Yosemite 10.10.1.

    Vaikutus: Haitallisella verkkosivustolla käynti saattoi johtaa ohjelman odottamattomaan sulkeutumiseen tai mielivaltaisen koodin suorittamiseen.

    Kuvaus: WebKitissä oli useita muistin vioittumiseen liittyviä ongelmia. Ongelmat on ratkaistu parantamalla muistin käsittelyä.

    CVE-ID

    CVE-2014-4452

    CVE-2014-4459

    CVE-2014-4466: Apple

    CVE-2014-4468: Apple

    CVE-2014-4469: Apple

    CVE-2014-4470: Apple

    CVE-2014-4471: Apple

    CVE-2014-4472: Apple

    CVE-2014-4473: Apple

    CVE-2014-4474: Apple

    CVE-2014-4475: Apple

Muita kuin Applen valmistamia tuotteita sekä itsenäisiä verkkosivustoja (joita Apple ei hallitse tai joita se ei ole testannut) koskevat tiedot on tarkoitettu vain tiedoksi. Apple ei suosittele tai tue niitä. Apple ei vastaa muun valmistajan verkkosivustojen tai tuotteiden valikoimasta, suorituskyvystä tai käytöstä. Apple ei vastaa muun valmistajan verkkosivuston oikeellisuudesta tai luotettavuudesta. Internetin käyttöön liittyy riskejä. Pyydä lisätietoja valmistajalta. Muut yritysten ja tuotteiden nimet saattavat olla omistajiensa tavaramerkkejä.

Julkaisupäivämäärä: