Tietoja iOS 4.3.4 -ohjelmistopäivityksen turvallisuussisällöstä

Tässä asiakirjassa kerrotaan iOS 4.3.4 -ohjelmistopäivityksen turvallisuussisällöstä.

Suojellakseen asiakkaitaan Apple ei paljasta tietoturvaongelmia eikä anna niistä tietoja tai vahvista niitä, ennen kuin täydellinen tutkinta on tehty ja tarpeelliset korjauspäivitykset tai uudet versiot ovat saatavilla. Lisätietoja Applen tuoteturvallisuudesta on Applen tuoteturvallisuussivustossa.

Lisätietoja Applen tuoteturvallisuuden PGP-avaimesta on artikkelissa Applen tuoteturvallisuuden PGP-avaimen käyttäminen.

CVE ID -tunnuksia käytetään mahdollisuuksien mukaan viittaamaan lisätietoihin haavoittuvuuksista.

Tietoja muista suojauspäivityksistä on artikkelissa Applen suojauspäivitykset.

iOS 4.3.4 -ohjelmistopäivitys

  • CoreGraphics

    Saatavuus: iOS 3.0–4.3.3 (iPhone 3GS ja iPhone 4:n GSM-malli), iOS 3.1–4.3.3 (iPod touch, 3. sukupolvi tai uudempi) ja iOS 3.2–4.3.3 (iPad).

    Vaikutus: Haitallisen PDF-tiedoston tarkasteleminen saattoi aiheuttaa ohjelman odottamattoman sulkeutumisen tai mielivaltaisen koodin suorittamisen.

    Kuvaus: FreeTypen tavassa käsitellä TrueType-fontteja oli puskurin ylivuoto. Haitallisen PDF-tiedoston tarkasteleminen saattoi aiheuttaa ohjelman odottamattoman sulkeutumisen tai mielivaltaisen koodin suorittamisen.

    CVE-ID

    CVE-2010-3855

  • CoreGraphics

    Saatavuus: iOS 3.0–4.3.3 (iPhone 3GS ja iPhone 4:n GSM-malli), iOS 3.1–4.3.3 (iPod touch, 3. sukupolvi tai uudempi) ja iOS 3.2–4.3.3 (iPad).

    Vaikutus: Haitallisen PDF-tiedoston tarkasteleminen saattoi aiheuttaa ohjelman odottamattoman sulkeutumisen tai mielivaltaisen koodin suorittamisen.

    Kuvaus: FreeTypen tavassa käsitellä Type 1 -fontteja oli etumerkillisyyteen liittyvä ongelma. Haitallisen PDF-tiedoston tarkasteleminen saattoi aiheuttaa ohjelman odottamattoman sulkeutumisen tai mielivaltaisen koodin suorittamisen.

    CVE-ID

    CVE-2011-0226: comex

  • IOMobileFrameBuffer

    Saatavuus: iOS 3.0–4.3.3 (iPhone 3GS ja iPhone 4:n GSM-malli), iOS 3.1–4.3.3 (iPod touch, 3. sukupolvi tai uudempi) ja iOS 3.2–4.3.3 (iPad).

    Vaikutus: Käyttäjänä esiintyvä haitallinen koodi saattoi saada järjestelmän käyttöoikeudet.

    Kuvaus: IOMobileFrameBufferin jonotusalkeistyyppien käytössä oli virheelliseen tyyppikonversioon liittyvä ongelma, jonka seurauksena käyttäjänä toimiva haitallinen koodi saattoi pystyä saamaan järjestelmän käyttöoikeudet.

    CVE-ID

    CVE-2011-0227: comex

Muita kuin Applen valmistamia tuotteita sekä itsenäisiä verkkosivustoja (joita Apple ei hallitse tai joita se ei ole testannut) koskevat tiedot on tarkoitettu vain tiedoksi. Apple ei suosittele tai tue niitä. Apple ei vastaa muun valmistajan verkkosivustojen tai tuotteiden valikoimasta, suorituskyvystä tai käytöstä. Apple ei vastaa muun valmistajan verkkosivuston oikeellisuudesta tai luotettavuudesta. Internetin käyttöön liittyy riskejä. Pyydä lisätietoja valmistajalta. Muut yritysten ja tuotteiden nimet saattavat olla omistajiensa tavaramerkkejä.

Julkaisupäivämäärä: