Tietoja iOS 6.0.1 -ohjelmistopäivityksen turvallisuussisällöstä

Tässä asiakirjassa kerrotaan iOS 6.0.1 -ohjelmistopäivityksen turvallisuussisällöstä. Päivitys voidaan ladata ja asentaa iTunesin avulla.

Suojellakseen asiakkaitaan Apple ei paljasta tietoturvaongelmia eikä anna niistä tietoja tai vahvista niitä, ennen kuin täydellinen tutkinta on tehty ja tarpeelliset korjauspäivitykset tai uudet versiot ovat saatavilla. Lisätietoja Applen tuoteturvallisuudesta on Applen tuoteturvallisuussivustolla.

Lisätietoja Applen tuoteturvallisuuden PGP-avaimesta on artikkelissa Applen tuoteturvallisuuden PGP-avaimen käyttäminen.

CVE ID -tunnuksia käytetään mahdollisuuksien mukaan viittaamaan lisätietoihin haavoittuvuuksista.

Tietoja muista suojauspäivityksistä on artikkelissa Applen suojauspäivitykset.

iOS 6.0.1

  • Kernel

    Saatavuus: iPhone 3GS ja uudemmat, iPod touch (4. sukupolvi) ja uudemmat sekä iPad 2 ja uudemmat.

    Vaikutus: Haitalliset tai vaarantuneet iOS-ohjelmat saattoivat pystyä selvittämään osoitteita kernelissä.

    Kuvaus: Kernel-laajennuksiin liittyvien API-ohjelmointirajapintojen käsittelyssä oli tietojen paljastumiseen liittyvä ongelma. OSBundleMachOHeaders-avaimen sisältävissä vastauksissa saattoi olla kernel-osoitteita, jotka voivat auttaa ohittamaan osoiteavaruuden asettelun satunnaistamissuojauksen. Ongelma on korjattu vapauttamalla osoitteet ennen niiden palauttamista.

    CVE-ID

    CVE-2012-3749: Azimuth Securityn Mark Dowd, Squaren Eric Monti ja muita nimettömiä tutkijoita

  • Pääsykoodi

    Saatavuus: iPhone 3GS ja uudemmat, iPod touch (4. sukupolvi) ja uudemmat, iPad 2 ja uudemmat.

    Vaikutus: Henkilö, jolla oli fyysinen pääsy laitteeseen, saattoi päästä käsiksi Passbook-kortteihin antamatta pääsykoodia.

    Kuvaus: Passbook-korttien käsittelyssä lukitusnäytöllä oli tilanhallintaongelma. Ongelma on korjattu parantamalla Passbook-korttien käsittelyä.

    CVE-ID

    CVE-2012-3750: Anton Tsviatkou

  • WebKit

    Saatavuus: iPhone 3GS ja uudemmat, iPod touch (4. sukupolvi) ja uudemmat sekä iPad 2 ja uudemmat.

    Vaikutus: Haitallisella verkkosivustolla käynti saattoi johtaa ohjelman odottamattomaan sulkeutumiseen tai mielivaltaisen koodin suorittamiseen.

    Kuvaus: JavaScript-matriisien käsittelyssä oli tarkistusajasta käyttöaikaan -ongelma. Ongelma on korjattu JavaScript-matriisien lisätarkistuksella.

    CVE-ID

    CVE-2012-3748: HP TippingPointin Zero Day Initiativen parissa työskentelevät Certified Securen Joost Pol ja Daan Keuper

  • WebKit

    Saatavuus: iPhone 3GS ja uudemmat, iPod touch (4. sukupolvi) ja uudemmat sekä iPad 2 ja uudemmat.

    Vaikutus: Haitallisella verkkosivustolla käynti saattoi johtaa ohjelman odottamattomaan sulkeutumiseen tai mielivaltaisen koodin suorittamiseen.

    Kuvaus: SVG-kuvien käsittelyssä oli use after free -ongelma. Ongelma on korjattu parantamalla muistin hallintaa.

    CVE-ID

    CVE-2012-5112: Googlen Pwnium 2 -kilpailun parissa työskentelevä Pinkie Pie

Muita kuin Applen valmistamia tuotteita sekä itsenäisiä verkkosivustoja (joita Apple ei hallitse tai joita se ei ole testannut) koskevat tiedot on tarkoitettu vain tiedoksi. Apple ei suosittele tai tue niitä. Apple ei vastaa muun valmistajan verkkosivustojen tai tuotteiden valikoimasta, suorituskyvystä tai käytöstä. Apple ei vastaa muun valmistajan verkkosivuston oikeellisuudesta tai luotettavuudesta. Internetin käyttöön liittyy riskejä. Pyydä lisätietoja valmistajalta. Muut yritysten ja tuotteiden nimet saattavat olla omistajiensa tavaramerkkejä.

Julkaisupäivämäärä: