Acerca del contenido de seguridad de iOS 9.3.3

En este documento se describe el contenido de seguridad de iOS 9.3.3.

Acerca de las actualizaciones de seguridad de Apple

Con el fin de proteger a nuestros clientes, Apple no revelará, discutirá ni confirmará problemas de seguridad hasta que se haya llevado a cabo una investigación y estén disponibles las correcciones o versiones correspondientes. Las versiones más recientes se pueden encontrar en la página Actualizaciones de seguridad de Apple.

Para obtener más información sobre la seguridad, consulta la página de seguridad de los productos Apple. Puedes encriptar las comunicaciones con Apple mediante la clave PGP de seguridad de los productos Apple.

Para hacer referencia a las vulnerabilidades en los documentos de seguridad de Apple, se usan ID CVE siempre que sea posible.

iOS 9.3.3

Fecha de lanzamiento: 18 de julio de 2016

Calendario

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Una invitación del calendario creada con fines malintencionados podía causar que un dispositivo se reiniciara de manera inesperada.

Descripción: Se solucionó un problema de falta de referencia de puntero nulo mejorando el manejo de la memoria.

CVE-2016-4605: Dr. Henry Feldman en Beth Israel Deaconess Medical Center

Credenciales CFNetwork

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante con una posición de red privilegiada podía divulgar información confidencial del usuario.

Descripción: Existía un problema de reducción con las credenciales de autenticación HTTP guardadas en el llavero. Este problema se solucionó almacenando los tipos de autenticación con las credenciales.

CVE-2016-4644: Jerry Decime coordinado a través de CERT

Proxies de CFNetwork

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante con una posición de red privilegiada podía divulgar información confidencial del usuario.

Descripción: Existía un problema de validación en el análisis de 407 respuestas. Este problema se solucionó mejorando la validación de respuesta.

CVE-2016-4643: Xiaofeng Zheng del equipo Blue Lotus, Universidad Tsinghua; Jerry Decime coordinado a través de CERT

Proxies de CFNetwork

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Una app podía enviar sin conocimiento una contraseña encriptada a través de la red.

Descripción: La autenticación de proxy informaba incorrectamente que los proxies HTTP recibían credenciales de manera segura. Para solucionar este problema, se mejoró la advertencia.

CVE-2016-4642: Jerry Decime coordinado a través de CERT

CoreGraphics

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante remoto podía ejecutar código arbitrario.

Descripción: Se solucionó un problema de daños en la memoria mejorando el manejo de la memoria.

CVE-2016-4637: Tyler Bohan de Cisco Talos (talosintel.com/vulnerability-reports)

FaceTime

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante con una posición de red privilegiada podía causar que una llamada transmitida siguiera transmitiendo audio aunque la llamada apareciera como si hubiera finalizado.

Descripción: Existían inconsistencias de interfaz del usuario en el manejo de las llamadas transmitidas. Para solucionar estos problemas, se mejoró la lógica de visualización de FaceTime.

CVE-2016-4635: Martin Vigo

GasGauge

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Una app malintencionada podía ejecutar código arbitrario con privilegios del kernel.

Descripción: Existía un problema de daños en la memoria del kernel. Este problema se solucionó mejorando el manejo de la memoria.

CVE-2016-7576: qwertyoruiop

Entrada agregada el 27 de septiembre de 2016

ImageIO

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante remoto podía provocar una denegación de servicio.

Descripción: Se solucionó un problema de consumo de memoria mejorando el manejo de la memoria.

CVE-2016-4632: Evgeny Sidorov de Yandex

ImageIO

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante remoto podía ejecutar código arbitrario.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2016-4631: Tyler Bohan de Cisco Talos (talosintel.com/vulnerability-reports)

ImageIO

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: El procesamiento de una imagen creada con fines malintencionados podía ocasionar la ejecución de código arbitrario.

Descripción: Se solucionó un problema de daños en la memoria mejorando el manejo de la memoria.

CVE-2016-7705: Craig Young de Tripwire VERT

Entrada agregada el 30 de noviembre de 2017

IOAcceleratorFamily

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un usuario local podía leer la memoria del kernel.

Descripción: Se solucionó un problema de lectura fuera de los límites mejorando la comprobación de límites.

CVE-2016-4628: Ju Zhu de Trend Micro

IOAcceleratorFamily

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un usuario local podía ejecutar código arbitrario con privilegios del kernel.

Descripción: Se solucionó el problema de falta de referencia de puntero nulo mejorando la validación.

CVE-2016-4627: Ju Zhu de Trend Micro

IOHIDFamily

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un usuario local podía ejecutar código arbitrario con privilegios del kernel.

Descripción: Se solucionó un problema de falta de referencia de puntero nulo mejorando la validación de entradas.

CVE-2016-4626: Stefan Esser de SektionEins

Kernel

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un usuario local podía ejecutar código arbitrario con privilegios del kernel.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2016-1863: Ian Beer de Google Project Zero

CVE-2016-4653: Ju Zhu de Trend Micro

CVE-2016-4582: Shrek_wzw y Proteas de Qihoo 360 Nirvan Team

Kernel

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un usuario local podía provocar una denegación de servicio del sistema.

Descripción: Se solucionó un problema de falta de referencia de puntero nulo mejorando la validación de entradas.

CVE-2016-1865: CESG, Marco Grassi (@marcograss) de KeenLab (@keen_lab), Tencent

Libc

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un atacante remoto podía ocasionar el cierre inesperado de una app o la ejecución de código arbitrario.

Descripción: Existía un desbordamiento del búfer dentro de la función "link_ntoa()" en linkaddr.c. Este problema se solucionó mediante comprobaciones de límites adicionales.

CVE-2016-6559: Apple

Entrada agregada el 10 de enero de 2017

libxml2

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Varias vulnerabilidades en libxml2.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2015-8317: Hanno Boeck

CVE-2016-1836: Wei Lei y Liu Yang de la Universidad Tecnológica de Nanyang

CVE-2016-4447: Wei Lei y Liu Yang de la Universidad Tecnológica de Nanyang

CVE-2016-4448: Apple

CVE-2016-4483: Gustavo Grieco

CVE-2016-4614: Nick Wellnhofer

CVE-2016-4615: Nick Wellnhofer

CVE-2016-4616: Michael Paddon

Entrada actualizada el 4 de junio de 2017

libxml2

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: El análisis de un documento XML creado con fines malintencionados podía provocar la divulgación de información del usuario.

Descripción: Existía un problema de acceso en el análisis de archivos XML creados con códigos malintencionados. Este problema se solucionó mejorando la validación de entradas.

CVE-2016-4449: Kostya Serebryany

libxslt

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Existían varias vulnerabilidades en libxslt.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2016-1683: Nicolas Grégoire

CVE-2016-1684: Nicolas Grégoire

CVE-2016-4607: Nick Wellnhofer

CVE-2016-4608: Nicolas Grégoire

CVE-2016-4609: Nick Wellnhofer

CVE-2016-4610: Nick Wellnhofer

Entrada actualizada el 11 de abril de 2017

Safari

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la suplantación de la interfaz del usuario.

Descripción: La redirección de respuestas podría haber permitido a un sitio web creado con fines malintencionados mostrar un dominio arbitrario mientras mostraba contenido arbitrario. Este problema se solucionó mejorando la lógica de visualización de las URL.

CVE-2016-4604: xisigr de Tencent's Xuanwu Lab (www.tencent.com)

Perfiles de zona protegida

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Una app local podía acceder a la lista de procesos.

Descripción: Existía un problema de acceso con las llamadas de API privilegiadas. Este problema se solucionó mediante restricciones adicionales.

CVE-2016-4594: Stefan Esser de SektionEins

Contactos de Siri

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Una persona con acceso físico a un dispositivo podía ver información privada de contactos.

Descripción: Existía un problema de privacidad en la administración de las tarjetas de contactos. Este problema se solucionó mejorando la administración de estado.

CVE-2016-4593: Pedro Pinheiro (facebook.com/pedro.pinheiro.1996)

Contenido multimedia web

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Al ver un video en el modo de navegación privada de Safari, aparece la dirección URL del video fuera del modo de navegación privada.

Descripción: Existía un problema de privacidad en el manejo de los datos del usuario en el controlador de visualización de Safari. Este problema se solucionó mejorando la administración de estado.

CVE-2016-4603: Brian Porter (@portex33)

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la divulgación de la memoria de procesos.

Descripción: Un problema de inicialización de la memoria se solucionó mejorando el manejo de la memoria.

CVE-2016-4587: Apple

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la divulgación de datos de imágenes de otro sitio web.

Descripción: Existía un problema de temporización en el procesamiento de SVG. Este problema se solucionó mejorando la validación.

CVE-2016-4583: Roeland Krak

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Al visitar un sitio web creado con fines malintencionados, se podía filtrar información confidencial.

Descripción: Existía un problema de permisos en el manejo de la variable de ubicación. El problema se solucionó mediante comprobaciones de propiedad adicionales.

CVE-2016-4591: ma.la de LINE Corporation

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la ejecución de código arbitrario.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2016-4589: Tongbo Luo y Bo Qu de Palo Alto Networks

CVE-2016-4622: Samuel Gross en colaboración con la iniciativa Zero Day de Trend Micro

CVE-2016-4623: Apple

CVE-2016-4624: Apple

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la suplantación de la interfaz del usuario.

Descripción: Existía un problema de herencia de origen en el análisis de las URL “about:”. Este problema se solucionó mejorando la validación de los orígenes de seguridad.

CVE-2016-4590: xisigr de Tencent's Xuanwu Lab (www.tencent.com)

WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar una página web creada con fines malintencionados podía ocasionar una denegación de servicio por parte del sistema.

Descripción: Se solucionó un problema de consumo de memoria mejorando el manejo de la memoria.

CVE-2016-4592: Mikhail

Enlaces de JavaScript de WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la ejecución de secuencias de comandos en el contexto de un servicio que no fuera HTTP.

Descripción: Existía un problema de secuencias de comandos de protocolos cruzados y sitios cruzados (XPXSS) en Safari al enviar formularios a servicios que no fueran HTTP compatibles con HTTP/0.9. Este problema se solucionó desactivando las secuencias de comandos y los módulos en los recursos cargados mediante HTTP/0.9.

CVE-2016-4651: Obscure

Carga de la página WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Un sitio web malintencionado podía exfiltrar datos mediante un origen cruzado.

Descripción: Existía un problema de secuencias de comandos de sitios cruzados en la redirección de las URL de Safari. Este problema se solucionó mejorando la validación de las URL en la redirección.

CVE-2016-4585: Takeshi Terada de Mitsui Bussan Secure Directions, Inc. (www.mbsd.jp)

Carga de la página WebKit

Disponible para iPhone 4s y posteriores, iPod touch (quinta generación y posteriores) y iPad 2 y posteriores.

Impacto: Visitar un sitio web creado con fines malintencionados podía provocar la ejecución de código arbitrario.

Descripción: Se solucionaron varios problemas de daño en la memoria mejorando el manejo de la memoria.

CVE-2016-4584: Chris Vienneau

La información acerca de los productos no fabricados por Apple o la de los sitios web independientes no controlados o probados por Apple se ofrece sin ninguna recomendación o aprobación. Apple no asume ninguna responsabilidad respecto a la selección, el rendimiento o el uso de los sitios web o productos de otros fabricantes. Apple no ofrece ninguna representación con relación a la precisión o fiabilidad de los sitios web de terceros. El uso de Internet conlleva riesgos inherentes. Comunícate con el proveedor para obtener información adicional. Otros nombres de compañías y productos mencionados pueden ser marcas registradas de sus respectivos propietarios.

Fecha de publicación: