If you get a message that PowerPC applications are no longer supported on your Mac

You're attempting to open a PowerPC application that isn't compatible with your version of the Mac operating system.

If you try to open a PowerPC-based application, you might see a message that you can't open the application because PowerPC applications are no longer supported. You might also see a prohibitory sign over the icon of the application in the Finder.

Contact the maker of the application for a version that is compatible with your macOS version.

Published Date: