Import split stereo audio files in Logic Pro X

Depending on how you import split stereo audio files in Logic Pro X, your audio might be converted to interleaved stereo, split stereo, or dual mono.

Use these steps to determine how your stereo audio files are imported. Split stereo audio files are displayed as interleaved if you don't convert them.

Split stereo

If you want the leave the stereo format as split, use one of these import methods:

  • Drag the audio file directly into the Tracks area from the Finder.
  • Add the audio file to an Audio track in the Tracks area by clicking with the Pencil tool.
  • Drag the audio file into the Project Audio window from the Finder.
  • Drag the audio file into the Browsers > Project Audio tab from the Finder.

Interleaved stereo

If you want to convert split stereo audio files to interleaved stereo:

  • Open the Project Audio window and choose Audio File > Add Audio File.
  • Click the Browsers button in the Main window, then click the Project tab. Choose Audio File > Add Audio File.

Split stereo SDII files are never converted to interleaved stereo during import. If you want to convert them to interleaved, use the Project Audio > Audio File > Copy/Convert File(s) command to convert them to AIFF, WAV, or CAF files with an interleaved stereo format after you import them.

Dual mono

If you want split stereo audio files to be displayed as dual mono regions, be sure the audio file names are different before the L and R file extension in each file name.

For example, if two files are named "Split.L.aif" and "Split.R.aif" then Logic Pro X imports them as an interleaved stereo file. If you rename them to "Split1.R.aif" and "Split2.L.aif" then Logic Pro X imports and displays these files as individual mono files.

Last Modified: