Use layered graphics files in Final Cut Pro X

Learn how to get the best results when using layered graphics files in your Final Cut Pro X project.

In Final Cut Pro X 10.0.3 and later, you can add a layered graphics file such as an Adobe Photoshop (PSD) file to your Final Cut Pro project, and then edit it as a connected clip in the Timeline.

This article explains how to create the file to get the best results for use in your project, and how to change the duration of the file and resize it once it's in your project.

Create a layered graphics file

You can create a layered graphics file for use in Final Cut Pro in an application such as Adobe Photoshop. Follow these guidelines when creating the file to get the best results.

Color mode

Create the file in 8-bit RGB Color mode. If you try to import a file with a different Color mode into your Final Cut Pro project:

  • Layers in a file created in 16-bit Color mode import flattened. Create the file in 8-bit RGB mode to maintain the file's layers in your project.
  • A file created in 32-bit Color mode will not import.
  • A file in a color mode such as CMYK Color, Lab Color, or Bitmap will not import.

Frame size

Create the file at a frame size compatible with the television or film pixel dimensions used in the Final Cut Pro project. Photoshop, for example, has presets for common video and film pixel dimensions.

Photoshop adjustment layers

Flatten any Photoshop adjustment layers prior to importing the file into Final Cut Pro. You can save a copy of the file with adjustments layers flattened for use in Final Cut Pro, and also keep a master version of the file with the adjustment layers intact. This allows you to make further changes to the adjustment layers if necessary.

Photoshop blend modes

If the file includes blend modes, for best results use blend modes in Photoshop that have equivalent Final Cut Pro blend modes.

Visible and hidden layers

If a file includes visible and hidden layers, they are enabled and disabled accordingly when added to the Timeline of your project. You can enable and disable a layer in Final Cut Pro by selecting the layer in the Timeline and pressing the V key.

Embedded color profiles

Final Cut Pro recognizes the embedded color profile of a layered graphics file, if the file was saved with one. To view the embedded color profile of a file in Final Cut Pro:

  1. Select the file.
  2. Choose Window > Go To > Inspector.
  3. Click the Info button at the top of the inspector.
  4. Choose Extended from the Metadata pop-up menu.
  5. Scroll in the inspector to view the Color profile metadata field.

Change the duration of a layered graphics file

By default, Final Cut Pro sets the duration of a layered graphics file to one minute. You can change the duration of the file in the Browser, so the file maintains that length when used in other libraries or projects.

To change the duration of a layered graphics file:

  1. Control-click the layered graphics file and choose Open Clip from the menu. The file opens in its own Timeline showing the individual layers.
  2. Choose Edit > Select All to select all layers.
  3. Choose Modify > Change Duration. The timecode entry field appears in the Dashboard.
  4. Type in the duration, then press Enter. Final Cut Pro supports durations of up to 24 hours. 

Resize a layered graphics file

  1. Select the file and choose Window > Go To > Inspector. 
  2. Click the Video button at the top of the inspector.
  3. Do any of the following to resize the file:

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information. Other company and product names may be trademarks of their respective owners.

Published Date: