
<!DOCTYPE html>
    <html lang="en" prefix="og: http://ogp.me/ns#" dir="ltr">
        <head>
            <meta http-equiv="X-UA-Compatible" content="IE=edge" />
            <meta name="viewport" content="width=device-width, initial-scale=1" />
            <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
            <title lang="en">How to create a bootable installer for macOS - Apple Support</title>
            <link rel="dns-prefetch" href="https://www.apple.com/" />
            <link rel="preconnect" href="https://www.apple.com/" crossorigin />

            
            <link rel="canonical" href="https://support.apple.com/en-us/HT201372" />
            
                
                    <link rel="alternate" hreflang="en-ie" href="https://support.apple.com/en-ie/HT201372">
                
                    <link rel="alternate" hreflang="ar-kw" href="https://support.apple.com/ar-kw/HT201372">
                
                    <link rel="alternate" hreflang="en-il" href="https://support.apple.com/en-il/HT201372">
                
                    <link rel="alternate" hreflang="en-in" href="https://support.apple.com/en-in/HT201372">
                
                    <link rel="alternate" hreflang="en-ae" href="https://support.apple.com/en-ae/HT201372">
                
                    <link rel="alternate" hreflang="en-za" href="https://support.apple.com/en-za/HT201372">
                
                    <link rel="alternate" hreflang="no-no" href="https://support.apple.com/no-no/HT201372">
                
                    <link rel="alternate" hreflang="en-al" href="https://support.apple.com/en-al/HT201372">
                
                    <link rel="alternate" hreflang="en-is" href="https://support.apple.com/en-is/HT201372">
                
                    <link rel="alternate" hreflang="el-gr" href="https://support.apple.com/el-gr/HT201372">
                
                    <link rel="alternate" hreflang="en-am" href="https://support.apple.com/en-am/HT201372">
                
                    <link rel="alternate" hreflang="nl-nl" href="https://support.apple.com/nl-nl/HT201372">
                
                    <link rel="alternate" hreflang="en-au" href="https://support.apple.com/en-au/HT201372">
                
                    <link rel="alternate" hreflang="he-il" href="https://support.apple.com/he-il/HT201372">
                
                    <link rel="alternate" hreflang="hu-hu" href="https://support.apple.com/hu-hu/HT201372">
                
                    <link rel="alternate" hreflang="en-jo" href="https://support.apple.com/en-jo/HT201372">
                
                    <link rel="alternate" hreflang="en-bh" href="https://support.apple.com/en-bh/HT201372">
                
                    <link rel="alternate" hreflang="es-cl" href="https://support.apple.com/es-cl/HT201372">
                
                    <link rel="alternate" hreflang="fr-sn" href="https://support.apple.com/fr-sn/HT201372">
                
                    <link rel="alternate" hreflang="fr-ca" href="https://support.apple.com/fr-ca/HT201372">
                
                    <link rel="alternate" hreflang="es-co" href="https://support.apple.com/es-co/HT201372">
                
                    <link rel="alternate" hreflang="pl-pl" href="https://support.apple.com/pl-pl/HT201372">
                
                    <link rel="alternate" hreflang="en-bn" href="https://support.apple.com/en-bn/HT201372">
                
                    <link rel="alternate" hreflang="pt-pt" href="https://support.apple.com/pt-pt/HT201372">
                
                    <link rel="alternate" hreflang="en-sa" href="https://support.apple.com/en-sa/HT201372">
                
                    <link rel="alternate" hreflang="fr-be" href="https://support.apple.com/fr-be/HT201372">
                
                    <link rel="alternate" hreflang="ar-eg" href="https://support.apple.com/ar-eg/HT201372">
                
                    <link rel="alternate" hreflang="en-bw" href="https://support.apple.com/en-bw/HT201372">
                
                    <link rel="alternate" hreflang="en-sg" href="https://support.apple.com/en-sg/HT201372">
                
                    <link rel="alternate" hreflang="en-ke" href="https://support.apple.com/en-ke/HT201372">
                
                    <link rel="alternate" hreflang="hr-hr" href="https://support.apple.com/hr-hr/HT201372">
                
                    <link rel="alternate" hreflang="en-om" href="https://support.apple.com/en-om/HT201372">
                
                    <link rel="alternate" hreflang="zh-mo" href="https://support.apple.com/zh-mo/HT201372">
                
                    <link rel="alternate" hreflang="de-at" href="https://support.apple.com/de-at/HT201372">
                
                    <link rel="alternate" hreflang="en-gu" href="https://support.apple.com/en-gu/HT201372">
                
                    <link rel="alternate" hreflang="en-gw" href="https://support.apple.com/en-gw/HT201372">
                
                    <link rel="alternate" hreflang="fr-gn" href="https://support.apple.com/fr-gn/HT201372">
                
                    <link rel="alternate" hreflang="fr-gq" href="https://support.apple.com/fr-gq/HT201372">
                
                    <link rel="alternate" hreflang="cs-cz" href="https://support.apple.com/cs-cz/HT201372">
                
                    <link rel="alternate" hreflang="en-ph" href="https://support.apple.com/en-ph/HT201372">
                
                    <link rel="alternate" hreflang="zh-tw" href="https://support.apple.com/zh-tw/HT201372">
                
                    <link rel="alternate" hreflang="ko-kr" href="https://support.apple.com/ko-kr/HT201372">
                
                    <link rel="alternate" hreflang="en-hk" href="https://support.apple.com/en-hk/HT201372">
                
                    <link rel="alternate" hreflang="sk-sk" href="https://support.apple.com/sk-sk/HT201372">
                
                    <link rel="alternate" hreflang="ru-ru" href="https://support.apple.com/ru-ru/HT201372">
                
                    <link rel="alternate" hreflang="en-qa" href="https://support.apple.com/en-qa/HT201372">
                
                    <link rel="alternate" hreflang="sv-se" href="https://support.apple.com/sv-se/HT201372">
                
                    <link rel="alternate" hreflang="da-dk" href="https://support.apple.com/da-dk/HT201372">
                
                    <link rel="alternate" hreflang="en-us" href="https://support.apple.com/en-us/HT201372">
                
                    <link rel="alternate" hreflang="en-mk" href="https://support.apple.com/en-mk/HT201372">
                
                    <link rel="alternate" hreflang="en-mn" href="https://support.apple.com/en-mn/HT201372">
                
                    <link rel="alternate" hreflang="en-eg" href="https://support.apple.com/en-eg/HT201372">
                
                    <link rel="alternate" hreflang="en-mo" href="https://support.apple.com/en-mo/HT201372">
                
                    <link rel="alternate" hreflang="fr-ne" href="https://support.apple.com/fr-ne/HT201372">
                
                    <link rel="alternate" hreflang="en-mt" href="https://support.apple.com/en-mt/HT201372">
                
                    <link rel="alternate" hreflang="nl-be" href="https://support.apple.com/nl-be/HT201372">
                
                    <link rel="alternate" hreflang="zh-cn" href="https://support.apple.com/zh-cn/HT201372">
                
                    <link rel="alternate" hreflang="en-mz" href="https://support.apple.com/en-mz/HT201372">
                
                    <link rel="alternate" hreflang="fr-ml" href="https://support.apple.com/fr-ml/HT201372">
                
                    <link rel="alternate" hreflang="en-my" href="https://support.apple.com/en-my/HT201372">
                
                    <link rel="alternate" hreflang="fr-mu" href="https://support.apple.com/fr-mu/HT201372">
                
                    <link rel="alternate" hreflang="en-ng" href="https://support.apple.com/en-ng/HT201372">
                
                    <link rel="alternate" hreflang="el-cy" href="https://support.apple.com/el-cy/HT201372">
                
                    <link rel="alternate" hreflang="en-vn" href="https://support.apple.com/en-vn/HT201372">
                
                    <link rel="alternate" hreflang="ja-jp" href="https://support.apple.com/ja-jp/HT201372">
                
                    <link rel="alternate" hreflang="de-ch" href="https://support.apple.com/de-ch/HT201372">
                
                    <link rel="alternate" hreflang="en-nz" href="https://support.apple.com/en-nz/HT201372">
                
                    <link rel="alternate" hreflang="ro-ro" href="https://support.apple.com/ro-ro/HT201372">
                
                    <link rel="alternate" hreflang="it-ch" href="https://support.apple.com/it-ch/HT201372">
                
                    <link rel="alternate" hreflang="tr-tr" href="https://support.apple.com/tr-tr/HT201372">
                
                    <link rel="alternate" hreflang="fr-fr" href="https://support.apple.com/fr-fr/HT201372">
                
                    <link rel="alternate" hreflang="en-gb" href="https://support.apple.com/en-gb/HT201372">
                
                    <link rel="alternate" hreflang="fi-fi" href="https://support.apple.com/fi-fi/HT201372">
                
                    <link rel="alternate" hreflang="en-ca" href="https://support.apple.com/en-ca/HT201372">
                
                    <link rel="alternate" hreflang="fr-tn" href="https://support.apple.com/fr-tn/HT201372">
                
                    <link rel="alternate" hreflang="ar-ae" href="https://support.apple.com/ar-ae/HT201372">
                
                    <link rel="alternate" hreflang="en-kw" href="https://support.apple.com/en-kw/HT201372">
                
                    <link rel="alternate" hreflang="fr-cf" href="https://support.apple.com/fr-cf/HT201372">
                
                    <link rel="alternate" hreflang="fr-ci" href="https://support.apple.com/fr-ci/HT201372">
                
                    <link rel="alternate" hreflang="fr-ch" href="https://support.apple.com/fr-ch/HT201372">
                
                    <link rel="alternate" hreflang="es-us" href="https://support.apple.com/es-us/HT201372">
                
                    <link rel="alternate" hreflang="fr-cm" href="https://support.apple.com/fr-cm/HT201372">
                
                    <link rel="alternate" hreflang="en-lb" href="https://support.apple.com/en-lb/HT201372">
                
                    <link rel="alternate" hreflang="ar-sa" href="https://support.apple.com/ar-sa/HT201372">
                
                    <link rel="alternate" hreflang="de-de" href="https://support.apple.com/de-de/HT201372">
                
                    <link rel="alternate" hreflang="en-lk" href="https://support.apple.com/en-lk/HT201372">
                
                    <link rel="alternate" hreflang="fr-ma" href="https://support.apple.com/fr-ma/HT201372">
                
                    <link rel="alternate" hreflang="zh-hk" href="https://support.apple.com/zh-hk/HT201372">
                
                    <link rel="alternate" hreflang="pt-br" href="https://support.apple.com/pt-br/HT201372">
                
                    <link rel="alternate" hreflang="de-li" href="https://support.apple.com/de-li/HT201372">
                
                    <link rel="alternate" hreflang="ar-bh" href="https://support.apple.com/ar-bh/HT201372">
                
                    <link rel="alternate" hreflang="es-es" href="https://support.apple.com/es-es/HT201372">
                
                    <link rel="alternate" hreflang="fr-mg" href="https://support.apple.com/fr-mg/HT201372">
                
                    <link rel="alternate" hreflang="ar-jo" href="https://support.apple.com/ar-jo/HT201372">
                
                    <link rel="alternate" hreflang="es-mx" href="https://support.apple.com/es-mx/HT201372">
                
                    <link rel="alternate" hreflang="it-it" href="https://support.apple.com/it-it/HT201372">
                
                    <link rel="alternate" hreflang="en-ug" href="https://support.apple.com/en-ug/HT201372">
                
                    <link rel="alternate" hreflang="id-id" href="https://support.apple.com/id-id/HT201372">
                
                    <link rel="alternate" hreflang="de-lu" href="https://support.apple.com/de-lu/HT201372">
                
                    <link rel="alternate" hreflang="en-md" href="https://support.apple.com/en-md/HT201372">
                
                    <link rel="alternate" hreflang="fr-lu" href="https://support.apple.com/fr-lu/HT201372">
                
                    <link rel="alternate" hreflang="en-me" href="https://support.apple.com/en-me/HT201372">
                
                    <link rel="alternate" hreflang="th-th" href="https://support.apple.com/th-th/HT201372">
                 
                   

            
                <meta name="description" content="You can use an external drive or secondary volume as a startup disk from which to install the Mac operating system.

" />
                <meta property="og:url" content="https://support.apple.com/en-us/HT201372" />
                <meta property="og:title" content="How to create a bootable installer for macOS" />
                <meta property="og:description" content="You can use an external drive or secondary volume as a startup disk from which to install the Mac operating system.

" />
                <meta property="og:site_name" content="Apple Support" />
                <meta property="og:locale" content="en_US" />
                <meta property="og:type" content="article" />
                <meta name="ac-gn-search-field[locale]" content="en_US" /> 

                
                    <meta name="twitter:card" content="summary_large_image" />
                    <meta name="twitter:site" content="@AppleSupport" />
                    <meta name="twitter:title" content="How to create a bootable installer for macOS" />
                    <meta name="twitter:description" content="You can use an external drive or secondary volume as a startup disk from which to install the Mac operating system.

"/>
                    <meta name="twitter:image" content="https://support.apple.com/library/content/dam/edam/applecare/images/en_US/social/open_graph_logo.png" />
                    <meta property="og:image"  content="https://support.apple.com/library/content/dam/edam/applecare/images/en_US/social/open_graph_logo.png" />
                    <meta property="og:image:width" content="630" />
                    <meta property="og:image:height" content="1200" />
                

                <script type="application/ld+json">{ "@context": "https://ziyuan.baidu.com/contexts/cambrian.jsonld","@id":"https://support.apple.com/en-us/HT201372","appid": "1583465330249689","title":"How to create a boo","pubDate":"2014-11-04T02:08:58","upDate":"2020-03-12T06:07:32","images":"https://support.apple.com/library/content/dam/edam/applecare/images/en_US/social/open_graph_logo.png"}</script>

            

            

            

            
                <link rel="stylesheet" href="https://support.apple.com/clientside/build/app-ht.css" type="text/css" />
            
                <link rel="stylesheet" href="https://www.apple.com/ac/globalfooter/3/en_US/styles/ac-globalfooter.built.css" type="text/css" />
            
                <link rel="stylesheet" href="https://www.apple.com/ac/globalnav/5/en_US/styles/ac-globalnav.built.css" type="text/css" />
            
                <link rel="stylesheet" href="//www.apple.com/wss/fonts?families&#x3D;SF+Pro,v1:200,300,400,500,600|SF+Pro+Icons,v1" type="text/css" />
            
            <script>
    var _applemd = {
        page: {
            site_section: "kb",
            content_type: "ht",
            info_type: "task-using",
            topics: "install os x,developer",
            in_house: "osx,domain",
            locale: "en-us",
            friendly_content: {
                title: "How to create a bootable installer for macOS",
                
                    content_id: "HT201372",
                    status: "unarchieved",
                    version: "1.55"
                
            },
            
            
             testandtarget:{
                throttle:"0.0" 
            },
            

             
                product: ["acs::kb::productcategory::macos::macos","acs::kb::productcategory::servers and enterprise",]
            
        },
        eventName : "ht_link.click"
    }
</script>
             
                <script src="/clientside/build/nn.js" type="text/javascript" charset="utf-8"></script>
<script>
    
     var neighborInitData = {
        site: 'SS',
        level1: "KB",
        level2: "HT",
        contentID: "HT201372",
        endpoint: 'https://supportmetrics.apple.com/content/services/stats'
    }

</script>
            
            <script>
                var data = {
                    showHelpFulfeedBack: true,
                    id: "HT201372",
                    locale: "en_US",
                    urlLocale: "en-us",
                    isPreview : false,
                    productCategories : "PF6,PF20,PL166",
                    source : "",
                    channel : "HOWTO_ARTICLES",
                    bizChatLink : "https://bcrw.apple.com/urn:biz:b15ed773-9eed-11e7-baa2-7b88b04daa8e",
                    bizChatIntentId : "ContactApple",
                    bizChatGroupId : "%7B%22domain%22:%20%22AC%22,%22origin%22:%20%22OLS%22,%22page%22:%20%22acs::kb::ht::ARTICLEID::contact%20apple%20for%20support%20and%20service%20(en-us)%22%7D",
                    bizChatBody : "%3Cstrong%3EChat using Messages%3C/strong%3E %3Cbr%3E Have a question? Ask now.",
                    bizChatSupportedCountries : "US",
                    bizChatthrottleValue : 0.0,
                    bypassBizChat: false,
                    akamaiEdgeScapeURL: "https://support.apple.com/edge-sight",
                    isNeighborJsEnabled: true,
                    isOkapiEnabled: false
                }
                window.appState = JSON.stringify(data);

                document.cookie = 'POD=us~en; path=/; domain=.apple.com; expires='+new Date(Date.now() + (28 * 24 * 60 * 60 * 1000)).toGMTString();
            </script>
        </head>
        <body class="ac-gn-current-support no-js"  itemscope itemtype="https://schema.org/TechArticle" >
        
        

            <meta name="ac-gn-store-key" content="S2A49YFKJF2JAT22K" /><meta name="ac-gn-search-action" content="https://support.apple.com/kb/index" /><meta name="ac-gn-search-input" content="q" /><meta name="ac-gn-search-field[src]" content="globalnav_support" /><meta name="ac-gn-search-field[type]" content="organic" /><meta name="ac-gn-search-field[page]" content="search" /><meta name="ac-gn-search-field[locale]" content="en_US" /><link onerror="headerCssFallback()" rel="stylesheet" type="text/css" href="https://www.apple.com/ac/globalnav/5/en_US/styles/ac-globalnav.built.css"><aside id="ac-gn-segmentbar" class="ac-gn-segmentbar" lang="en-US" dir="ltr" data-strings="{ 'exit': 'Exit', 'view': '{%STOREFRONT%} Store Home', 'segments': { 'smb': 'Business Store Home', 'eduInd': 'Education Store Home', 'other': 'Store Home' } }"></aside><input type="checkbox" id="ac-gn-menustate" class="ac-gn-menustate" /><nav id="ac-globalnav" class="no-js" role="navigation" aria-label="Global" data-hires="false" data-analytics-region="global nav" lang="en-US" dir="ltr" data-www-domain="www.apple.com" data-store-locale="us" data-store-root-path="/us" data-store-api="https://www.apple.com/[storefront]/shop/bag/status" data-search-locale="en_US" data-search-locale="en_US" data-search-suggestions-api="https://www.apple.com/search-services/suggestions/" data-search-defaultlinks-api="https://www.apple.com/search-services/suggestions/defaultlinks/"><div class="ac-gn-content"><ul class="ac-gn-header"><li class="ac-gn-item ac-gn-menuicon"><label class="ac-gn-menuicon-label" for="ac-gn-menustate" aria-hidden="true"><span class="ac-gn-menuicon-bread ac-gn-menuicon-bread-top"><span class="ac-gn-menuicon-bread-crust ac-gn-menuicon-bread-crust-top"></span></span><span class="ac-gn-menuicon-bread ac-gn-menuicon-bread-bottom"><span class="ac-gn-menuicon-bread-crust ac-gn-menuicon-bread-crust-bottom"></span></span></label><a href="#ac-gn-menustate" role="button" class="ac-gn-menuanchor ac-gn-menuanchor-open" id="ac-gn-menuanchor-open"><span class="ac-gn-menuanchor-label">Global Nav Open Menu</span></a><a href="#" role="button" class="ac-gn-menuanchor ac-gn-menuanchor-close" id="ac-gn-menuanchor-close"><span class="ac-gn-menuanchor-label">Global Nav Close Menu</span></a></li><li class="ac-gn-item ac-gn-apple"><a class="ac-gn-link ac-gn-link-apple" href="https://www.apple.com/" data-analytics-title="apple home" id="ac-gn-firstfocus-small"><span class="ac-gn-link-text">Apple</span></a></li><li class="ac-gn-item ac-gn-bag ac-gn-bag-small" id="ac-gn-bag-small"><div class="ac-gn-bag-wrapper"><a class="ac-gn-link ac-gn-link-bag" href="https://www.apple.com/us/shop/goto/bag" data-analytics-title="bag" data-analytics-click="bag" aria-label="Shopping Bag" data-string-badge="Shopping Bag with item count :"><span class="ac-gn-link-text">Shopping Bag</span></a><span class="ac-gn-bag-badge"><span class="ac-gn-bag-badge-separator"></span><span class="ac-gn-bag-badge-number"></span><span class="ac-gn-bag-badge-unit">+</span></span></div><span class="ac-gn-bagview-caret ac-gn-bagview-caret-large"></span></li></ul><div class="ac-gn-search-placeholder-container" role="search"><div class="ac-gn-search ac-gn-search-small"><a id="ac-gn-link-search-small" class="ac-gn-link" href="https://support.apple.com/kb/index?page=search&locale=en_US" data-analytics-title="search" data-analytics-click="search" data-analytics-intrapage-link aria-label="Search Support"><div class="ac-gn-search-placeholder-bar"><div class="ac-gn-search-placeholder-input"><div class="ac-gn-search-placeholder-input-text" aria-hidden="true"><div class="ac-gn-link-search ac-gn-search-placeholder-input-icon"></div><span class="ac-gn-search-placeholder">Search Support</span></div></div><div class="ac-gn-searchview-close ac-gn-searchview-close-small ac-gn-search-placeholder-searchview-close"><span class="ac-gn-searchview-close-cancel" aria-hidden="true">Cancel</span></div></div></a></div></div><ul class="ac-gn-list"><li class="ac-gn-item ac-gn-apple"><a class="ac-gn-link ac-gn-link-apple" href="https://www.apple.com/" data-analytics-title="apple home" id="ac-gn-firstfocus"><span class="ac-gn-link-text">Apple</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-mac"><a class="ac-gn-link ac-gn-link-mac" href="https://www.apple.com/mac/" data-analytics-title="mac"><span class="ac-gn-link-text">Mac</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-ipad"><a class="ac-gn-link ac-gn-link-ipad" href="https://www.apple.com/ipad/" data-analytics-title="ipad"><span class="ac-gn-link-text">iPad</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-iphone"><a class="ac-gn-link ac-gn-link-iphone" href="https://www.apple.com/iphone/" data-analytics-title="iphone"><span class="ac-gn-link-text">iPhone</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-watch"><a class="ac-gn-link ac-gn-link-watch" href="https://www.apple.com/watch/" data-analytics-title="watch"><span class="ac-gn-link-text">Watch</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-tv"><a class="ac-gn-link ac-gn-link-tv" href="https://www.apple.com/tv/" data-analytics-title="tv"><span class="ac-gn-link-text">TV</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-music"><a class="ac-gn-link ac-gn-link-music" href="https://www.apple.com/music/" data-analytics-title="music"><span class="ac-gn-link-text">Music</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-support"><a class="ac-gn-link ac-gn-link-support" href="https://support.apple.com" data-analytics-title="support"><span class="ac-gn-link-text">Support</span></a></li><li class="ac-gn-item ac-gn-item-menu ac-gn-search" role="search"><a id="ac-gn-link-search" class="ac-gn-link ac-gn-link-search" href="https://support.apple.com/kb/index?page=search&locale=en_US" data-analytics-title="search" data-analytics-click="search" data-analytics-intrapage-link aria-label="Search Support"></a></li><li class="ac-gn-item ac-gn-bag" id="ac-gn-bag"><div class="ac-gn-bag-wrapper"><a class="ac-gn-link ac-gn-link-bag" href="https://www.apple.com/us/shop/goto/bag" data-analytics-title="bag" data-analytics-click="bag" aria-label="Shopping Bag" data-string-badge="Shopping Bag with item count : {%BAGITEMCOUNT%}"><span class="ac-gn-link-text">Shopping Bag</span></a><span class="ac-gn-bag-badge" aria-hidden="true"><span class="ac-gn-bag-badge-separator"></span><span class="ac-gn-bag-badge-number"></span><span class="ac-gn-bag-badge-unit">+</span></span></div><span class="ac-gn-bagview-caret ac-gn-bagview-caret-large"></span></li></ul><aside id="ac-gn-searchview" class="ac-gn-searchview" role="search" data-analytics-region="search"><div class="ac-gn-searchview-content"><div class="ac-gn-searchview-bar"><div class="ac-gn-searchview-bar-wrapper"><form id="ac-gn-searchform" class="ac-gn-searchform" action="https://www.apple.com/us/search" method="get"><div class="ac-gn-searchform-wrapper"><input id="ac-gn-searchform-input" class="ac-gn-searchform-input" type="text" aria-label="Search Support" placeholder="Search Support" autocorrect="off" autocapitalize="off" autocomplete="off" spellcheck="false" role="combobox" aria-autocomplete="list" aria-expanded="true" aria-owns="quicklinks suggestions" /><input id="ac-gn-searchform-src" type="hidden" name="src" value="globalnav" /><button id="ac-gn-searchform-submit" class="ac-gn-searchform-submit" type="submit" disabled aria-label="Submit Search"></button><button id="ac-gn-searchform-reset" class="ac-gn-searchform-reset" type="reset" disabled aria-label="Clear Search"><span class="ac-gn-searchform-reset-background"></span></button></div></form><button id="ac-gn-searchview-close-small" class="ac-gn-searchview-close ac-gn-searchview-close-small" aria-label="Cancel Search"><span class="ac-gn-searchview-close-cancel" aria-hidden="true">Cancel</span></button></div></div><aside id="ac-gn-searchresults" class="ac-gn-searchresults" data-string-quicklinks="Quick Links" data-string-suggestions="Suggested Searches" data-string-noresults=""></aside></div><button id="ac-gn-searchview-close" class="ac-gn-searchview-close" aria-label="Cancel Search"><span class="ac-gn-searchview-close-wrapper"><span class="ac-gn-searchview-close-left"></span><span class="ac-gn-searchview-close-right"></span></span></button></aside><aside class="ac-gn-bagview" data-analytics-region="bag"><div class="ac-gn-bagview-scrim"><span class="ac-gn-bagview-caret ac-gn-bagview-caret-small"></span></div><div class="ac-gn-bagview-content" id="ac-gn-bagview-content"></div></aside></div></nav><div class="ac-gn-blur"></div><div id="ac-gn-curtain" class="ac-gn-curtain"></div><div id="ac-gn-placeholder" class="ac-nav-placeholder"></div>

            <div id="app">
                <div >
                    <section class="section section-content">
                        <div>
                            <div class="column small-12 medium-12 large-12 large-centered text-center">
                                <div class="main" role="main" id="howto-section">
                                    <div id="content" >
                                        
                                        <h1  id="howto-title" itemprop='headline'>How to create a bootable installer for macOS</h1>
                                        <div class="intro"><p>You can use an external drive or secondary volume as a startup disk from which to install the Mac operating system.</p>

</div>
                                        
                                        <div itemprop='author' itemscope itemtype='http://schema.org/Organization'>
                                            <meta itemprop='name' content='Apple' />
                                        </div>
                                        <div id="sections" itemprop="articleBody">
                                            
    
        <div >
    

    
            
            <div  ><p>These advanced steps are primarily for system administrators and others who are familiar with the command line.&nbsp;You don't need a bootable installer to&nbsp;<a href="https://support.apple.com/kb/HT201475">upgrade macOS</a>&nbsp;or <a href="https://support.apple.com/kb/HT204904">reinstall macOS</a>, but it can be useful when you want to install on multiple computers without downloading the installer each time.</p>

</div>
            
        </div>

    
        <div >
    

    
            <h2 id="download">Download macOS</h2>
            <div  ><p>Find the appropriate download link in the upgrade instructions for each macOS version:</p>
<p><strong><a href="https://support.apple.com/kb/HT201475">macOS Catalina</a>,&nbsp;<a href="https://support.apple.com/kb/HT210190">macOS Mojave</a>, </strong>or<strong>&nbsp;<a href="https://support.apple.com/kb/HT208969">macOS High Sierra<br>
 </a></strong>Installers for each of these macOS versions download directly to your Applications folder as an app named Install macOS Catalina, Install macOS Mojave, or Install macOS High Sierra.&nbsp;If the installer opens after downloading, quit it without continuing installation. <strong>Important</strong>: To get the correct installer, download from a Mac that is using&nbsp;<a href="https://support.apple.com/kb/HT201260">macOS Sierra 10.12.5 or later</a>, or El Capitan 10.11.6. Enterprise administrators, please download from Apple, not a locally hosted software-update server.&nbsp;</p>
<p><strong><a href="https://support.apple.com/kb/HT206886">OS X El Capitan</a></strong><mark><br>
 </mark>El Capitan downloads as a disk image.&nbsp;<strong>On a Mac that is compatible with El Capitan</strong>, open the disk image and run the installer within, named InstallMacOSX.pkg. It installs an&nbsp;app named&nbsp;Install OS&nbsp;X El Capitan into your Applications folder. You will create the bootable installer from this app, not from the disk image or .pkg installer.</p>

</div>
            
        </div>

    
        <div >
    

    
            <h2 id="create">Use the 'createinstallmedia' command in Terminal</h2>
            <div  ><ol>
<li>Connect the USB flash drive or other volume that you're using for the bootable installer. Make sure that it has at least 12GB of available storage and is <a href="https://support.apple.com/kb/HT208496">formatted as Mac OS Extended</a>.</li>
<li>Open Terminal, which is in the Utilities folder of your Applications folder.</li>
<li>Type or paste one of the following commands in Terminal. These assume that the installer&nbsp;is still in your Applications folder, and MyVolume is the name of the USB flash drive or other volume you're using. If it has a different name, replace <code><var>MyVolume</var></code>&nbsp;in these commands with the name of your volume.<br>
<br>
<strong>Catalina</strong>:*<br>
<pre>
<span class="note">sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/<var>MyVolume</var>
</pre>
<br>
<strong>Mojave</strong>:*<mark><br>
 </mark><pre>
<span class="note">sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/<var>MyVolume</var>
</pre>
<br>
<strong>High Sierra</strong>:*<br>
<pre>
<span class="note">sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/<var>MyVolume</var>
</pre>
<br>
<strong>El Capitan</strong>:<br>
<pre>
<span class="note">sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/<var>MyVolume</var> --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app</span>
</pre>
<br>
</li>
<li>Press Return after typing the command.</li>
<li>When prompted, type your administrator password and press Return again. Terminal doesn't show any characters as you type your password.</li>
<li>When prompted, type&nbsp;<code>Y</code>&nbsp;to confirm that you want to erase the volume, then press Return. Terminal shows the progress as the bootable installer is created. &nbsp;</li>
<li>When Terminal says that it's done, the volume will have the same name as the installer you downloaded, such as Install macOS Catalina. You can now quit Terminal and eject the volume.</li>
</ol>
<p><img alt="" src="/library/content/dam/edam/applecare/images/en_US/macos/macos-high-sierra-terminal-create-bootable-installer.png" width="600"></p>
<p><span class="note">* If your Mac is using macOS Sierra or earlier, include the&nbsp;<code>--applicationpath</code>&nbsp;argument, similar to the way this argument is used in the command for&nbsp;El Capitan.</span></p>

</div>
            
        </div>

    
        <div >
    

    
            <h2 id="use">Use the bootable installer</h2>
            <div  ><p>After <a href="#create">creating the bootable installer</a>, follow these steps to use it:</p>
<ol>
<li>Plug the bootable installer into a <a href="https://support.apple.com/kb/HT201686">compatible Mac</a>.</li>
<li>Use Startup Manager or Startup Disk preferences to&nbsp;select the&nbsp;bootable installer as the startup disk, then start up from it. Your Mac will start up&nbsp;to&nbsp;<a href="https://support.apple.com/kb/HT201314">macOS Recovery</a>.&nbsp;<br>
<span class="note">Learn about&nbsp;<a href="https://support.apple.com/kb/HT202796">selecting a startup disk</a>, including what to do&nbsp;<a href="https://support.apple.com/kb/HT202796#gethelp">if your Mac doesn't start up from it</a>.</span></li>
<li>Choose your language, if prompted.</li>
<li>A bootable installer doesn't download macOS from the Internet, but it does require the Internet to get information specific to your Mac model, such as firmware updates. If you need to connect to a Wi-Fi network, use the Wi-Fi&nbsp;menu&nbsp;<img alt="" src="/library/content/dam/edam/applecare/images/en_US/il/yosemite-disconnected_icon-public.png" width="20">&nbsp;in the menu bar.&nbsp;</li>
<li>Select Install macOS (or Install OS X) from the Utilities window, then click Continue and follow the onscreen instructions.</li>
</ol>

</div>
            
        </div>

    
        <div >
    

    
            <h2>Learn more</h2>
            <div  ><p>For more information about the <code>createinstallmedia</code>&nbsp;command and&nbsp;the arguments that you can use with it,&nbsp;make sure that the macOS installer is in your Applications folder, then enter this path in Terminal:</p>
<p><strong>Catalina</strong>:</p>
<pre>
<span class="note">/Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia</span>
</pre>
<p><strong>Mojave</strong>:</p>
<pre>
<span class="note">/Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia</span>
</pre>
<p><strong>High Sierra</strong>:</p>
<pre>
<span class="note">/Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia</span>
</pre>
<p><strong>El Capitan</strong>:</p>
<pre>
<span class="note">/Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia</span>
</pre>

</div>
            
        </div>


                                        </div>
                                        
                                        
                                            <div class='mod-date'>
                                                <span>Published Date:</span>&nbsp;<time dateTime=2020-03-12 itemprop='datePublished'>March 12, 2020</time>
                                            </div>
                                        
                                    </div>
                                </div>
                            </div>
                        </div>
                    </section>
                </div>
            </div>
            
            <div id='helpful-rating-wrapper'>
                
<div id='helpful' class='ratings okapi-enabled'>
    <div id='question-state' class='show'>
        <fieldset>
            <legend>
                <div id="okapi-a">
                    <span>Helpful?</span>
                </div>
                
            </legend>
            <div class='helpful-btn-grp'>
                <button class='button' id='yes-button' 
                    data-ss-analytics-link-component_name='helpful'
                    data-ss-analytics-link-component_type='helpful'
                    data-ss-analytics-link-text='yes'
                    data-ss-analytics-event=ht_link.click
                    title='Solved my problem'>
                    Yes
                </button>
                <button class='button' id='no-button'
                    data-ss-analytics-link-component_name='helpful'
                    data-ss-analytics-link-component_type='helpful'
                    data-ss-analytics-link-text='no'
                    data-ss-analytics-event=ht_link.click
                    title='Not helpful'>
                    No
                </button>
            </div>
        </fieldset>
    </div>

    <div id='feedback-state' class="form-element form-textbox-labelbelow hide">
        <form autocomplete="off">
            <input type='hidden' id='form-counter-error-message' 
                value="Maximum character limit is 250."
            />
            <label id='feedback-label' htmlFor='feedback' 
                data-no-label="Thanks for letting us know."
                data-yes-label="We’re glad this article helped."
            ></label>
            <div class='form-element form-textbox-labelbelow' id='feedback'>
                <textarea
                  class='form-textbox form-textbox-textarea form-counter-textarea form-textbox-entered'
                  data-no-placeholder="How can we make this article more helpful? (Optional)"
                  data-yes-placeholder="Anything else you’d like us to know? (Optional)"
                  data-max-length='250'
                  aria-labelledby='optional_label'
                  aria-describedby='char_limit_counter'
                ></textarea>
                <div class='form-textarea-paddingcover'>
                    <div class='form-textarea-paddingcover-color'></div>
                </div>
                <span class='form-label' id='optional_label' aria-hidden='true'></span>
                <div class='form-textbox-counter' id='char_limit_counter'>
                    <span class='visuallyhidden' id="char-limit-message">Character limit:</span>
                    <span class='form-counter'>250</span>
                </div>
                <label htmlFor='feedback-note'>Please don’t include any personal information in your comment.</label>
                <div class='form-message-wrapper'>
                    <span class='form-message'>Maximum character limit is 250.</span>
                </div>
                <button type='submit' class='button' id="submit-feedback">
                    Submit
                </button>
            </div>
        </form>
    </div>

    <div id='rating-done' class="hide">
        Thanks for your feedback.
    </div>

    <div id='results-helpful' class='show'>
    
    </div>
</div>


            </div>
   
            
            <div id='ask-widget-wrapper' class='css-not-downloaded discussions'>
                <div id='ask-widget'>
    <div class='contentWrapper'>
        <div class='sectionHeaderLayout'>
            <div class='icon'></div> 
            <div class='titleTextLayout'>
                <h2 class='title'>Start a discussion <span id='discussion-subtitle'>in&nbsp;Apple&nbsp;Support&nbsp;Communities</span></h2>
            </div>
        </div>

        <div class='sectionFormInputLayout'>
            <form 
                action='https://discussions.apple.com/create/question'
                id='question-form'
                method='get'
                data-ss-analytics-link-component_name='Start a discussion'
                data-ss-analytics-link-component_type="discussion"
                data-ss-analytics-link-text='Submit my question'
                data-ss-analytics-link-url='https://discussions.apple.com/create/question'
                data-ss-analytics-event=ht_link.click
                data-ignore-tracking='true'
                
                >
                <span class='fieldwrap'>
                    <label htmlFor='interactiveQuestionSearchField' class='a11y'>
                        Ask other users about this article
                    </label>
                    <input type='hidden' id='discussionFormArticleId' name='articleId' value=HT201372 />
                    <input type='hidden' id='ols_discussion_error_no_question' value='Please enter your question!' />
                   <div class="form-element">
                        <input
                            id='questionInputField'
                            type='text'
                            class='questionInputField form-textbox form-textbox-text'
                            name='title'
                            maxLength='255'
                            aria-labelledby="placeholder-text"
                            aria-invalid="false"
                        />
                        <span class="form-label" id="placeholder-text" aria-hidden="true">Ask other users about this article</span>
                    </div>
                </span>

                <div class='jive-widget-question-div clearfix' id='question-submit'>
                     <input type='submit' class='questionSubmitFormButton button button-secondary button-compact'
                        value='Submit my question' />   
                        
                </div>

                <a data-ss-analytics-link-component_name='Start a discussion'
                    data-ss-analytics-link-component_type="discussion"
                    data-ss-analytics-link-text='See all questions on this article'
                    data-ss-analytics-link-url='https://discussions.apple.com/article/HT201372'
                    data-ss-analytics-event=ht_link.click
                    class='see-all-questions' href='https://discussions.apple.com/article/HT201372'>
                    See all questions on this article
                    <span class='icon icon-chevronright' aria-hidden='true' />
                </a>

            </form>
        </div>
    </div>
</div>
            </div>
            

            
            <div id='flexbanner-wrapper'>
                <div id='flexbanner'></div>
            </div>
            
                
    
        <div class="footer-wrapper">
            <footer
                    id="ac-globalfooter"
                    lang="en-us"
                    dir="ltr"
                    class="js no-touch svg no-ie7 no-ie8 footer-global"
                    data-analytics-region="global footer"
                    role="contentinfo"
                    aria-labelledby="ac-gf-label">
                <div class="ac-gf-content">
                    <h2 class="ac-gf-label" id="ac-gf-label">Apple Footer</h2>
                    <nav class="ac-gf-breadcrumbs" aria-label="Breadcrumbs" role="navigation">
                        <a href="https://www.apple.com" class="home ac-gf-breadcrumbs-home">
                            <span class="ac-gf-breadcrumbs-home-icon" aria-hidden="true"></span>
                            <span class="ac-gf-breadcrumbs-home-label">Apple</span>
                            <span class="ac-gf-breadcrumbs-home-chevron"></span>
                            <span class="ac-gf-breadcrumbs-home-mask"></span>
                        </a>
                        <div class="ac-gf-breadcrumbs-path">
                            <ol class="ac-gf-breadcrumbs-list" vocab="http://schema.org/" typeof="BreadcrumbList">
                                <li class="ac-gf-breadcrumbs-item" property="itemListElement" typeof="ListItem">
                                    <span property="name">
                                        <a href="https://support.apple.com">Support</a>
                                    </span>
                                    <meta property="position" content="1"/>
                                </li>

                                

                                
                                    <li class="ac-gf-breadcrumbs-item" property="itemListElement" typeof="ListItem">
                                        <span property="name">How to create a bootable installer for macOS</span>
                                        <meta property="position" content="2" />
                                    </li>
                                

                            </ol>
                        </div>
                    </nav>
                    <section class="ac-gf-footer" vocab="https://schema.org/" typeof="Organization">             <div class="ac-gf-footer-shop" x-ms-format-detection="none"></div>             <div class="ac-gf-footer-locale">                 <a class="ac-gf-footer-locale-link" href="https://support.apple.com/en-us/HT201372/localeselector" title="Choose your country or region" aria-label="United States. Choose your country or region"><img class="ac-gf-footer-locale-flag" src="https://support.apple.com/content/dam/edam/applecare/images/en_US/flags/footer_flags/us.png" alt="" width="16" height="16">United States</a>             </div>             <div class="ac-gf-footer-legal">                 <div class="ac-gf-footer-legal-copyright">Copyright © 2020 Apple Inc. All rights reserved.</div>                 <div class="ac-gf-footer-legal-links"> <a class="ac-gf-footer-legal-link analytics-exitlink" href="https://www.apple.com/legal/privacy/en-ww/">Privacy Policy</a> <a class="ac-gf-footer-legal-link analytics-exitlink" href="https://www.apple.com/legal/internet-services/terms/site.html">Terms of Use</a> <a class="ac-gf-footer-legal-link analytics-exitlink" href="https://www.apple.com/shop/goto/help/sales_refunds">Sales and Refunds</a> <a class="ac-gf-footer-legal-link" href="https://www.apple.com/sitemap/">Site Map</a></div>             </div>             <meta content="Apple" property="name">             <meta content="1-800-692-7753" property="telephone">         </section>
                </div>
            </footer>
        </div>
    



            
            
                <script src="https://support.apple.com/clientside/build/app-ht-route.js" type="text/javascript" charset="utf-8"></script>
            
                <script src="/etc/designs/support/publish/JS/pattern/accsoffer.js" type="text/javascript" charset="utf-8"></script>
            
                <script src="https://www.apple.com/ac/globalnav/5/en_US/scripts/ac-globalnav.built.js" type="text/javascript" charset="utf-8"></script>
            
                <script src="https://km.support.apple.com/clientside/build/applesatellitelib.full.js" type="text/javascript" charset="utf-8"></script>
            
            <div id="apd-aria-live-region" aria-live="polite" role="status" class="a11y"></div>
        </body>
    </html>

