About the Apple Remote Desktop v3.5.2 Admin Update

Learn about the Apple Remote Desktop 3.5.2 Admin Update.
This article has been archived and is no longer updated by Apple.

System requirements

The Apple Remote Desktop 3.5.2 Admin Update requires:

  • OS X Lion, OS X Lion Server, Mac OS X v10.6, or Mac OS X Server v10.6
    • OS X Lion and OS X Lion Server require Apple Remote Desktop 3.5 or later
  • Apple Remote Desktop Admin 3.0 or later
  • A network connection via Ethernet (recommended), AirPort (Wi-Fi), or IP over FireWire

Compatibility with previous versions of Apple Remote Desktop

Apple Remote Desktop Admin v3.5.2 will work with client computers running version 3.0, 3.1, 3.2, 3.2.2, 3.3.1, 3.3.2, 3.4, 3.5, 3.5.1, 3.5.2 and 3.5.3 of the client software.

Improvements

  • Provides support for Mac computers with Retina displays
  • Provides the ability to Control and Observe Mac computers with Retina displays
  • Improves general Control and Observe performance
  • Improves general application stability and reliability
  • Improves performance when observing multiple clients
Published Date: