Share a High Dynamic Range (HDR) Final Cut Pro X video to YouTube

You can upload an Apple ProRes master file of your HDR clip or project to YouTube.

To successfully upload your HDR video to YouTube, use the HDR Tools effect in Final Cut Pro to limit the peak luminance of your video. Then, add the metadata required for proper processing and playback of your HDR video on YouTube.

Before you start, make sure to do the following:

Learn more about working with HDR video in Final Cut Pro and Compressor.

Use the HDR Tools effect

When color correcting an HDR video for YouTube, you should use the HDR Tools effect to apply a soft roll-off to limit the peak luminance, or brightness, of the clips in your project.

  1. In Final Cut Pro, choose Window > Show in Workspace > Inspector (or press Command–4) to open the Inspector.
  2. Choose Window > Show in Workspace >  Effects (or press Command–5).
  3. Click the Color category in the Effects Browser.
  4. Drag the HDR Tools effect from the Effects Browser to a clip in the timeline, then select the clip in the timeline.
  5. In the HDR Tools Effect in the Video Inspector, choose PQ Output Tone Map from the Mode pop-up menu.
  6. Set "Peak Brightness (nits)" to 1000.
  7. Repeat steps 4–6 for all clips in the project.

You can also create a compound clip of the clips in your project and apply the HDR Tools Effect to the compound clip.

Add optional HDR metadata

  1. In the browser, select the project or clip.
  2. If necessary, choose Window > Show in Workspace > Inspector (or press Command–4) to open the Inspector, then click .
  3. If you know the characteristics of your mastering display (the video monitor you use for critical color accuracy and color correction), enter the values in the HDR Mastering Display Metadata section. If you’re unsure of the proper values to enter, leave the fields empty.
    For example, if you’re mastering using a Sony BVM-X300 monitor, you would enter the following:
    • Display Primaries: Rec. 2020
    • Display White Point: D65
    • Maximum Display Luminance: 1000
    • Minimum Display Luminance: 0 or 0.0001
  4. You can leave MaxCLL and MaxFALL blank, unless you want to enter specific values.

Export an Apple ProRes HDR master file

  1. In the browser, select the project or clip that you want to export.
  2. Choose File > Share > Master File.
  3. Click Settings, choose Video and Audio from the Format pop-up menu, then choose Apple ProRes 422 from the “Video codec" pop-up menu. 
  4. Click Next, choose a location for the saved file, then click Save.

You can now upload the Apple ProRes HDR master file to YouTube via the YouTube website.

Published Date: