Transitioning to Compressor 4.1

Learn more about transitioning to Compressor 4.1 from a previous version of Compressor.

Transcoding

Where are the built-in settings?

Settings are grouped by category in the Settings pane. To show the Settings pane, choose View > Settings (Shift-Command-1) or click the Settings & Locations button   in the upper-left corner of the Compressor window. Then click Settings at the top of the pane.

Where are the properties of a setting or job?

Properties are in the Inspector pane. To open the Inspector pane, choose Window > Show Inspector (Command-4) or click the Inspector button   in the upper-right corner of the Compressor window. When you select a setting or job, the Inspector pane shows the properties of your selection. You can modify editable properties directly in the Inspector.

How do I create custom settings?

In the Settings pane, choose New Setting from the Add menu   in the lower-left corner. In the dialog that appears, choose a transcoding format from the pop-up menu, enter a name and description for the setting, then click OK. You can then modify the properties of your custom setting by adjusting the properties in the General, Video, and Audio inspectors. The settings you create appear at the bottom of the Settings pane, under the heading CUSTOM.

How do I create a reusable location for my output files?

For consistency with Final Cut Pro X, what was called a destination in Compressor 4.0.7 is called a location in Compressor 4.1. A location specifies where the output of a job is saved, and the Locations pane lists all preconfigured locations. To show the Locations pane, click the Settings & Locations button   in the upper-left corner of the Compressor window, then click Locations at the top of the pane. Or choose View > Locations (Shift-Command-2). To add a new location, click the Add button   in the lower-left corner of the pane.

How do I create a batch and submit it for transcoding?

Create a batch by adding one or more jobs to your session, each containing a source file, one or more settings, and a location. Submit a batch by clicking the Start Batch button (or pressing Command-B) at the bottom of the batch area of the Compressor window.

How do I monitor the progress of a transcoding job?

When you click Start Batch to submit a batch for transcoding, the Compressor window switches from Current view to Active view, where you can monitor the transcoding process. When the job completes, it's moved to the Completed View, which shows information about your completed batches. You can switch between all three views by using the view buttons at the top of the window:

How can I edit the extension of file that I’m encoding?

Compressor 4.1 automatically chooses the appropriate extension of the output file. To change the extension, wait until the encoding job completes, then go to file in the Finder and edit the extension there. You can use Compressor to locate the file in the Finder: Switch to Completed view, click the disclosure triangle next to the completed job, then click the magnifying glass in the far right of that row.

Where is the deinterlace filter?

Deinterlacing is automatically applied when the source is interlaced and the output setting is progressive. You can control the quality of deinterlacing in the Quality section of the Video inspector.

Can I chain jobs?

Yes, you can use the output of one job as a source for another. Control-click on the source that you want to chain to a new job, then create a new job by selecting New Job With Selected Output. You can configure the new job separately.

Destinations and batch templates

How do I create a batch template (associate a setting and job action together to apply to a target)?

In Compressor 4.1, destinations replicate much of the functionality previously available in batch templates in Compressor 4.0. Destinations consist of one or more transcoding instructions combined with an automated job action—such as burning a DVD or uploading to YouTube or Vimeo—performed after transcoding. You can choose from a number of built-in destinations or create your own by choosing New Destination from the Add menu   in the lower-left corner of the Settings pane.

How do I reuse a destination?

After you create a custom destination, it appears at the bottom of the Settings pane, under the heading CUSTOM. Reuse the destination by dragging it onto a job.

How do I submit a new batch using all the settings, sources, and job actions of a previous batch?

In Completed view, click click a job’s Reuse button   at the far right of the row. All of the job’s information is copied to Current view, where you can modify the job’s properties and other information before transcoding.

How can I receive an email notification when my batch is complete?

The email notification option for settings has been removed in Compressor 4.1.

Can I export using MPEG-1 or DV Stream settings?

These legacy settings are not available in Compressor 4.1, which includes more modern and flexible options such as MPEG-4 and HTTP Live Streaming.

Droplets

How do I create a droplet?

In the Settings tab, select one or more settings, setting groups, or a destination that you want to save as a droplet, then choose ‘Save as Droplet’ from the Action pop-up menu. Or Control-click any destination or setting and choose “Save as Droplet.”

How do I launch Share Monitor when encoding with a droplet?

Double-click the droplet to open it, then choose Droplet > Launch Share Monitor.

How do I edit the settings of a droplet?

Droplet settings can't be modified, but you can create a new droplet with new settings.

Distributed processing

How do I create a cluster or group of computers for processing?

What was previously referred to as a “cluster” is now called a “group” of computers in Compressor 4.1. To configure a group, choose Compressor > Preferences, then click Shared Computers. Click the Add button   at the bottom of the left pane to create a new group, then click the Add button at the bottom of the right pane to add computers to the group. Each computer in the group must have the same version of Compressor installed. Each computer must also have “Allow other computers to process batches on my computer” turned on in the My Computer tab of Compressor preferences.

How do I select a group of computers to process a batch?

When you submit a batch, select a computer or group of computers from the Process On menu at the bottom of the Compressor window. This menu appears only after you create a group of computers.

How do I set up additional instances of Compressor to process batches?

Choose Compressor > Preferences, then click Advanced. Select “Enable additional Compressor instances,” then choose a number of instances from the pop-up menu. This number specifies the additional instances of Compressor, so if the number is 1, then the total number of Compressor instances is 2. Learn more about enabling additional Compressor instances.

What computer is the controller when I submit a batch to a group of computers?

The computer you submit the batch from is always the controller. If the submitting computer is turned off or logged out, processing is suspended.

Published Date: