Move a Final Cut Pro X library

Move a Final Cut Pro X library to an external drive to save space or to edit your project on another Mac.

In Final Cut Pro, you organize your work in libraries. A single library can hold multiple events and projects. A library can also hold the media and Motion content used in your events and projects. You can move your library to an external drive to save space on your Mac, to edit your project on another Mac, or to collaborate on your project with others.

Prepare to move your library

Before you move a library, be aware that the source media files linked to the clips in your project and Motion content might not be located in the library you want to move. If you want to open the library on another Mac for editing or collaboration, you should consolidate the media and Motion content in the library you want to move. That way, you'll have all the content you need to work on your project on another Mac. 

If you plan on opening the library on another Mac, you'll have to install any third-party plug-ins and special fonts on the other Mac. Moving your library to another Mac doesn't move your third-party plug-ins and special fonts. Make sure that each plug-in is compatible with the versions of macOS and Final Cut Pro on the other Mac.

Prepare your drive

You can store libraries on an external storage device such as a USB drive, FireWire drive, or Thunderbolt drive formatted as APFS or MacOS Extended (Journaled).

You can’t store your library on an external drive or other disk used for Time Machine backups.

Remove generated files

Final Cut Pro creates generated files such as render files, optimized files, and proxy media files in the background while you’re working on a project. Before you move a Final Cut Pro library, you can delete generated files to save space. Final Cut Pro regenerates render files the next time you open and work on your project. If you delete optimized and proxy media files, you'll have to regenerate them manually when you reopen the library.

  1. To see how much space generated files take up, select the library in the Libraries sidebar, then scroll to Cache in the Library Properties window.
  2. Choose File > Delete Generated Library Files.
  3. To save the most space, select all options, then click OK.

Move a library

After removing generated files, move the library.

  1. To locate the library file, select the library in the Libraries sidebar, then choose File > Reveal in Finder. A new Finder window opens with the library selected.
  2. Quit Final Cut Pro.
  3. In the Finder, drag the library file to your external hard drive.

Consolidate media

If you’re moving a library to work on a project on another Mac, you might want to consolidate source media files and Motion content in the library you’re moving. Consolidate media after you've moved the library.

  1. To show the Libraries sidebar in Final Cut Pro, choose Window > Show In Workspace > Sidebar, or click .
  2. In the Libraries sidebar, select the library you want to move.
  3. In the Library Properties inspector, click Modify Settings.
  4. For the content you want to save with the library, choose "In Library" from each pop-up menu, then click OK. If you created any custom Motion effects, transitions, titles, or generators, make sure to also set the storage location for Motion Content to "In Library".
  5. In the Library Properties inspector, click Consolidate in the Media and Motion Content sections.
  6. To view the progress of the consolidation, choose Window > Background Tasks.
  7. When consolidation is finished, double-click the library file in the new location to open it in Final Cut Pro.*
  8. If you want to save space on your Mac, make sure the library you moved contains all your media, then drag the original library file on your Mac to the Trash.

* If you see a missing item alert icon, you might need to relink clips.

Published Date: