Create test media for Final Cut Pro

Find out how to create known-good media that you can use to isolate an issue in Final Cut Pro.

If you're having issues with Final Cut Pro, you can create known-good media to troubleshoot an issue. Use known-good media to troubleshoot a wide range of issues, including situations where media doesn't play or get exported as expected. The steps below demonstrate how to create an Apple ProRes 422 file using media included with Final Cut Pro, which you can then use to help isolate an issue in Final Cut Pro.

Install Additional Content

Before starting, make sure you've installed Final Cut Pro Additional Content. In Final Cut Pro, choose Final Cut Pro > Download Additional Content, then click More info in Software Update. If Final Cut Pro Additional Content appears in the window, select it, then click Install Now.

Add a placeholder

  1. Open Final Cut Pro.
  2. Choose File > New > Library.
  3. Enter "Test Library" as the name, press Command-Shift-D, then click Save to save the library to the Desktop.
  4. Choose File > New > Project. If Use Automatic Settings appears in the button in the bottom right-hand corner of the dialogue, click it so Use Custom Settings appears instead.
  5. Name the project "Test Media", then click OK.
  6. Choose Edit > Insert Generator > Placeholder or press Command-Option-W in the Video Properties window, click OK. The placeholder appears in the timeline. Press Shift-Z to zoom the placeholder to fit the size of the timeline.

Add a sound effect

  1. Click the Photos and Audio button in the top left-hand corner of the Final Cut Pro window.
  2. Click Sound Effects.
  3. Enter "ascending" into the search field above the Browser. A file called "Ascending" should appear in the search results.
  4. Drag the Ascending file to the timeline and drop it below the placeholder clip in the timeline.
  5. Press Shift-Z to zoom the timeline.
  6. Select the placeholder clip in the timeline, then drag the end of clip to match the end of the Ascending sound effect.

Export an Apple ProRes 422 file

After you've created the project and added content to it, share the project as an Apple ProRes 422 file using the Export File command.

  1. Choose File > Share > Export File, click Settings, then set the destination settings as follows:
    • Format: Video and Audio
    • Video codec: Apple ProRes 422
    • Resolution: 1920 x 1080
    • Audio file format: Linear PCM (QuickTime movie)
    • Tick the "Include chapter markers" box.
    • Action: Save only.
  2. Click Next.
  3. Enter "Test Media" as the name, press Command-Shift-D, then click Save to save the file to the Desktop.
  4. Click Close when the Share Successful notification appears.

Use test media

To test Final Cut Pro using the test media file, create a new library and create a new project. Then import the test media file into the new project. Try to recreate the issue. If the issue doesn’t occur when you use the test media, media in the affected project may be the cause. If the issue persists, you'll need to take further steps to isolate and resolve your issue.

Published Date: