Migrate your Aperture library to the Photos app or Adobe Lightroom Classic

Aperture won't run in versions of macOS after macOS Mojave. Here's how to move your Aperture libraries to Photos or Adobe Lightroom Classic.

In June 2014, Apple announced that development of Aperture has been discontinued. Since then, Apple has released six major macOS upgrades. For technical reasons, macOS Mojave is the last version of macOS to run Aperture. Starting with macOS Catalina, Aperture is no longer compatible with macOS.

To continue working with your Aperture photo libraries, you must migrate them to another photo app. You can migrate them to the Photos app, which is included with macOS Yosemite or later, or migrate them to Adobe Lightroom Classic or another app. You should do this before upgrading to macOS Catalina.

 


Migrate your library to Photos

If you're using macOS Mojave or earlier

Follow these steps if you're using macOS Mojave or earlier:

  1. Open Aperture.
  2. Choose Aperture > Preferences, click the Previews tab, then change the Photo Preview setting to Don't Limit. Close the preferences window.
  3. From the list of projects in the Library inspector, select all of your projects. For example, click the first project listed, then press and hold the Shift key while clicking the last project.
  4. Click the Browser layout button in the toolbar, so that all photos are shown as thumbnails.
  5. Choose Edit > Select All to select all of your photos.
  6. Press and hold the Option key, then choose Photos > Generate Previews.
  7. Aperture now generates full-size previews for every photo in your library. To follow its progress, choose Window > Show Activity from the menu bar. Quit Aperture when processing is complete.
  8. Open the Photos app, then choose your Aperture library when prompted, as pictured above. If you aren't prompted to choose a library, press and hold the Option key while opening Photos. If your Aperture library isn’t listed, click Other Library, then locate and choose your library.

When Photos shows the photos from your Apterture library, migration is complete. Learn more about how Photos migration works and how Photos handles content, metadata, and smart albums from Aperture.

If you're using macOS Catalina

Starting with macOS Catalina, Aperture is no longer compatible with macOS. If you upgraded to macOS Catalina before migrating your library to Photos, follow these steps:

  1. Install the latest macOS Catalina updates. Your Mac must be using macOS Catalina 10.15.1 or later.
  2. If you migrated your library to Photos after installing macOS Catalina 10.15 but before updating to macOS Catalina 10.15.1, complete these steps before continuing:
    1. Select your Aperture library in the Finder. By default, it's named Aperture Library and is in the Pictures folder of your home folder. 
    2. Choose File > Get Info. An Info window for your Aperture library opens.
    3. In the Name & Extension section of the Info window, replace .migratedphotolibrary at the end of the file name with .aplibrary. Then close the window.
  3. Open the Photos app, then choose your Aperture library when prompted, as pictured above. If you aren't prompted to choose a library, press and hold the Option key while opening Photos. If your Aperture library isn’t listed, click Other Library, then locate and choose your library.

When Photos shows the photos from your Aperture library, migration is complete. Learn more about how Photos migration works and how Photos handles content, metadata, and smart albums from Aperture.

 


Migrate your library to Adobe Lightroom Classic

Adobe Lightroom Classic version 5.7 and later includes a built-in tool for migrating Aperture libraries to Lightroom catalogs.

If you’ve upgraded to macOS Catalina, learn about compatibility with Lightroom Classic.

When an Aperture library is migrated to Lightroom, your library's organization, metadata, and image adjustments are preserved, with some exceptions:

  • RAW files are migrated, but Aperture's non-destructive adjustment layer does not. Lightroom’s migrator tool includes an option to export and migrate Aperture’s full-size JPEG previews for edited images. If you want to preserve your Aperture edits in another format, export the edited images from Aperture first, then reimport them into Lightroom after migrating your library.
  • Projects, folders, and albums are migrated to Lightroom collections and collection sets.
  • Faces, color labels, and stacks are migrated as keywords.
  • Rejected images are migrated to a collection.
  • Slideshows are migrated as collections.
  • Smart Albums and custom metadata fields aren't migrated.
  • Album organization is alphabetical, so manual sidebar organization might not be preserved.
  • Custom metadata fields aren't migrated.

 

 


Export your Aperture library

You can also export the contents of your Aperture library to back it up or to import into another app.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information. Other company and product names may be trademarks of their respective owners.

Published Date: