About the security content of Java for Mac OS X 10.4 Release 9

This document describes the security content of Java for Mac OS X 10.4 Release 9, which can be downloaded and installed via Software Update preferences, or from Apple Downloads.

For the protection of our customers, Apple does not disclose, discuss, or confirm security issues until a full investigation has occurred and any necessary patches or releases are available. To learn more about Apple Product Security, see the Apple Product Security website.

For information about the Apple Product Security PGP Key, see "How to use the Apple Product Security PGP Key."

Where possible, CVE IDs are used to reference the vulnerabilities for further information.

To learn about other Security Updates, see "Apple Security Updates."

Dieser Artikel wurde archiviert und wird von Apple nicht mehr aktualisiert.

Java for Mac OS X 10.4 Release 9

  • Java

    CVE-ID: CVE-2009-1107, CVE-2008-5352, CVE-2008-5356, CVE-2008-5353, CVE-2008-5354, CVE-2008-5357, CVE-2008-5359, CVE-2009-1104, CVE-2008-5344, CVE-2008-5345, CVE-2008-5346, CVE-2009-1103, CVE-2008-5349, CVE-2008-5350, CVE-2008-5351, CVE-2008-5348, CVE-2009-1101, CVE-2009-1100, CVE-2009-1100, CVE-2009-1099, CVE-2009-1098, CVE-2009-1095, CVE-2009-1096, CVE-2009-1094, CVE-2009-1093, CVE-2008-5341, CVE-2008-5339, CVE-2008-5360

    Available for: Mac OS X v10.4.11 with Java for Mac OS X 10.4 Release 8, Mac OS X Server v.10.4.11 with Java for Mac OS X 10.4 Release 8

    Impact: Multiple vulnerabilities in Java 1.5.0_16

    Description: Multiple vulnerabilities exist in Java 1.5.0_16, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by updating Java 1.5 to version 1.5.0_19. Further information is available via the Sun Java website at http://java.sun.com/j2se/1.5.0/ReleaseNotes.html

  • Java

    CVE-ID: CVE-2008-5342, CVE-2008-5356, CVE-2008-5353, CVE-2008-5354, CVE-2008-5357, CVE-2008-5340, CVE-2008-5359, CVE-2009-1104, CVE-2008-5360, CVE-2008-5344, CVE-2008-5345, CVE-2008-2086, CVE-2008-5346, CVE-2009-1103, CVE-2008-5350, CVE-2008-5351, CVE-2008-5348, CVE-2009-1100, CVE-2009-1100, CVE-2009-1098, CVE-2009-1094, CVE-2009-1093, CVE-2008-5343, CVE-2008-5339

    Available for: Mac OS X v10.4.11 with Java for Mac OS X 10.4 Release 8, Mac OS X Server v.10.4.11 with Java for Mac OS X 10.4 Release 8

    Impact: Multiple vulnerabilities in Java 1.4.2_18

    Description: Multiple vulnerabilities exist in Java 1.4.2_18, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by updating Java 1.4 to version 1.4.2_21. Further information is available via the Sun Java website at http://java.sun.com/j2se/1.4.2/ReleaseNotes.html

Veröffentlichungsdatum: 2016-01-28