Hvis webbrowseren mangler QuickTime-tilbehøret

Et mindre antal ældre websider er stadig baseret på det ældre QuickTime 7-webtilbehør til afspilning af medier. Dette tilbehør er ikke længere aktiveret i de nye versioner af macOS og nogle webbrowsere.

Denne artikel er blevet arkiveret og opdateres ikke længere af Apple.

Hvis du besøger en webside, der kræver det ældre QuickTime 7-webtilbehør, viser din webbrowser muligvis en besked om, at tilbehøret mangler eller ikke understøttes.

  • Tilbehøret er ikke længere aktiveret i macOS Sierra, El Capitan, Yosemite og Mavericks. Websteder bruger i stigende grad webstandarden HTML5 for at opnå en bedre videoafspilning på en bred vifte af browsere og enheder.
  • Nyere versioner af nogle andre webbrowsere understøtter heller ikke længere det ældre webtilbehør.

Gendan om nødvendigt tilbehøret

Hvis du ikke kan vente på, at websiden opdateres, kan du gendanne det ældre QuickTime 7-webtilbehør. Når du lader ældre browsertilbehør være deaktiveret, forbedrer du sikkerheden på din Mac-computer, så du skal kun følge disse trin, hvis det er nødvendigt.

  1. Kontroller, at du bruger Safari eller en anden browser, der understøtter ældre webtilbehør.
  2. Vælg Gå > Gå til mappe på menulinjen i Finder.
  3. Skriv /Bibliotek/Internet Plug-Ins i søgefeltet, og klik derefter på Gå. Mappen Internet Plug-Ins åbnes.
  4. Hold Kommandotasten (⌘) nede, mens du klikker to gange på mappen Disabled Plug-Ins for at åbne den i et nyt vindue.
  5. Træk de to arkiver fra mappen Disabled Plug-Ins til mappen Internet Plug-Ins:
    • QuickTime Plugin.plugin
    • nslQTScriptablePlugin.xpt
  6. Hvis du bliver bedt om at godkende, skal du klikke på Godkend og derefter indtaste et navn og en adgangskode for en administrator.
  7. Luk webbrowseren, og åbn den derefter igen. Det skulle nu være muligt at afspille medierne. 

Hvis du vil deaktivere det ældre QuickTime 7-webtilbehør igen, skal du flytte begge arkiver tilbage til mappen Disabled Plug-Ins.

Opdater dine websider, så kravet om tilbehør stopper

Hvis du er webudvikler, skal du opdatere din websider ved at erstatte alle <embed>-mærker, der henter det ældre QuickTime 7-webtilbehør. Du skal i stedet bruge HTML5 <video>-mærket, der tillader, at dine medier afspilles i de fleste moderne webbrowsere til stationære og mobile enheder uden yderligere software eller tilbehør. Oplysninger om, hvordan dette mærke bruges, findes mange steder.

Hvis du bruger det ældre QuickTime 7-webtilbehør til at få vist panoramabilleder, skal du bruge en HTML5-baseret panoramafremviser i stedet for. Søg på nettet efter en panoramafremviser, der ikke kræver et webtilbehør.

Oplysninger om produkter, der ikke er fremstillet af Apple, eller selvstændige websteder, der ikke er styret eller testet af Apple, er ikke udtryk for anbefalinger eller godkendelser fra Apples side. Apple påtager sig intet ansvar med hensyn til udvalget af disse produkter, produkternes funktionsevne eller brugen af produkterne. Apple giver ingen garanti for, at indholdet på websteder, som Apple ikke står bag, er pålideligt og præcist. Det er forbundet med en naturlig risiko at bruge internettet. Kontakt producenten for at få yderligere oplysninger. Andre virksomheds- og produktnavne kan være varemærker tilhørende de respektive ejere.

Udgivelsesdato: