Informace o bezpečnostním obsahu Xcode 7.0

Tento dokument popisuje bezpečnostní obsah Xcode 7.0.

Apple v zájmu ochrany zákazníků nezveřejňuje, nerozebírá ani nepotvrzuje bezpečnostní problémy, dokud nejsou plně vyšetřeny a nejsou k dispozici potřebné opravy nebo aktualizace. Podrobnější informace o zabezpečení produktů Apple najdete na webové stránce Zabezpečení produktů Apple.

Informace o klíči PGP zabezpečení produktů Apple najdete v článku Jak používat klíč PGP zabezpečení produktů Apple.

Pokud je to možné, jako odkazy na další informace o bezpečnostních chybách se používají identifikátory CVE ID.

Informace o dalších bezpečnostních aktualizacích najdete v článku Bezpečnostní aktualizace Apple.

Xcode 7.0

  • DevTools

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Dopad: Útočník může obejít omezení přístupu.

    Popis: V konfiguraci Apache existoval problém s API. Problém byl vyřešen aktualizací souborů hlaviček na nejnovější verzi.

    CVE-ID

    CVE-2015-3185 : Branko Äibej z nadace Apache Software Foundation

  • IDE Xcode server

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Dopad: Útočník může získat přístup k omezeným částem souborového systému.

    Popis: V odesílacím modulu node.js existoval před verzí 0.8.4 problém se srovnáváním. Problém byl vyřešen aktualizací na verzi 0.12.3.

    CVE-ID

    CVE-2014-6394 : Ilya Kantor

  • IDE Xcode server

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Dopad: Několik bezpečnostních slabin v knihovně OpenSSL.

    Popis: Modul node.js knihovny OpenSSL obsahoval ve verzích před 1.0.1j několik bezpečnostních slabin. Problémy byly vyřešeny aktualizací OpenSSL na verzi 1.0.1j.

    CVE-ID

    CVE-2014-3513

    CVE-2014-3566

    CVE-2014-3567

    CVE-2014-3568

  • IDE Xcode server

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Dopad: Útočník s vysokými oprávněními v síti může číst provoz směrovaný na Xcode server.

    Popis: Připojení k serverům Xcode bylo možné navázat i bez šifrování. Problém byl vyřešen vylepšením logiky, která řídí připojování k síti.

    CVE-ID

    CVE-2015-5910 : Anonymní výzkumník

  • IDE Xcode server

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Dopad: Oznámení o sestavách mohou být zasílána nezamýšleným adresátům.

    Popis: Úložiště obsahuje seznam e-mailů, při jejichž zpracovávání existoval problém s přístupem. Problém byl vyřešen vylepšením ověřování.

    CVE-ID

    CVE-2015-5909 : Daniel Tomlinson ze společnosti Rocket Apps, David Gatwood ze společnosti Anchorfree

  • subversion

    K dispozici pro: OS X Yosemite 10.10.4 a novější

    Popis: Software SVN obsahoval ve verzích před 1.7.19 několik bezpečnostních slabin.

    Popis: Software SVN obsahoval ve verzích před 1.7.19 několik bezpečnostních slabin. Ty byly vyřešeny aktualizací SVN na verzi 1.7.20.

    CVE-ID

    CVE-2015-0248

    CVE-2015-0251

Informace o produktech, které nevyrábí Apple, a o nezávislých webech, které Apple nemá pod kontrolou a netestuje je, jsou poskytovány bez doporučení nebo záruky za jejich obsah. Apple v souvislosti s výběrem, výkonem nebo použitím webů nebo produktů třetích stran nepřebírá žádnou odpovědnost. Apple nijak nezaručuje přesnost nebo spolehlivost webů třetích stran. S používáním internetu jsou neodmyslitelně spojena rizika. Další informace získáte od výrobce. Názvy jiných společností a produktů mohou být ochrannými známkami příslušných vlastníků.

Datum zveřejnění: