Informace o bezpečnostním obsahu OS X Serveru 3.1.2

Tento dokument popisuje bezpečnostní obsah OS X Serveru 3.1.2.

Apple v zájmu ochrany zákazníků nezveřejňuje, nerozebírá ani nepotvrzuje bezpečnostní problémy, dokud nejsou plně vyšetřeny a nejsou k dispozici potřebné opravy nebo aktualizace. Podrobnější informace o zabezpečení produktů Apple najdete na webové stránce Zabezpečení produktů Apple.

Informace o klíči PGP zabezpečení produktů Apple najdete v článku Jak používat klíč PGP zabezpečení produktů Apple.

Pokud je to možné, jako odkazy na další informace o bezpečnostních chybách se používají identifikátory CVE ID.

Informace o dalších bezpečnostních aktualizacích najdete v článku Bezpečnostní aktualizace Apple.

OS X Server 3.1.2

  • Ruby

    K dispozici pro: OS X Mavericks 10.9.3 nebo novější

    Dopad: Spuštění skriptu Ruby, který využívá nedůvěryhodný vstup k vytvoření objektu Float, může vést k zamrznutí aplikace nebo ke svévolnému spuštění kódu.

    Popis: Ve skriptu Ruby docházelo při převodu řetězce na hodnotu s plovoucí desetinnou čárkou k problému s přetečením vyrovnávací paměti haldy. Útočník mohl Profile Manageru nebo skriptu Ruby odeslat speciálně vytvořený požadavek, který mohl vést k zamrznutí aplikace nebo ke svévolnému spuštění kódu. Tento problém byl vyřešen dodatečným ověřováním hodnot s plovoucí desetinnou čárkou.

    CVE-ID

    CVE-2013-4164

Informace o produktech, které nevyrábí Apple, a o nezávislých webech, které Apple nemá pod kontrolou a netestuje je, jsou poskytovány bez doporučení nebo záruky za jejich obsah. Apple v souvislosti s výběrem, výkonem nebo použitím webů nebo produktů třetích stran nepřebírá žádnou odpovědnost. Apple nijak nezaručuje přesnost nebo spolehlivost webů třetích stran. S používáním internetu jsou neodmyslitelně spojena rizika. Další informace získáte od výrobce. Názvy jiných společností a produktů mohou být ochrannými známkami příslušných vlastníků.

Datum zveřejnění: