Informace o bezpečnostním obsahu OS X Serveru 3.0

Tento článek obsahuje informace o bezpečnostním obsahu OS X Serveru 3.0.

Tento dokument popisuje bezpečnostní obsah OS X Serveru 3.0.

Apple v zájmu ochrany zákazníků nezveřejňuje, nerozebírá ani nepotvrzuje bezpečnostní problémy, dokud nejsou plně vyšetřeny a nejsou k dispozici potřebné opravy nebo aktualizace. Podrobnější informace o zabezpečení produktů Apple najdete na webové stránce Zabezpečení produktů Apple.

Informace o klíči PGP zabezpečení produktů Apple najdete v článku Jak používat klíč PGP zabezpečení produktů Apple.

Pokud je to možné, jako odkazy na další informace o bezpečnostních chybách se používají identifikátory CVE ID.

Informace o dalších bezpečnostních aktualizacích najdete v článku Bezpečnostní aktualizace Apple.

OS X Server 3.0

  • Profile Manager

    K dispozici pro: OS X Mavericks 10.9 nebo novější

    Dopad: Vzdálený útočník může způsobit odmítnutí služby.

    Popis: Při analýze vstupů určitých konstrukcí JSON přiděloval Ruby Gem paměť natrvalo. Útočník toho může využít, aby použil všechnu dostupnou paměť, což může vést k odmítnutí služby. Problém byl vyřešen další ověřováním dat ve formátu JSON.

    CVE-ID

    CVE-2013-0269

  • Profile Manager

    K dispozici pro: OS X Mavericks 10.9 nebo novější

    Dopad: Několik problémů v Ruby on Rails.

    Popis: Ve frameworku Ruby on Rails existovalo několik problémů. Nejvážnější z nich mohly vést ke skriptování mezi weby. Problémy byly vyřešeny aktualizací implementace Rails, kterou používá Profile Manager, na verzi 2.3.18.

    CVE-ID

    CVE-2013-1854

    CVE-2013-1855

    CVE-2013-1856

    CVE-2013-1857

  • FreeRADIUS

    K dispozici pro: OS X Mavericks 10.9 nebo novější

    Dopad: Vzdálený útočník může způsobit odmítnutí služby nebo může svévolně spustit kód.

    Popis: Při analýze časového razítka „not after“ klientského certifikátu s použitím metod EAP založených na protokolu TLS docházelo v systému FreeRADIUS k přetečení vyrovnávací paměti. Problém byl vyřešen aktualizací systému FreeRADIUS na verzi 2.2.0.

    CVE-ID

    CVE-2012-3547

  • Aplikace Server

    K dispozici pro: OS X Mavericks 10.9 nebo novější

    Dopad: Při ověřování může server použít záložní certifikát.

    Popis: Existoval logický problém, kvůli kterému mohla služba RADIUS vybrat ze seznamu nakonfigurovaných certifikátů nesprávný certifikát. Problém byl vyřešen použitím stejného certifikátu, jaký používají jiné služby.

    CVE-ID

    CVE-2013-5143 : Arek Dreyer ze společnosti Dreyer Network Consultants, Inc.

Informace o produktech, které nevyrábí Apple, a o nezávislých webech, které Apple nemá pod kontrolou a netestuje je, jsou poskytovány bez doporučení nebo záruky za jejich obsah. Apple v souvislosti s výběrem, výkonem nebo použitím webů nebo produktů třetích stran nepřebírá žádnou odpovědnost. Apple nijak nezaručuje přesnost nebo spolehlivost webů třetích stran. S používáním internetu jsou neodmyslitelně spojena rizika. Další informace získáte od výrobce. Názvy jiných společností a produktů mohou být ochrannými známkami příslušných vlastníků.

Datum zveřejnění: