Languages

iCloud: Archiving or making copies of your iCloud data

Learn how to make copies of the various types of data that you use with iCloud.

It's a good idea to make a copy of the data that you use with iCloud, and keep in a safe place. If you accidentally delete an important contact, email, or document, you can retrieve it from this copy. The instructions below explain how to make a copy of the data for each of your applications.

Expand All | Collapse All

Bookmarks

Exporting a copy of your Safari bookmarks

  1. Choose File > Export Bookmarks.
  2. Specify a location on your computer for the exported file, then click Save. The file’s name will be Safari Bookmarks.html unless you change it.

Exporting a copy of your FireFox bookmarks

Refer to Mozilla's instructions for exporting bookmarks.

Exporting a copy of your Google Chrome bookmarks

Refer to Google's instructions for exporting bookmarks.

Exporting a copy of your Internet Explorer favorites (bookmarks)

Refer to Microsoft's instructions for exporting bookmarks.

Calendars

Exporting a calendar in OS X Mountain Lion and later

Refer to the instructions for exporting calendars.

Exporting a calendar in OS X Lion

  1. Open iCal.
  2. Click the Calendars button to show the Calendar list, if it's not already displayed.
  3. Select one of the calendars in the Calendar list.
  4. Choose File > Export > Export.
  5. Specify a location on your computer to save the calendar. Click Export.
  6. Repeat with each calendar that you want to copy.

Downloading a calendar from iCloud.com

  1. Go to iCloud Calendar at iCloud.com and sign in with your iCloud Apple ID.
  2. Publicly share a calendar.
  3. Copy the URL (web address) of the shared calendar and paste it into the address field in your browser. Do not press Enter or Return yet.
  4. Change "webcal" to "http" and press Enter or Return. An ICS file will download to your default download location.
  5. Add the calendar to a calendar client such as Calendar or iCal on a Mac, or Outlook on a Windows computer.
  6. Unpublish the shared calendar.

Exporting a calendar in Outlook 2007 or later

  1. Open Outlook.
  2. Select the calendar you want to copy in the Calendar list. Deselect all other calendars.
  3. Choose File > Save As.
  4. Click More Options to adjust the date range and amount of detail to include in the calendar (this will vary depending on your version of Outlook). Click OK.
  5. Specify a location on your computer to save the calendar, then click Save.
  6. Repeat with each calendar you want to copy.

Contacts

Exporting contacts in OS X Mountain Lion and later, and Address Book in OS X Lion

  1. Open Contacts or Address Book.
  2. Choose View > Groups. (In OS X Mavericks, choose View > Show Groups.)
  3. Select All Contacts in the Groups list.
  4. Choose File > Export > Export vCard.
  5. Specify a location on your computer to save the file, then click Save.

Note: If you use Groups, you should consider archiving your entire Contacts or Address Book database. The standard vCard method described above will copy your contacts, but not your Groups. Archives are more complex, but in some cases they may not properly restore data for iCloud members while connected to the Internet. If you use Groups, create both types of backups.

  • In OS X Mountain Lion and later, open contacts and choose File > Export > Contacts Archive.
  • In OS X Lion, open Address Book and choose File > Export > Address Book Archive.

Exporting contacts from iCloud.com

Refer to the instructions for exporting iCloud contact information as a vCard.

Exporting contacts in Outlook 2007 or later

Refer to Microsoft's instructions for exporting contacts.

Documents

Copying documents in OS X Mountain Lion and later

  1. Open the application used to create the document, then choose File > Open.
  2. Click iCloud in the top-left corner of the Open dialog.
  3. Open the document you want to copy, then hold down the Option key and choose File > Save As.
  4. Specify a location on your computer to save the document, then click Save.

Note: In OS X Mountain Lion and later, Preview and TextEdit files stored in iCloud are available only from the iCloud list in the Open dialog. They aren't available on iCloud.com.

Downloading copies of iWork documents

  1. Sign in to iCloud.com on a Mac or a Windows computer and open the application you used to create the document you want to download (Pages, Numbers, or Keynote).
  2. Select the document and choose the Download option from the Action (Gear) pop-up menu. The document will download to your default downloads location.

Copying documents created with third-party apps

For documents stored in iCloud that were created with third-party apps, contact the app developer for more information on how to make a copy of that app's data.

iTunes in the Cloud

iTunes in the Cloud is a way to access past music, movie, and TV show purchases from any of your devices. To make a complete backup, you may want to make a copy of your iTunes data as well. Learn how to back up your iTunes library by copying to an external hard drive.

Mail and notes

Copying mail in OS X Lion and later

Refer to the instructions for using OS X Mail to move, delete, or copy iCloud email.

Copying notes 

Open the Notes app at iCloud.com. Copy the text of each note and paste it into a document on your computer, such as a Pages or TextEdit document. Save the document to your computer.

My Photo Stream

Copying My Photo Stream in iOS 6 and iOS 7

You may already have a copy of the photos in My Photo Stream:

  • In OS X, My Photo Stream photos are automatically imported to your iPhoto or Aperture library, unless My Photo Stream and Automatic Import are turned off in iPhoto or Aperture preferences.
  • In Windows, My Photo Stream photos are automatically imported when My Photo Stream is turned on in the iCloud Control Panel.

Follow these steps to manually copy photos from My Photo Stream:

  • In iOS 7:
    1. Open Photos, tap Albums, then tap My Photo Stream.
    2. Save images using one of these methods:
      • Tap an image to open it, then tap Share . To select more images, scroll the images left or right and tap the ones you want to save. Tap Save to Camera Roll. (If you're using an iPhone 4S or iPhone 4, tap Next, then tap Save to Camera Roll.)
      • Tap Select, then tap the images you want to save. Tap Share , then tap Save to Camera Roll.
    3. Save your Camera Roll to your computer.
  • In iOS 6:
    1. Open Photos, tap Photo Stream, then tap My Photo Stream.
    2. Save images using one of these methods:
      • Tap an image to open it. Tap Share , then tap Save to Camera Roll.
      • Tap Edit, then tap the images you want to save. Tap Share , then tap Save to Camera Roll.
    3. Save your Camera Roll to your computer.

Follow these steps to manually copy photos and videos from a shared photo stream to which you have subscribed:

  • In iOS 7:
    1. Open Photos, then tap Shared.
    2. Tap the name of the shared photo stream.
    3. Save images using one of the following methods:
      • Tap an image to open it, then tap Share . To select more images, scroll the images left or right and tap the ones you want to save. Tap Save to Camera Roll. (If you're using an iPhone 4S or iPhone 4, tap Next, then tap Save to Camera Roll.)
      • Tap Select, then tap the images you want to save. Tap Share , then tap Save to Camera Roll.
    4. Save your Camera Roll to your computer.
  • In iOS 6:
    1. Open Photos, then tap Photo Stream.
    2. Tap the name of the shared photo stream.
    3. Save images using one of the following methods:
      • Tap an image to open it. Tap Share , then tap Save to Camera Roll.
      • Tap Edit, then tap the images you want to save. Tap Share , then tap Save to Camera Roll.
    4. Save your Camera Roll to your computer.

Note: Any comments or Likes attached to a shared photo stream photo are not saved.

Copying My Photo Stream in OS X Lion and later

You may already have a copy of the photos in My Photo Stream. In OS X, My Photo Stream photos are automatically imported to your iPhoto or Aperture library, unless My Photo Stream and Automatic Import are turned off in iPhoto or Aperture preferences.

Follow these steps to manually import photos to your iPhoto library:

  1. Connect your iOS device to your computer.
  2. Do one of the following:
    • To import all new photos shown in the iPhoto window, click the Import button that displays the number of photos.
    • To import a selection of photos, hold down the Command key while clicking photo thumbnails, or drag to select a group of photos. Then click Import Selected.
  3. If you want to make a backup of your iPhoto library, refer to iPhoto '11: Back up your iPhoto library.

Follow these steps to manually import photos to your Aperture library:

  1. In the Library inspector, select Photo Stream, then double-click My Photo Stream.
  2. Select the photos you want to import from your photo stream, then drag them to a project or an album in the Library inspector.
  3. If you want to make a backup of your Aperture library, refer to the Aperture backup overview.

Copying My Photo Stream in Windows

All photos in My Photo Stream are automatically saved to your Windows PC and are available even if you turn off Photos in the iCloud Control Panel. To save photos and videos from a shared stream, you must first save them to another folder on your hard drive:

  1. In Windows 8, go to the Start screen, then click the iCloud tile. In Windows 7, choose Start menu > All Programs > iCloud > iCloud.
  2. In the iCloud Control Panel, click the Options button next to Photos (or Photo Stream). Note the path listed under "iCloud Photos location".
  3. Open a File Explorer window (Windows 8) or Windows Explorer window (Windows 7).
  4. Navigate to the iCloud Photos folder location using the path you noted earlier in the iCloud Control Panel. Open the Shared folder.
  5. Select the photos you want to save, then copy them to another folder on your hard drive. Be sure to include this folder if you back up your computer's hard drive to another device or service.

Note: For information on backing up your Windows computer, see Microsoft Support.

Reminders

Exporting reminders in OS X Mountain Lion and later

Refer to the instructions for exporting Reminders in Mountain Lion. You also can use these instructions to export reminders in OS X Mavericks.

Exporting a reminder list in OS X Lion

  1. Open iCal and click Reminders. If you don't see the Reminders pop-up list, choose View > Show Reminders.
  2. Hold down the Control key, click the name of the reminder list that contains the reminders you want to export and choose Export from the pop-up menu.
  3. Specify a location on your computer to save the file and click Export. The reminders are exported as an .ics file.


Additional information
If you save copies of your application data to your computer, you should regularly back up your computer to a storage device or service. You should also regularly back up your iOS devices. Having a backup makes it possible to restore your data if your computer or iOS device is damaged or lost.

Important: Mention of third-party websites and products is for informational purposes only and constitutes neither an endorsement nor a recommendation. Apple assumes no responsibility with regard to the selection, performance or use of information or products found at third-party websites. Apple provides this only as a convenience to our users. Apple has not tested the information found on these sites and makes no representations regarding its accuracy or reliability. There are risks inherent in the use of any information or products found on the Internet, and Apple assumes no responsibility in this regard. Please understand that a third-party site is independent from Apple and that Apple has no control over the content on that website. Please contact the vendor for additional information.
Important: Information about products not manufactured by Apple is provided for information purposes only and does not constitute Apple’s recommendation or endorsement. Please contact the vendor for additional information.
Last Modified: Feb 25, 2014
Helpful?
Yes
No
Not helpful Somewhat helpful Helpful Very helpful Solved my problem
Print this page
  • Last Modified: Feb 25, 2014
  • Article: HT4910
  • Views:

    2918452
  • Rating:
    • 57.0

    (9810 Responses)
Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked