Languages

About the security content of Mac OS X v10.6.7 and Security Update 2011-001

This document describes the security content of Mac OS X v10.6.7 and Security Update 2011-001.

This document describes the security content of Mac OS X v10.6.7 and Security Update 2011-001, which can be downloaded and installed via Software Update preferences, or from Apple Downloads.

For the protection of our customers, Apple does not disclose, discuss, or confirm security issues until a full investigation has occurred and any necessary patches or releases are available. To learn more about Apple Product Security, see the Apple Product Security website.

For information about the Apple Product Security PGP Key, see "How to use the Apple Product Security PGP Key."

Where possible, CVE IDs are used to reference the vulnerabilities for further information.

To learn about other Security Updates, see "Apple Security Updates."

Mac OS X v10.6.7 and Security Update 2011-001

  • AirPort

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: When connected to Wi-Fi, an attacker on the same network may be able to cause a system reset

    Description: A divide by zero issue existed in the handling of Wi-Fi frames. When connected to Wi-Fi, an attacker on the same network may be able to cause a system reset. This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2011-0172

  • Apache

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Multiple vulnerabilities in Apache 2.2.15

    Description: Apache is updated to version 2.2.17 to address several vulnerabilities, the most serious of which may lead to a denial of service. Further information is available via the Apache web site at http://httpd.apache.org/

    CVE-ID

    CVE-2010-1452

    CVE-2010-2068

  • AppleScript

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Running an AppleScript Studio-based application that allows untrusted input to be passed to a dialog may lead to an unexpected application termination or arbitrary code execution

    Description: A format string issue existed in AppleScript Studio's generic dialog commands ("display dialog" and "display alert"). Running an AppleScript Studio-based application that allows untrusted input to be passed to a dialog may lead to an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0173 : Alexander Strange

  • ATS

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution

    Description: A heap buffer overflow issue existed in the handling of OpenType fonts. Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution.

    CVE-ID

    CVE-2011-0174

  • ATS

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution

    Description: Multiple buffer overflow issues existed in the handling of TrueType fonts. Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution.

    CVE-ID

    CVE-2011-0175 : Christoph Diehl of Mozilla, Felix Grobert of the Google Security Team, Marc Schoenefeld of Red Hat Security Response Team, Tavis Ormandy and Will Drewry of Google Security Team

  • ATS

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution

    Description: Multiple buffer overflow issues existed in the handling of Type 1 fonts. Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution.

    CVE-ID

    CVE-2011-0176 : Felix Grobert of the Google Security Team, geekable working with TippingPoint's Zero Day Initiative

  • ATS

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution

    Description: Multiple buffer overflow issues existed in the handling of SFNT tables. Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution.

    CVE-ID

    CVE-2011-0177 : Marc Schoenefeld of Red Hat Security Response Team

  • bzip2

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Using the command line bzip2 or bunzip2 tool to decompress a bzip2 file may result in an unexpected application termination or arbitrary code execution

    Description: An integer overflow issue existed in bzip2's handling of bzip2 compressed files. Using the command line bzip2 or bunzip2 tool to decompress a bzip2 file may result in an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2010-0405

  • CarbonCore

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Applications that use FSFindFolder() with the kTemporaryFolderType flag may be vulnerable to a local information disclosure

    Description: When used with the kTemporaryFolderType flag, the FSFindFolder() API returns a directory that is world readable. This issue is addressed by returning a directory that is only readable by the user that the process is running as.

    CVE-ID

    CVE-2011-0178

  • ClamAV

    Available for: Mac OS X Server v10.5.8, Mac OS X Server v10.6.6

    Impact: Multiple vulnerabilities in ClamAV

    Description: Multiple vulnerabilities exist in ClamAV, the most serious of which may lead to arbitrary code execution. This update addresses the issues by updating ClamAV to version 0.96.5. ClamAV is distributed only with Mac OS X Server systems. Further information is available via the ClamAV website at http://www.clamav.net/

    CVE-ID

    CVE-2010-0405

    CVE-2010-3434

    CVE-2010-4260

    CVE-2010-4261

    CVE-2010-4479

  • CoreText

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution

    Description: A memory corruption issue existed in CoreText's handling of font files. Viewing or downloading a document containing a maliciously crafted embedded font may lead to arbitrary code execution.

    CVE-ID

    CVE-2011-0179 : Christoph Diehl of Mozilla

  • File Quarantine

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Definition added

    Description: The OSX.OpinionSpy definition has been added to the malware check within File Quarantine.

  • HFS

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: A local user may be able to read arbitrary files from an HFS, HFS+, or HFS+J filesystem

    Description: An integer overflow issue existed in the handling of the F_READBOOTSTRAP ioctl. A local user may be able to read arbitrary files from an HFS, HFS+, or HFS+J filesystem.

    CVE-ID

    CVE-2011-0180 : Dan Rosenberg of Virtual Security Research

  • ImageIO

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution

    Description: A heap buffer overflow issue existed in ImageIO's handling of JPEG images. Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution.

     

    CVE-ID

    CVE-2011-0170 : Andrzej Dyjak working with iDefense VCP

  • ImageIO

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted XBM image may result in an unexpected application termination or arbitrary code execution

    Description: An integer overflow issue existed in ImageIO's handling of XBM images. Viewing a maliciously crafted XBM image may result in an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0181 : Harry Sintonen

  • ImageIO

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted TIFF image may result in an unexpected application termination or arbitrary code execution

    Description: A buffer overflow existed in libTIFF's handling of JPEG encoded TIFF images. Viewing a maliciously crafted TIFF image may result in an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0191 : Apple

  • ImageIO

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted TIFF image may result in an unexpected application termination or arbitrary code execution

    Description: A buffer overflow existed in libTIFF's handling of CCITT Group 4 encoded TIFF images. Viewing a maliciously crafted TIFF image may result in an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0192 : Apple

  • ImageIO

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted JPEG-encoded TIFF image may result in an unexpected application termination or arbitrary code execution

    Description: An integer overflow issue existed in ImageIO's handling of JPEG-encoded TIFF images. Viewing a maliciously crafted TIFF image may result in an unexpected application termination or arbitrary code execution. This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2011-0194 : Dominic Chell of NGS Secure

  • Image RAW

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted Canon RAW image may result in an unexpected application termination or arbitrary code execution

    Description: Multiple buffer overflow issues existed in Image RAW's handling of Canon RAW images. Viewing a maliciously crafted Canon RAW image may result in an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0193 : Paul Harrington of NGS Secure

  • Installer

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Visiting a maliciously crafted website may lead to the installation of an agent that contacts an arbitrary server when the user logs in, and mislead the user into thinking that the connection is with Apple

    Description: A URL processing issue in Install Helper may lead to the installation of an agent that contacts an arbitrary server when the user logs in. The dialog resulting from a connection failure may lead the user to believe that the connection was attempted with Apple. This issue is addressed by removing Install Helper.

    CVE-ID

    CVE-2011-0190 : Aaron Sigel of vtty.com

  • Kerberos

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Multiple vulnerabilities in MIT Kerberos 5

    Description: Multiple cryptographic issues existed in MIT Kerberos 5. Only CVE-2010-1323 affects Mac OS X v10.5. Further information on the issues and the patches applied is available via the MIT Kerberos website at http://web.mit.edu/Kerberos/

    CVE-ID

    CVE-2010-1323

    CVE-2010-1324

    CVE-2010-4020

    CVE-2010-4021

  • Kernel

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: A local user may be able to execute arbitrary code with system privileges

    Description: A privilege checking issue existed in the i386_set_ldt system call's handling of call gates. A local user may be able to execute arbitrary code with system privileges. This issue is addressed by disallowing creation of call gate entries via i386_set_ldt().

    CVE-ID

    CVE-2011-0182 : Jeff Mears

  • Libinfo

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: A remote attacker may be able to cause a denial of service on hosts that export NFS file systems

    Description: An integer truncation issue existed in Libinfo's handling of NFS RPC packets. A remote attacker may be able to cause NFS RPC services such as lockd, statd, mountd, and portmap to become unresponsive.

    CVE-ID

    CVE-2011-0183 : Peter Schwenk of the University of Delaware

  • libxml

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution

    Description: A memory corruption issue existed in libxml's XPath handling. Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2010-4008 : Bui Quang Minh from Bkis (www.bkis.com)

  • libxml

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution

    Description: A double free issue existed in libxml's handling of XPath expressions. Visiting a maliciously crafted website may lead to an unexpected application termination or arbitrary code execution. This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2010-4494 : Yang Dingning of NCNIPC, Graduate University of Chinese Academy of Sciences

  • Mailman

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Multiple vulnerabilities in Mailman 2.1.13

    Description: Multiple cross-site scripting issues existed in Mailman 2.1.13. These issues are addressed by updating Mailman to version 2.1.14. Further information is available via the Mailman site at http://mail.python.org/pipermail/mailman-announce/2010-September/000154.html

    CVE-ID

    CVE-2010-3089

  • PHP

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Multiple vulnerabilities in PHP 5.3.3

    Description: PHP is updated to version 5.3.4 to address multiple vulnerabilities, the most serious of which may lead to arbitrary code execution. Further information is available via the PHP website at http://www.php.net/

    CVE-ID

    CVE-2006-7243

    CVE-2010-2950

    CVE-2010-3709

    CVE-2010-3710

    CVE-2010-3870

    CVE-2010-4150

    CVE-2010-4409

  • PHP

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8

    Impact: Multiple vulnerabilities in PHP 5.2.14

    Description: PHP is updated to version 5.2.15 to address multiple vulnerabilities, the most serious of which may lead to arbitrary code execution. Further information is available via the PHP website at http://www.php.net/

    CVE-ID

    CVE-2010-3436

    CVE-2010-3709

    CVE-2010-4150

  • QuickLook

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Downloading a maliciously crafted Excel file may lead to an unexpected application termination or arbitrary code execution

    Description: A memory corruption issue existed in QuickLook's handling of Excel files. Downloading a maliciously crafted Excel file may lead to an unexpected application termination or arbitrary code execution. This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2011-0184 : Tobias Klein working with Verisign iDefense Labs

  • QuickLook

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Downloading a maliciously crafted Microsoft Office file may lead to an unexpected application termination or arbitrary code execution

    Description: A memory corruption issue existed in QuickLook's handling of Microsoft Office files. Downloading a maliciously crafted Microsoft Office file may lead to an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-1417 : Charlie Miller and Dion Blazakis, working with TippingPoint's Zero Day Initiative

  • QuickTime

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted JPEG2000 image with QuickTime may lead to an unexpected application termination or arbitrary code execution

    Description: Multiple memory corruption issues existed in QuickTime's handling of JPEG2000 images. Viewing a maliciously crafted JPEG2000 image with QuickTime may lead to an unexpected application termination or arbitrary code execution.

    CVE-ID

    CVE-2011-0186 : Will Dormann of the CERT/CC

  • QuickTime

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted movie file may lead to an unexpected application termination or arbitrary code execution

    Description: An integer overflow existed in QuickTime's handling of movie files. Viewing a maliciously crafted movie file may lead to an unexpected application termination or arbitrary code execution. For Mac OS X v10.5 this issue was addressed in QuickTime 7.6.9.

    CVE-ID

    CVE-2010-4009 : Honggang Ren of Fortinet's FortiGuard Labs

  • QuickTime

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted FlashPix image may lead to an unexpected application termination or arbitrary code execution

    Description: A memory corruption issue existed in QuickTime's handling of FlashPix images. Viewing a maliciously crafted FlashPix image may lead to an unexpected application termination or arbitrary code execution. For Mac OS X v10.5 this issue was addressed in QuickTime 7.6.9.

    CVE-ID

    CVE-2010-3801 : Damian Put working with TippingPoint's Zero Day Initiative, and Rodrigo Rubira Branco from the Check Point Vulnerability Discovery Team

  • QuickTime

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Visiting a maliciously crafted website may lead to the disclosure of video data from another site

    Description: A cross-origin issue existed in QuickTime plug-in's handling of cross-site redirects. Visiting a maliciously crafted website may lead to the disclosure of video data from another site. This issue is addressed by preventing QuickTime from following cross-site redirects.

    CVE-ID

    CVE-2011-0187 : Nirankush Panchbhai and Microsoft Vulnerability Research (MSVR)

  • QuickTime

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Viewing a maliciously crafted QTVR movie file may lead to an unexpected application termination or arbitrary code execution

    Description: A memory corruption issue existed in QuickTime's handling of panorama atoms in QTVR (QuickTime Virtual Reality) movie files. Viewing a maliciously crafted QTVR movie file may lead to an unexpected application termination or arbitrary code execution. For Mac OS X v10.5 this issue was addressed in QuickTime 7.6.9.

    CVE-ID

    CVE-2010-3802 : an anonymous researcher working with TippingPoint's Zero Day Initiative

  • Ruby

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Running a Ruby script that uses untrusted input to create a BigDecimal object may lead to an unexpected application termination or arbitrary code execution

    Description: An integer truncation issue existed in Ruby's BigDecimal class. Running a Ruby script that uses untrusted input to create a BigDecimal object may lead to an unexpected application termination or arbitrary code execution. This issue only affects 64-bit Ruby processes.

    CVE-ID

    CVE-2011-0188 : Apple

  • Samba

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: If SMB file sharing is enabled, a remote attacker may cause a denial of service or arbitrary code execution

    Description: A stack buffer overflow existed in Samba's handling of Windows Security IDs. If SMB file sharing is enabled, a remote attacker may cause a denial of service or arbitrary code execution.

    CVE-ID

    CVE-2010-3069

  • Subversion

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Subversion servers that use the non-default "SVNPathAuthz short_circuit" mod_dav_svn configuration setting may allow unauthorized users to access portions of the repository

    Description: Subversion servers that use the non-default "SVNPathAuthz short_circuit" mod_dav_svn configuration setting may allow unauthorized users to access portions of the repository. This issue is addressed by updating Subversion to version 1.6.13. This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2010-3315

  • Terminal

    Available for: Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: When ssh is used in Terminal's "New Remote Connection" dialog, SSH version 1 is selected as the default protocol version

    Description: When ssh is used in Terminal's "New Remote Connection" dialog, SSH version 1 is selected as the default protocol version. This issue is addressed by changing the default protocol version to "Automatic". This issue does not affect systems prior to Mac OS X v10.6.

    CVE-ID

    CVE-2011-0189 : Matt Warren of HNW Inc.

  • X11

    Available for: Mac OS X v10.5.8, Mac OS X Server v10.5.8, Mac OS X v10.6 through v10.6.6, Mac OS X Server v10.6 through v10.6.6

    Impact: Multiple vulnerabilities in FreeType

    Description: Multiple vulnerabilities existed in FreeType, the most serious of which may lead to arbitrary code execution when processing a maliciously crafted font. These issues are addressed by updating FreeType to version 2.4.4. Further information is available via the FreeType site at http://www.freetype.org/

    CVE-ID

    CVE-2010-3814

    CVE-2010-3855

 

Important: Mention of third-party websites and products is for informational purposes only and constitutes neither an endorsement nor a recommendation. Apple assumes no responsibility with regard to the selection, performance or use of information or products found at third-party websites. Apple provides this only as a convenience to our users. Apple has not tested the information found on these sites and makes no representations regarding its accuracy or reliability. There are risks inherent in the use of any information or products found on the Internet, and Apple assumes no responsibility in this regard. Please understand that a third-party site is independent from Apple and that Apple has no control over the content on that website. Please contact the vendor for additional information.
Last Modified: May 30, 2012
Helpful?
Yes
No
  • Last Modified: May 30, 2012
  • Article: HT4581
  • Views:

    19893
  • Rating:
    • 100.0

    (1 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked