Languages

Logic Pro X 10.0.6: Release notes

Symptoms

Logic Pro X 10.0.6 is an update to Logic Pro X. Logic Pro X is a new paid version of Logic Pro.

Resolution

Logic Pro X 10.0.6 update

Fixes an audio-input issue that caused the Record Enable button to be unavailable with some audio interfaces, including the M-Audio Fast Track Pro, M-Audio Plus, Blue Yeti USB mic, Alesis i02 Express, Avid Mbox, and Griffin iMic.

Logic Pro X 10.0.5 update

New features and enhancements

  • Includes 3 new Drummers and 11 new Drum Kit Designer patches.
  • Significant enhancements to Channel EQ and Linear Phase EQ plug-ins, including:
    • Redesigned, easier-to-use interface that's also accessible within the Smart Controls area
    • Double Precision processing provides more accurate filtering, especially for low frequencies
    • Oversampling option improves high-frequency clarity
    • Option to apply EQ only to stereo left, right, middle, or side signals
  • There is now an option to set the Piano Roll to a light background color.
  • Selected notes in the Piano Roll are now highlighted by a selection frame.
  • When Logic is stopped or in Play mode, the glyph on the Metronome button in the control bar now illuminates to indicate that “Click while recording” is enabled.
  • The Shuffle commands are improved (see Logic Pro X Help for details).

User interface

  • There is now a command to assign region names to track names.
  • The waveform size in an audio region now adapts to the value of the region gain parameter.
  • Loops that belong to the same family can now be selected and changed using a new control in the region header.
  • Logic Pro X now assigns region and Mixer channel colors that are closer to the original colors when opening a project created in an earlier version of Logic.
  • Option-clicking a disclosure triangle in the Project Audio window now toggles all disclosure triangles in the window.
  • The Windows menu again lists all currently open windows.
  • The Mixer can now be reliably resized when in All mode.
  • Renaming multiple selected Mixer channels now reliably renames all channel strips in the selection.
  • When creating a duplicate track, the correct track icon and color are now assigned to the duplicate.
  • The song title is now automatically populated in the Share to iTunes dialog when sharing a song created in Logic 9 or GarageBand for iOS.
  • It's once again possible to browse or load patches onto the Output channel strip via the Library.
  • The View menu items One Track and Selected Regions in the Piano Roll are now disabled when Link mode is disabled.

Performance

  • Improves processor balancing for multi-output software instrument configurations.
  • Improves handling of multiple displays on OS X Mavericks v10.9.
  • Resolves an issue that in some cases might cause audio clicks and pops when scrolling.
  • Moving an automation line while playing no longer spikes in CPU usages, or clicks and pops in the audio output.
  • Resolves an issue that could cause clicks and pops in the audio output when adjusting the gain or output level settings during playback in the various plug-ins.
  • Logic's interface no longer freezes when using the Native Instruments Maschine controller to adjust two macro controls simultaneously.
  • Fixes an issue in which a warning about not enough memory might be displayed when performing Undo after editing a protected track.
  • Adjusting the frequency controls while playing audio through the Stereo Spread plug-in no longer causes audible zipper noise.
  • Improves the performance of scrolling when dragging regions in the Tracks area beyond the currently visible section.
  • Playing notes live into the Arpeggiator plug-in no longer sometimes leads to spikes in CPU usage.
  • Fixes an issue that could cause a spike in CPU usage when recording near the end of a project.
  • Logic 9 projects that contain a macro object in the Environment now behave more reliably when opened into Logic Pro X. 
  • Multiple instances of the Scripter plug-in no longer have the potential to cause stuck notes.
  • The Scripter plug-in is no longer prone to causing stuck notes when using the Delay Note Until Next Beat preset.
  • Switching between presets in the Space Designer plug-in no longer sometimes results in noise.

General

  • Regions copied from a Track Stack can now be muted as expected even when they are within a Track Stack that is muted.
  • Deleting an audio Track Stack while it was soloed no longer leaves all the remaining tracks muted.
  • Entering a new crossfade value in the Region inspector for multiple selected regions now works as expected.
  • Region-based automation data beyond the end of a region is now chased properly even when playback is started after the last automation node within the bounds of the region.
  • Logic now maintains the correct relative levels when automation on multiple tracks belonging to the same Group are copied by dragging.
  • Resolves an issue in which track automation might be deleted when switching patches.
  • The default display setting when showing automation on Track Stacks is now Volume, instead of Display Off.
  • A track is now created as expected when using a control surface to set the automation mode of a channel strip not previously assigned to a track.
  • Moving a SMPTE locked region can no longer cause the automation on the track to move.
  • The position of the automation line no longer jumps unexpectedly when it is selected after creating 4 automation points with a Marquee selection.
  • Adjacent automation points of the same value are no longer sometimes inadvertently deleted when moving automation points on a grouped track.
  • The Repeat Section Between Locators command now includes automation on tracks that contain no regions in the repeated section.
  • When using Touch mode, Logic no longer writes unneeded automation points at the held value when holding a fader at the same position where there is an existing automation ramp.
  • Writing automation to an Aux not assigned to a track can no longer potentially cause tracks in a Track Stack to be rerouted to that Aux.
  • Copying multiple regions where only some affected tracks contain automation no longer activates Automation Read mode on the channel strips that have no automation.
  • Chase now works as expected for MIDI controllers on channels other than channel 1.
  • Takes are now shortened as expected when the take folder containing them is shortened by an edit operation and No Overlap mode is enabled.
  • Fixes an issue in which the visible area might jump unexpectedly when comping in a take folder that was not on the selected track.
  • Fixes an issue that caused some audio regions to be immovable when duplicate regions are packed into a take folder.
  • Packing regions with names containing non-ASCII characters into a take folder no longer creates garbled take names.
  • Numbers assigned to MIDI takes now increment reliably.
  • Expanding a take folder no longer potentially causes the playhead to fall out of sync with the audio output.
  • When using OS X v10.9, the playhead in the Audio Editor now consistently maintains the correct position when switching from Flex Time to Flex Pitch mode.
  • It's now possible to set a loop to a length of less than 1/16 note.
  • The position of beat markers in the Global Beat Mapping track are now updated appropriately when using the various Cut/Insert Time commands.
  • Inserting a beat marker in the Beat Mapping track no longer creates unexpected tempo events in some circumstances.
  • Expanding a take folder no longer potentially causes the playhead to fall out of sync with the audio output.
  • Resolves an issue in which some MIDI notes might unexpectedly change position when Beat Mapping.
  • Adding a Beat Mapping marker no longer intermittently removes existing tempo events.
  • Inserting a fade-in using Shift-Control and the Pointer tool now works consistently.
  • Using the Fade tool to set fade-ins on multiple regions in a set of grouped tracks now works reliably.
  • Dragging regions on multiple grouped tracks with the Drag Mode set to X-Fade no longer potentially results in crossfades of varying lengths. 
  • The Delete command now works as expected on selected regions that are inside a collapsed Group in the Project Audio window. 
  • It's now possible to add a green Apple MIDI loop to the Tracks area as an audio loop by dragging it from the Loops browser while pressing the Option key.
  • Logic Pro X no longer creates separate tracks for non-overlapping regions when unpacking folders in projects created by earlier versions of Logic.
  • Using the menu that appears when pressing the Metronome button in the Control Bar, it's now possible to set the metronome to sound only during count-in.
  • Improves the reliability of Undo in several areas.
  • The Mixer window no longer intermittently moves when scrolling past the minimum or maximum value of the fader using a scroll wheel or gesture.
  • It's now possible to select or open folder tracks in the Mixer.
  • Right-clicking an Aux or Output channel strip in the Mixer and selecting Create Track now behaves as expected even if the channel strip is not initially selected.
  • Command-click again works reliably to deselect a Mixer channel within a selected group of channels.
  • The display of audio waveforms of regions in a track no longer change unexpectedly when enabling or disabling the Groove status on a track.
  • Looped regions inside a folder now update the point they are supposed to stop playing after extending the length of the folder.
  • Overwriting an existing project no longer potentially leaves assets from the original project in place.
  • When creating a new project from a Logic 9 template, the default save path is no longer the location of the template.
  • Improves the mapping of Smart Controls to channel strip settings created in Logic 9.
  • The Follow Tempo parameter in the Region inspector is no longer incorrectly disabled for Apple Loops in songs last saved in GarageBand 6 or earlier.
  • Clicking and holding down on the upper-right corner of a region no longer unexpectedly enables looping in the Region inspector, with a loop length of zero.
  • The Region Inspector no longer displays a Loop checkbox for selected Track Stack folder regions.
  • It's once again possible to disable Quantize in the Region Inspector for a region on a track slaved to a Groove Master track.
  • Saving a song created from a template no longer resets the tempo to 120 BPM.
  • Text for alert messages now always displays correctly on control surfaces.
  • Changing Region inspector parameters for MIDI regions on the main track of a Track Stack now behaves as expected.
  • It's again possible to change the Transpose value in the Region Inspector using the + and - keys.
  • Logic now consistently responds to Play or Stop key commands when a floating Region inspector window is open.
  • It's no longer possible to give the same name to more than one project alternative.
  • MIDI played from the Musical Typing Keyboard and Logic Remote is now routed through the Physical Input object in the Environment, which allows Environment processing of MIDI as it is being played into Logic from these sources.
  • Logic no longer adds 2 extra frames to the value when entering a SMPTE position in a project set to a non-drop frame rate.
  • Regions copied by option-dragging in projects with a start position earlier than bar 1 now end at the desired position.
  • Moving the first arrangement marker in a project no longer inadvertently moves other arrangement markers.
  • Resolves a rare issue that could cause the timing of a track in a project with many tempo changes to be altered after turning Flex on and then off.
  • Logic now asks the user to save the project when closing a project immediately after entering text into the Project Notes area.
  • It's now possible to consistently add, remove, or edit plug-ins on tracks that were frozen in Source Only mode.
  • Pressing the Control key while dragging a region with the Snap Mode set to Bar now moves the region by beats instead of ticks, as expected.
  • Editing the left border of an audio region now behaves as expected when the Snap setting is set to “Snap Regions to Relative Value”.
  • Resizing a region with the Snap setting set to “Snap Regions to Absolute Value” now behaves as expected.
  • Resolves an issue that caused an event in the Event List to move later than expected when editing its position.
  • The “Capture as Recording” command now works as expected when multiple MIDI tracks are record-enabled.
  • It's now possible to preview sections of an audio file outside the current region borders by clicking the area in the Project Audio window.
  • The tap-to-click option for trackpads now works reliably with all drop down menus.
  • The “Discard Recording and Return to Last Play Position” key command now reliably discards the recording.
  • It's again possible to use the Tab key to navigate to the next control while working with plug-ins in Controls view.
  • The MIDI Activity display now shows chords as they are played when using Musical Typing.
  • All currently found audio files are now reliably saved with a project when using Save As or Save a Copy As with a project in which one or more audio files are missing.
  • The name of a project is now correctly updated after saving a project created from a template.
  • Fixes an issue in which clicking on the level LED in the track header did not select the track.
  • Resolves an issue in which changes made to the setup for Mackie Control and other MCU-compatible control surfaces were not saved by Logic Pro X.
  • Setting the Display Time preference to “SMPTE/EBU with Subframes”, “SMPTE/EBU without Subframes,” or “SMPTE/EBU with Quarter frames” can no longer cause the time display to jump unexpectedly.
  • Saving a project for the first time no longer resets the record path when it was previously set to an external path.
  • Performing undo in the Piano Roll or after deleting a flex marker no longer has the potential to unfreeze currently frozen tracks in the project.
  • Sample rate, tempo, and key information is now reliably stored within template files. 
  • Fixes an issue in which the Repeat Regions dialog did not have key focus when opened, making it necessary to click it with the mouse before pressing Return to confirm the operation.
  • Individual MIDI Draw points in the Piano Roll are now easier to grab.
  • Deleting a track no longer has the potential to inadvertently delete regions on other tracks.
  • Cut/Insert Time edits no longer add unexpected tempo changes.
  • Scrubbing the SMPTE display in the LCD no longer moves the playhead to the wrong position.
  • Copying an arrangement marker to a position between two other arrangement markers now moves the end-of-song marker to accommodate the new section, as expected.

Audio

  • Audio regions now appear as expected in the Audio Editor, even when cycle is enabled and there are no audio regions within the cycle area. 
  • Flex Pitch now correctly detects notes for take regions that have manually inserted flex markers.
  • The timing of notes played during the count-in on EXS24 or Drummer tracks is now more reliable.
  • Pasting an audio region into a take folder now correctly places the region on the selected take lane.
  • When saving an EXS instrument, the default save location is now ~/Music/Audio Music Apps/Sampler Instruments.
  • Editing the start point and anchor in the EXS audio editor now consistently alters playback as expected.
  • Logic no longer overwrites an existing audio file of the same name when performing a bounce with the option to create a split stereo file enabled.
  • Audio tracks assigned to output to a bus now consistently maintain that assignment when imported into a different song.
  • User-defined controller assignments now work as expected to control MIDI plug-in parameters.
  • The Record Repeat command now deletes the previous recording when used after recording in Cycle mode.
  • Quantize now operates reliably on takes that are displayed in the Audio Editor.
  • The Tuner window is no longer affected by the Content Link setting of other plug-in windows.
  • Audio now plays for multiple cycle iterations when using marquee selection to define the cycle area.
  • When the Edit command “Analyze Audio for Flex Editing” is used, Logic now properly resets any existing pitch edits on the selected audio files.
  • Command-clicking a selected note in Flex Pitch mode in the Audio Editor now deselects the note, as expected.
  • Setting a track to Flex Edit mode with the Slicing algorithm no longer processes the track with Flex if no edits have been applied.
  • It's again possible to set Software Instruments to mono.
  • Logic no longer creates an extra audio file when merging or format-converting audio files.
  • Resolves an issue in which the Mixer did not show the 8th bus send on a channel strip.
  • Changing the input format of a stereo output channel strip to mono now creates a second mono output channel strip on the Mixer for the other channel in the stereo pair.
  • Setting an external recording path now reliably resets the Audio Assets setting. Conversely, enabling the Audio Assets setting now disables an externally set recording path.
  • The compressor meter in the channel strip is now in sync with the meter in the plug-in window.

Drummer

  • Improves the translation of articulations when an Ultrabeat-based patch is assigned to a Drummer track.
  • When a project starts on an upbeat, a Drummer region at the project start now automatically creates a fill at the beginning.
  • Changes to Drummer regions are now reliably applied when the regions are set to follow a flexed audio track.

MIDI editors

  • The Link mode button is now available for the Piano Roll editor.
  • The “Limit Dragging to One Direction” setting now works as expected in the Piano Roll.
  • It's now possible to grab notes shorter than 15 ticks for editing in the Piano Roll.
  • Double-clicking a region with MIDI Draw enabled now consistently opens or closes a MIDI editor.
  • Resolves an issue in which recently recorded MIDI notes might disappear from view in the Piano Roll when recording with cycle engaged.
  • It's again possible to alter the pitch of notes in the Piano Roll via MIDI input.
  • Using Option-Shift to edit the end points of multiple selected notes to the same position in the Piano Roll Editor now works as expected.
  • In the Piano Roll, it's again possible to use Option-Shift in conjunction with the Velocity tool to set all selected notes to the same velocity.
  • An Event Float window that is linked no longer switches unexpectedly to the Region level when using arrow keys to move from note to note in the Piano Roll.
  • Pasting events in the Piano Roll when the playhead is to the right of the region border will not trigger the error “Illegal Region number”. 
  • It's now possible to copy a note in the Piano Roll to a different pitch at the same position when the note starts before the left edge of the region.
  • It’s now possible to move notes in the Piano Roll by increments smaller than 13 ticks when the “Limit Dragging to One Direction” setting is enabled.
  • User-inserted rests no longer incorrectly appear as notes in the Piano Roll.
  • Copying a muted note in the Piano Roll now creates a muted copy of the note, as expected.
  • Fixes an issue in which some note events might not be selectable in the Step Editor.
  • The contents of the Event List are now updated properly when deselecting a region from a multiple selection while Content Link mode is enabled.
  • The Event List now displays the correct LSB values for 14-bit pitch bend events.
  • Editing Release Velocity values in the Event List now behaves as expected.
  • The “Copy selected events” option in the MIDI Transform window now behaves as expected.

Score Editor

  • Fixes an issue that could cause the menu option for switching between Parts and Score view in the Score Sets window to disappear.
  • Double-clicking a region with the All Instruments filter setting active now reliably reveals all regions on that track, rather than just the single region.
  • The contents of the Event List editor are more consistently updated when changing the region selection from the Score window.
  • Newly inserted key signatures no longer display “xx Major” in some circumstances.
  • The Chord Grid Editor now correctly names Add 9 chords.
  • The clef menu no longer disappears for a Mapped Instrument staff style set to “No Clef”.
  • It's again possible to create a new Chord Grid library that uses an alternate tuning.
  • It's now possible to adjust the Velocity setting in the MIDI Meanings settings window by scrubbing the value with the mouse.
  • The length adjustment in the MIDI Meanings settings window can now be adjusted via a pop-up menu.
  • In the Staff Style window, the check marks indicating that a style is used in the current song now reliably update to reflect changes when Content Link mode is off.
  • Grace notes now scale properly when the scale setting of a Score Set is less than 100.
  • Resolves an issue that prevented reassigning instruments assigned to a Score Set after performing certain other edits.
  • Fixes an issue that prevented naming a floating score Part box set.

Plug-ins

  • Solo now works as expected on channel strips using an external I/O plug-in
  • Ultrabeat can now find samples that have been relocated from the default install location.
  • Ultrabeat now correctly applies the Fine Pitch adjustment to all triggered samples when trigger mode is set to Multi.
  • It's now possible to halve/double the current rate of the Arpeggiator plug-in by clicking the Slow/Fast buttons.
  • The ES1 synth plug-in can now be set to offer 32 and 64 voices per instance.
  • The Scripter plug-in now allows System Realtime MIDI events to pass through.
  • The Scripter plug-in now offers an option to keep current control values when recompiling a script, rather than resetting all values back to their defaults.
  • The Scripter MIDI plug-in now includes a Set Parameter function.
  • Switching between Vintage Electric Piano patches while holding notes no longer potentially results in momentary jumps in level.
  • The Vintage Electric Piano no longer potentially creates audible pops when switching patches when the Drive is enabled and set to Type II.
  • It's now possible to continue working with the Scripter editor window when Logic Pro X is not in focus.
  • The Surround Compressor plug-in now properly shows all the new circuit types available in Logic Pro X.
  • It's again possible to copy or paste settings in the Space Designer plug-in window.
  • The order of controls in the Retrosynth Filter Envelope and Amp Envelope sections has been reorganized to improve usability.
  • The plug-in window no longer appears empty for Waves plug-ins opened in projects created in Logic 9.
  • Fixes an issue in which inserting a plug-in on multiple stereo Software Instrument channel strips would insert mono versions of the plug-in on some channel strips.
  • EXS24 or Kontakt settings are no longer removed from a song if the Audio Device buffer size is changed before saving the song.
  • Resolves an issue in which adjusting parameters on the Channel EQ while playing back might cause minor clicks and pops in the audio signal.
  • Moving an Amp Designer instance to a different plug-in slot no longer sometimes changes its sound.
  • “Save as Default” for Audio Unit presets again works as expected.

Video

  • It's now possible to exchange movie files in a project by dragging a new movie file into the Movie window or the Movie inspector.
  • Logic Pro X can now work with the following professional video codecs, if OS X Mavericks v10.9 and the codecs are installed: Apple Intermediate Codec, Apple ProRes, AVC-Intra, DVCPRO HD, HDV, XDCAM HD / EX / HD422, MPEG IMX, Uncompressed 4:2:2, XAVC.
  • There is now a Show/Hide Movie Window command in the View menu when the current project contains a movie.
  • Resolves an issue in which some movies that were compatible with QuickTime X did not play in Logic Pro X.
  • Exporting audio to a movie with a portrait orientation no longer causes the movie to rotate 90 degrees.
  • Logic is now  able to export surround AAC audio to a movie even if the original audio in the movie was originally kept.
  • The visible frame of a movie now updates as note lengths in the Piano Roll are changed.

Import/export fixes and improvements

  • XML projects imported from Final Cut Pro X now contain volume and pan automation when opened in Logic Pro X.
  • Exporting a project as an Final Cut Pro/XML file with the “Export as Final Cut Compound Clip” option enabled now behaves as expected.
  • Includes several improvements to the way Logic handles audio sample-rate conversion when importing Final Cut Pro XML.
  • Logic now shows a progress bar when importing large Final Cut Pro XML projects.
  • 32-bit float audio files in Final Cut Pro XML projects are now converted to 24-bit files during import so they play properly when imported into Logic.
  • The start time of imported Final Cut Pro XML projects is now consistently correct.
  • It's now possible to export Music XML when the Score window is in linear view mode.
  • Logic no longer shows multiple alerts when importing a Final Cut Pro XML project containing videos in a format not supported by Logic.
  • Songs created in GarageBand 6 no longer load in Logic Pro X with an extra channel in the Mixer.
  • Fixes an issue in which audio in a song imported from GarageBand 6 might play back too fast in Logic Pro X.
  • Logic now offers to include embedded tempo and marker information when using Track Import to bring an audio file into a project that contains no other audio regions.
  • Simultaneously dragging multiple MIDI files into the Tracks area now behaves as expected when using No Overlap mode.
  • The default destination path for exported MIDI files is now the project folder instead of ~/Music/Logic.
  • When importing projects, there is now an Add All button in the Aux import dialog.
  • The user settings in the Bounce window are now retained after sharing to iTunes.
  • Split stereo SD2 files no longer incorrectly import as AIFF files when the WAV file option is enabled.
  • The “Share Song to iTunes” command now creates a playlist with the name entered if there is not already an iTunes playlist with that name.
  • MIDI events that precede the start point of a region are no longer included when the region is exported as a MIDI file.

Stability and reliability

Includes several fixes related to stability and reliability, including to resolve issues that could cause Logic to quit unexpectedly in these circumstances:

  • When changing the length of a time-stretched region
  • When importing tracks from another project
  • When recording with the color palette open
  • When bypassing an instance of the Maschine plug-in
  • When exporting Music XML after applying Enharmonic Shift to some notes
  • When changing the range on an Environment fader whose style was set to Text
  • When quitting a project that has a Surround Compressor inserted on a channel strip
  • When removing a control surface from the Control Surface setup window when the Logic Remote is also present
  • When changing the range value of a Smart Control during playback.
  • When reapplying a Time and Pitch operation after undoing a previous one
  • When dragging an audio region from a take folder to a new song

Logic Pro X 10.0.4 update

  • Includes a change that allows Logic to properly open GarageBand X projects.
  • Fixes an issue in which the Mixer might flicker when scrolling up or down in OS X Mavericks v10.9.
  • Resolves an issue in which EXS instruments created with third-party applications might exhibit unexpected voice "stealing" when played in Logic Pro X.
  • Resolves an issue in which the Tuner did not display correctly on Retina Displays with OS X Mavericks v10.9.
  • Fixes an issue in which Logic Pro X did not correctly display track icons in projects imported from GarageBand 2 for iOS.

Logic Pro X 10.0.3 update

  • Addresses an issue introduced in Logic Pro 10.0.2 in which Logic Pro would quit unexpectedly when a multi-output instance of a Software Instrument plug-in was bypassed.
  • Fixes an issue in which default MIDI region parameters in songs created in earlier versions of Logic might be set to incorrect values when opened in Logic Pro X.

Logic Pro X 10.0.2 update

Stability and Reliability

Includes various stability and reliability improvements, including, but not limited to:

  • Logic Pro X should no longer quit unexpectedly when:
    • Resizing a movie window while in full screen mode.
    • Opening a Text Style window in the Score Editor.
    • While making adjustments in the EXS Editor. 
    • Inserting notes in the Step Editor.
    • Going back a large number of steps in the Undo History.
    • Double-clicking the Drummer button in the Add New Track dialog.
    • Selecting all audio files in the Bin and then using the Copy/Convert command to relocate and convert them to another format.
    • Clicking an Apple Loop in the browser while another loop was playing back in the project.
    • Exporting a video with a cycle region active in the project.
    • Changing the Slope parameter in the Space Designer plug-in while using very long synthetic impulse responses.
  • Resolves an issue in which Logic Pro X might consume an unexpectedly large amount of CPU power while downloading content.
  • The Capture Last Take key command no longer erases a MIDI recording.

Performance

  • Improved CPU performance with audio plug-ins.
  • Fixes an issue in which changing the bypass state of a plug-in while Logic Pro was playing caused a CPU spike that might lead to an overload message.
  • Fixes an issue in which starting playback of the Ultrabeat sequencer could cause CPU spikes.
  • Using the Eraser tool to delete large numbers of notes in the Piano Roll no longer causes a long delay.
  • Improved CPU performance with MIDI plug-ins.
  • Fixes an issue in which playing notes into the Arpeggiator might lead to CPU overloads.
  • Includes various fixes to improve performance in Full Screen mode.

Compatibility

  • Specific Zoom and Snap functions in the Piano Roll now behave as expected when using a graphic tablet input device. 
  • The Apogee Control Panel is again accessible in Logic Pro X when using an Apogee Duet connected via FireWire.

Flex Editing

  • All tracks in a phase-locked edit group now remain in phase after using the "Reset all Flex Edits" command.
  • The "Set to Neutral Position" command is now correctly applied to all regions in a phase-locked edit group.
  • Tracks in a phase-locked edit group which have been flex edited now remain phase locked after changing a project's tempo.
  • Improved format preservation when shifting notes up or down by several semitones with Flex Pitch.

Track Stacks

  • Fixes an issue in which changing patches on a track that was soloed would cause any other soloed track stacks to become un-soloed.
  • Arming and disarming the main track in a Track Stack now reliably affects all sub-tracks that are part of the same group.

Score

  • Changing the font for Numbers & Names and then subsequently changing the font for another Text style no longer causes the second edit to be incorrectly applied to the Numbers & Names style.
  • Note heads now display as expected in the Note Attributes window when using Sigler Jazz or Swing fonts.
  • The Score preference previously labeled “Auto split notes in multi staff chord styles” is now labeled “Auto split notes in polyphonic staff styles.”
  • Tablature for 5-string banjo now displays correctly.
  • The Staff Style window now behaves as expected when Link mode was disabled.
  • Resolves an issue in which the text header and footer in Score were incorrectly positioned when printing or saving to PDF.
  • Fixes an issue in which the window focus unexpectedly jumped to the wrong area when editing a Staff Style with Link mode on.
  • Resolves an issue in the Score Editor in which it was possible to sometimes inadvertently select multiple notes when clicking on one note.

Drummer

  • Fixes an issue in which the Fills and Swing knobs in the Drummer Editor were accessible in cases where no region was selected.
  • Double-clicking on a Drummer region now opens or closes the editor.
  • Patch merging now works with Drummer patches.
  • Drummer regions are now created properly in songs with a start position before 1 1 1 1.

Movies

  • The movie inspector now shows the correct movie when two songs with movies are open at the same time.
  • Resolves an issue in which some supported movie files did not play in Logic Pro X.
  • Improves the chase behavior of movies when repositioning regions.
  • Movies containing a timecode track are now properly clipped to match an active cycle zone when exported from Logic Pro X.

User Interface

  • Resolves several issues in which Logic Pro X might display the wrong cursor.
  • The cursor now displays the correct tools when it is placed between transient markers while working in Flex Time mode within a Take folder.
  • Resolves an issue in which objects in the Environment window might snap much too far to the right when moved.
  • Increased window sizing flexibility when using Logic on portable computers.
  • Resolves an issue in which sliders in various preference windows had no effect until they were released.
  • Addresses a graphic issue in which the Piano Roll Editor could display an empty window.
  • Right-clicking in the Piano Roll now correctly brings up the Tool menu when the "Right Mouse Button: Opens Tool Menu" preference is set.
  • When a region color is changed, the color in the Step Editor now immediately updates as expected.
  • Resolves an issue in which the Playhead might not appear if an editor in the Main window is opened, closed, and then opened again.
  • Fixes an issue in which the Key Commands window might become inaccessible after entering and then leaving full screen mode.
  • Resolves an issue in which selecting a note in the Piano Roll might cause the visible area to jump to notes below the selected note.
  • The insert guideline now appears at the correct position when clicking with the Pencil tool when working with Flex Pitch in the Audio Editor.
  • The screen now redraws as expected when using the Select Next Event and Select Previous Event key commands in the Event List editor.
  • It is again possible to open plug-in windows while recording.
  • Fixes an issue in which AU plug-in names might incorrectly display as 4-character IDs in the mixer insert slot on systems running in Russian or Czech.
  • The LCD now properly displays minor song keys.
  • Fixes an issue in which it might not be possible to set the Mixer window to use all the vertical space on a display.
  • Resolves an issue in which the transparent overlay when dragging a region might not be visible in cases where the visible area is scrolled by dragging past the edge of the screen.
  • Fixes a screen redraw issue when the Edit > Move > To Selected Track command was used.
  • It is now easier to reveal the Toolbar by dragging down with the mouse cursor.

General

  • Clicking the Q button in an editor now correctly applies the Local Inspector setting instead of the setting in the Region Inspector.
  • Fixes an issue in which click-holding on a region might cause it to improperly shift slightly when Alignment Guides were active.
  • The "Limit Dragging to One Direction" setting now works as expected in the Piano Roll editor.
  • Undo commands work as expected after Flex Pitch editing.
  • Improves the reliability of of the Velocity tool in the Piano Roll when editing multiple notes at one time.
  • Resolves an issue in which the wrong sequence was sometimes pasted when using the Paste Sequence command in the Ultrabeat sequencer.
  • Fixes an issue in which arrangement markers could not be edited if the Marker track was protected.
  • Changing a stereo track patch to a mono patch now properly sets the channel strip input to mono.
  • Resolves an issue in which double-clicking in the MIDI Draw editor did not create an automation point if there were no existing automation points in the region.
  • Resolves an issue in which the "Export/Move active Comp to New Track" command created a track stack.
  • Region track assignments are now properly maintained when merging folders in the Main window. 
  • It is again possible to copy/paste data between takes within the same MIDI take folder.
  • The region play button in the Piano Roll now works reliably when working with MIDI takes.
  • Fixes an issue in which enabling the Protect button for any track disabled volume and pan adjustments for all tracks in the project.
  • Resolves an issue in which the Velocity setting in the Track Inspector might cause all notes to output with a velocity of 127.
  • Resolves an issue in which MIDI note off events might not be sent resulting in stuck notes when a large number of MIDI events were being processed in a short time.
  • Option-dragging a region to copy it in a project with a song start before 1 1 1 1 now works as expected.
  • Resolves an issue in which the snap setting was not reliably used when dragging regions with Alignment Guides visible in the Main window.
  • It is again possible to change the length of a loop in the Tracks area at small vertical zoom settings.
  • When multiple channels in the Mixer are selected, double-clicking on a fader’s value no longer causes the faders to move unexpectedly.
  • Resolves an issue in which pressing Enter to confirm text entry into the Mixer Track Notes caused the Playhead to jump back to the song start.
  • Fixes an issue in which using the Return key to confirm renaming a channel in the Mixer caused Logic to enter Play mode.
  • Resolves an issue in which the Piano Roll editor might be unexpectedly displayed if an audio region was selected and its position was outside the active cycle zone.
  • A track’s audio waveform display no longer changes when its Match Groove Track checkbox is toggled.
  • When multiple new tracks are created at once, all the new channels are now selected in the Mixer.
  • In songs created in GarageBand, changing the name of a channel on the Mixer now updates the corresponding track in the main window and vice versa.
  • Fixes an issue in which tracks that were muted in GarageBand Mobile songs were turned off when opened in Logic Pro X instead of muted.

Audio and Plug-ins

  • Changing the level or mute status of an Aux used as a submix no longer improperly changes the level or mute of an Aux set as a send destination from the same source channel strip.
  • Resolves an issue in which key click on the Vintage B3 Organ got softer at higher sample rates.
  • Fixes an issue in which the Rotor Cabinet in the Vintage B3 Organ got louder at higher sample rates.
  • Resolves an issue in which notes might hang when playing the Pedal manual of the Vintage B3 Organ with a sustain setting greater than 100 ms.
  • Fixes an issue in which Continuous Controller messages sent from a Roland VK77 controller might be sent to the wrong Manual in the Vintage B3 Organ.
  • The Vintage B3 Organ Upper Morph slider now updates properly when changing presets.
  • The Vintage Electric Piano plug-in now performs correctly at all sample rates.
  • The Adaptive Limiter Output Ceiling control again works correctly when Inter Sample Peak Detection is not enabled.
  • Resolves an issue in which the Gain meter did not reliably go back to "0db" when the Inter Sample Peak Detection checkbox was enabled.
  • Fixes an issue in which there might be an unexpected audio tail when un-bypassing a Software Instrument.

Logic Pro X 10.0.1 update

Stability

  • Logic Pro X should no longer quit unexpectedly when:
    • A Track Stack is flattened during playback.
    • Trimming an audio file in the Audio File Editor.
    • Switching from the Audio File Editor to the Audio Track Editor after enabling Flex Pitch.
    • Selecting or moving notes in the Piano Roll.
    • Saving a patch with an edited Smart Controls layout.
    • Several Software Instrument tracks are created in quick succession from Logic Remote.
    • Changing a velocity range in the EXS Editor while playing a note.
    • Deleting an arrangement marker.
    • A second lane of MIDI data is added with the pencil in the Step Editor.
  • Fixes an issue that could cause content downloading to hang.
  • Logic Pro X should no longer hang if the Length parameter in the Step Editor was double-clicked.
  • Logic Pro X no longer hangs when a settings folder containing more than 138 settings files is accessed from Logic Remote.

Track Stacks

  • Tuner is now available when selecting the main track of a Track Stack.
  • The output routing on a Drummer Track that has been manually reassigned to an Aux is no longer reassigned to No Output when changing drum characters.
  • It is again possible to switch Aux channels that are part of a Multi Output Software Instrument between mono and stereo.
  • Resolves an issue in which a copied main track of a Summing Track Stack did not maintain the correct routing for sub-tracks.
  • Track Stacks that contain both software instrument and audio tracks will no longer be inadvertently flattened by loading a Patch.
  • Multi-timbral tracks are no longer created as track stacks by default.

Score

  • Text styles in the Score window event inspector pop-up menu now display the currently selected language.
  • You should now be able to import custom Text Styles into a new project.
  • Edit focus on selected regions should now be properly maintained when opening the Staff Style window.
  • You should now be able to select rests and bar repeat objects in the Score window.
  • Mapped Staff Styles no longer improperly show a Transpose value.

General

  • Create New Track with Next Channel now works as expected for multi-timbral Software Instrument or External MIDI tracks.
  • When Follow is selected in the Drummer Editor, a track is now automatically assigned for Drummer to follow.
  • When exporting projects to AAF, 24-bit audio files are no longer converted to 16-bit.
  • Resolves an issue in which in some cases notes copied in the Piano Roll ended up at unexpected positions.
  • Shift-clicking in the timeline to adjust the cycle range now works as expected.
  • The Mixer now correctly shows channel strips when navigating between multiple folders in the Main window.
  • Take regions now appear consistently in the Track Audio Editor when they are selected.
  • Resolves an issue in which arrangement markers were improperly resized after being dragged in projects with a start point before bar 1 1 1 1.
  • Resolves an issue in which undo did not work after an arrangement marker was copied.
Important: Information about products not manufactured by Apple is provided for information purposes only and does not constitute Apple’s recommendation or endorsement. Please contact the vendor for additional information.
Last Modified: Jan 9, 2014
Helpful?
Yes
No
Not helpful Somewhat helpful Helpful Very helpful Solved my problem
Print this page
  • Last Modified: Jan 9, 2014
  • Article: TS4498
  • Views:

    132428
  • Rating:
    • 74.0

    (1034 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked