Languages

Aperture 3.4 and later: Some third-party plug-ins are no longer compatible

Symptoms

The App Sandbox is one of the security features of OS X Lion v10.7.5 and OS X Mountain Lion v10.8. It isolates apps from critical system components of your Mac, your data, and other apps in order to keep your Mac more secure from malicious software. Plug-ins that do not comply with the requirements of app sandboxing may not operate properly with Aperture 3.4 and later. When attempting to use an affected plug-in, you may be presented with an alert dialog. In some cases, you may be able to dismiss the alert message and use the plug-in anyway. In other cases, the plug-in may have no effect, or may cause Aperture to quit unexpectedly.

Resolution

In order to comply with the requirements of app sandboxing, some Aperture plug-ins may need to be updated by the developer. If you encounter a plug-in that no longer operates properly when you use it with Aperture 3.4, contact the developer of the plug-in directly and ask when a version compatible with app sandboxing will be available.

Important: Information about products not manufactured by Apple is provided for information purposes only and does not constitute Apple’s recommendation or endorsement. Please contact the vendor for additional information.
Last Modified: Sep 19, 2012
Helpful?
Yes
No
  • Last Modified: Sep 19, 2012
  • Article: TS4391
  • Views:

    4664
  • Rating:
    • 20.0

    (1 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked