Languages

Aperture 3.1: Alert while importing an Aperture 3 library

Symptoms

When you attempt to import a library created in Aperture 3.0.x into Aperture 3.1, you see the following alert:
"Error Importing Library.... The library could not be imported because it is from an out of date version..."

Resolution

 Any library from Aperture 3.0.x must be upgraded to Aperture 3.1 before it can be imported or merged into Aperture 3.1. To do this:

  1. In Aperture, choose File > Switch to Library > Other/New
  2. In the dialog that appears, select the library you want to upgrade from the the list. If the library you want to upgrade is not listed, click the Other Library button and use the file selector to choose the library.
  3. Click the Upgrade button in the "Welcome to Aperture 3.1" dialog.
  4. Switch back to your main Aperture library.
It is now possible to import the upgraded library into your main library.
Last Modified: Sep 2, 2012
Helpful?
Yes
No
Not helpful Somewhat helpful Helpful Very helpful Solved my problem
Print this page
  • Last Modified: Sep 2, 2012
  • Article: TS3527
  • Views:

    25786
  • Rating:
    • 57.0

    (666 Responses)
Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked