Languages

Archived - Final Cut Server 1.5: Alert may appear during upgrade

This article has been archived and is no longer updated by Apple.

Symptoms

When you upgrade to Final Cut Server 1.5, you may see the following alert during the upgrade process:

"The installer has detected an incompatible database schema version number for the upgrade."

This occurs if you restored the Final Cut Server database from a backup created in the Final Cut Server preference pane in System Preferences under Final Cut Server 1.0.

Resolution

When the alert appears the only option on the alert window is Quit. Click Quit to exit the Final Cut Server 1.5 Installer and use the following steps to restore the correct configuration file (postgresql.conf):

  1. Stop Final Cut Server from the Final Cut Server preference pane in System Preferences.
  2. Enter the following command in Terminal:
    sudo cp /Library/Application\ Support/Final\ Cut\ Server/Final\ Cut\ Server.bundle/Contents/Resources/share/postgresql/postgresql_8.2.conf /var/db/FinalCutServer/data/postgresql.conf
  3. Start Final Cut Server from the Final Cut Server preference pane in System Preferences.
  4. Open the Final Cut Server 1.5 Installer.

Additional Information

Note: If you know for certain that you restored the Final Cut Server database from a backup created in the Final Cut Server System Preferences under Final Cut Server 1.0, you can  follow the steps above prior to upgrading to Final Cut Server 1.5 to prevent the alert from appearing.

See this article for related information:

Final Cut Server 1.0: Using the preference pane to back up the database may not save the postgresql.conf file

Last Modified: Jul 29, 2013
Helpful?
Yes
No
  • Last Modified: Jul 29, 2013
  • Article: TS2862
  • Views:

    669
  • Rating:
    • 100.0

    (1 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked