OPENSTEP Current Patch List

This document discusses the current patches available for Apple's OPENSTEP operating system and for Enterprise Objects Framework. Follow the links in this article for detailed information on each patch.

This article has been archived and is no longer updated by Apple.
OPENSTEP 4.2 for Mach

All OPENSTEP 4.2 for Mach users should install the following patch:

    • OPENSTEP 4.2 Patch 4--This patch set includes fixes that address the Year 2000 compliance issue (century rollover). All users of OPENSTEP 4.2 should install this patch set. OPENSTEP 4.2 Patch 4 supercedes all previous OPENSTEP general system patches. If you have already installed an OPENSTEP patch on your system, you can install Patch 4 over your existing installation. You do not need to install any other OPENSTEP patches before installing this one.

There are several additional patches you may wish to install, depending on your needs:


OPENSTEP Enterprise 4.2 for Windows NT

All OPENSTEP 4.2 for Windows NT users should install the following patch:

    • OPENSTEP 4.2 Patch 4--This patch set includes fixes that address the Year 2000 compliance issue (century rollover). All users of OPENSTEP 4.2 should install this patch set. OPENSTEP 4.2 Patch 4 supercedes all previous OPENSTEP general system patches. If you have already installed an OPENSTEP patch on your system, you can install Patch 4 over your existing installation. You do not need to install any other OPENSTEP patches before installing this one.

OPENSTEP Enterprise 4.2 for Solaris and HP-UX

All OPENSTEP 4.2 for Solaris and HP-UX users should install the following patch:

    • OPENSTEP 4.2 Patch 4--This patch set includes fixes that address the Year 2000 compliance issue (century rollover). All users of OPENSTEP 4.2 should install this patch set. OPENSTEP 4.2 Patch 4 supercedes all previous OPENSTEP general system patches. If you have already installed an OPENSTEP patch on your system, you can install Patch 4 over your existing installation. You do not need to install any other OPENSTEP patches before installing this one.

OPENSTEP 4.0 and 4.1 for Mach

There are two patches available to users of OPENSTEP 4.1 for Mach:

    • NeXTSTEP and OPENSTEP Time Zone Patch--This patch corrects an issue with European daylight savings time under OPENSTEP 4.0 and 4.1
    • Sybase DBKit Adaptor Patch--This patch hould be installed only if you need to use DBKit-based legacy applications to access a Sybase database under OPENSTEP 4.0 or OPENSTEP 4.1 for Mach

OPENSTEP Enterprise 4.0 and 4.1 for Windows NT, Solaris, and HP-UX

There are no patches currently available for OPENSTEP Enterprise 4.0 or 4.1.

Enterprise Objects Framework 2.1

There are no patches currently available for users of EOF 2.1, but you should read the following article if you use the examples provided with EOF.

    • Correcting Century Issues in the EOF Examples--Apple is not aware of any century issues with Enterprise Objects Framework version 2.1 which would affect development or deployment of EOF applications. However, two scripts which install exaple data on Oracle for the Enterprise Objects Examples use a two-digit year format, which is not consistent with Apple's date-handling practice. This article provides instructions on how to change the EOF examples to avoid this issue.

Enterprise Objects Framework 2.0

There are several patches available for current users of EOF 2.0:

Enterprise Objects Framework 1.2

There are no patches currently available for users of EOF 1.2, but you should read the following article if you use the examples provided with EOF.

    • Correcting Century Issues in the EOF Examples--Apple is not aware of any century issues with Enterprise Objects Framework version 1.2 which would affect development or deployment of EOF applications. However, two scripts which install exaple data on Oracle for the Enterprise Objects Examples use a two-digit year format, which is not consistent with Apple's date-handling practice. This article provides instructions on how to change the EOF examples to avoid this issue.
Last Modified: Feb 20, 2012

Additional Product Support Information