Languages

Archived - Aperture: How to delete an image

This article has been archived and is no longer updated by Apple.

When it comes to deleting images, the required action will depend on whether you want to remove the master, one of its versions, or an alias. Because Aperture is a non-destructive editor with an emphasis on preserving untouched originals, it uses warning dialogs and more complex keyboard shortcuts to protect you from accidentally deleting valuable masters and versions. On the other hand, a single keystroke can delete alias files that lack unique information.

Here's a look at each type of image file, where you'll find them, and how to delete them by choosing a menu command or keyboard shortcut.

What is it? A master is the original image imported from your camera or other device.

Deleting a master will also delete all of its versions.
A version is a record of your adjustments to a master, plus a thumbnail. It does not contain a copy of the original image, so it takes up very little disk space.

The image you see in the Viewer is actually the result of adjustments contained within a version being applied to the master in real time.

Deleting a version from one location will also remove it from other locations in which it appears.
An alias is a pointer or reference to a version. It contains no unique information, so it's a breeze to delete.
Where it's seen Only when you choose View > Show Master Image in the Viewer. The thumbnails you see are always versions or aliases—never masters. In the browser for projects and the Library, and in the Viewer. In the browser for light tables, books, albums, web galleries, and web journals
How to delete
  1. Select a thumbnail.
  2. Choose File > Delete Master Image and All Versions.
  3. Click the "Move to Trash" button.
  1. Select a thumbnail.
  2. Choose File > Delete Version.
  3. Click the Remove button.
Note: If you have only one version of an image, you can't delete it without also deleting the master.
  1. Select a thumbnail.
  2. Choose Images > Remove From Album.
Shortcut Command-Delete Command-Delete Delete

In addition to menus and keyboard shortcuts, you can also access the image removal commands in the shortcut menu by Control-clicking any image.

Last Modified: Feb 18, 2012
  • Last Modified: Feb 18, 2012
  • Article: TA38325
  • Views:

    6007

Additional Product Support Information