Languages

Archived - Mac OS 8.5: Sherlock Features

What are the features of the Sherlock application?
This article has been archived and is no longer updated by Apple.

The Find File application, previously located in the Apple menu, has been expanded and renamed Sherlock in Mac OS 8.5. It includes two additional features: Find By Content and Search Internet. In addition, Sherlock allows you to save search settings into a settings file which can be used to quickly perform searches.

Find File - The Find File section lets you search local disks and connected file server volumes for files by file name or by many other file attributes:



Figure 1, Sherlock Find File feature

To select the volume to be searched, use the Find Items pulldown menu. Use the pulldown menus to select volume to be searched, the file attribute type and search arguments. For additional search options, click the More Choices button. After specifying your search criteria, click the Find button. The results of the search are shown in a separate window. Click the name of the file to view the location on the volume in the window below the search results.

Double-click on a file name to open it. To move or copy the file, click and drag its icon from the search results window to the Finder desktop, volume, or folder location, and release the mouse button.

Find By Content - The Find by Content section of Sherlock lets you search the contents of files on your local volumes for one or more key words. Find By Content works by searching for key words contained within the text of each of the files. After indexing your files, you can search for information contained within the file without first having to open the file. This makes finding information contained within multiple files quick and easy.

Find by Content and Search Internet requires QuickTime 3.

To access Find By Content, click its tab in the Sherlock window:



Figure 2, Sherlock Find by Content feature

You must index your hard disk volumes before you can search the contents of the files. Server volumes cannot be indexed. The Find button will remain disabled (gray) until indexing has been completed. Depending on the number of files contained on the volume, indexing may take a significant amount of time to complete. Note that, for optimum performance and disk space usage, only the first 2000 unique terms of each document are indexed. To learn more about that limit, see technical document 106986, "Mac OS: Find By Content Index Limited to 2000 Unique Terms".

After indexing is complete, you can enter keywords for information you want to find within the contents of files in the Find by Content window, then click the Find button. Search results are sorted by relevancy and can be sorted by name, kind, or size by clicking the column heading name. To open a file, double-click its name in the list.

To find files that are similar in content to a file in the search results list, first select the file, then click the Find Similar Files button. The contents of the file you selected will be used to search for other files with similar contents.

To summarize the contents of a file to the clipboard, hold down the Control key while clicking on the file name in the search results list. Select Summarize to Clipboard from the contextual menu that appears. The contents of the file will be summarized and displayed in the Finder's clipboard window:

Note: The Summarize to Clipboard feature works only on files whose type is TEXT.

Search Internet - the Search Internet section of Sherlock provides the ability to quickly search the Internet using your choice of popular search engines. Additional Internet search sites can be easily added by dropping their files onto the System Folder. Search site files go into the Internet Search Sites folder.

Find by Content and Search Internet requires QuickTime 3.

The Search Internet feature is the fastest and easiest way to search Internet search engines since you search multiple sites with a single search.

To access the Search Internet section, click its tab in the Sherlock window:



Figure 3, Sherlock Search Internet feature

To perform an Internet search, type the keywords for the information you want in the Words field. Select the checkbox for each Internet search engines to use for the search, then click the Search button. For example, typing "PowerBook 1400 and memory" would perform a search on the selected Internet search sites for these keywords. The results of the search are presented in a window, ranked by relevance.

To sort the search results by Name or by Site, click the column heading.

To view a summary of a link in the list, click its name. A short summary of the link is presented in the window below the search results.

To open the link with your web browser software, click the link name in the summary window.

Internet search site files may be periodically updated for changes in search engines or to take advantage of newer features. When performing an Internet search with a search source file, an automatic check is performed to determine if an updated search source is available. If such an update is available, a window will appear:



Figure 4, Updated Search Sites Available window.

To accept the update, click the Update button. You can also manually check for updates by selecting the Update Search Sites command in the Find menu.

Save Search Criteria - After you have specified the search criteria for Find File, Find by Content, or Search Internet, you can save the search as a file. This file can be opened later to automatically perform the search. To save search criteria, select Save Search Criteria in the File menu. Enter the name and location to save the search criteria, then click the Save button. The search criteria is saved in a file and appears in the location you specified.

Sherlock Preferences - The Preferences allows you specify options to be used with the Sherlock application. The access the Preferences, select Preferences from the Edit menu:



Figure 5, Sherlock Preferences

Show current search status for Find File - selecting this option provides the search status in the Find File window.

Indexing options - select the Don't index items with this label to have the index ignore all folders and files using that label. NOTE: Be certain that all items you wish to have indexed on the hard disk are set to use a label other than the one you select.

System Responsiveness while indexing - if you choose to work with the computer while indexing files, you may find the system performance to be slow. In this case, adjust this setting to the More Responsive setting to help improve system performance.

For additional information on how to use this feature, click the Help button or open the Help Center (from the help menu) and type the name of the feature. Balloon Help can also answer questions about window contents, window controls and menu items in the Finder, Control Panels and Applications, where supported. To turn on Balloon Help, choose "Balloon Help" from the Help menu in the Finder.

Last Modified: Feb 20, 2012
  • Last Modified: Feb 20, 2012
  • Article: TA25758
  • Views:

    538

Additional Product Support Information