Languages

Archived - AppleWorks: Restoring Unusable Database Document

If an AppleWorks database document will not allow new records to be added, or the document starts behaving erratically, use the following information to extract the data from the database and insert it into a new database.
This article has been archived and is no longer updated by Apple.
Important: This technique works best for databases in which all the fields are defined as text, such as an address list for mailing labels. If your database fields contain calculations or non-text field types, then you may refer to "AppleWorks: Document Recovery Techniques" for a more general process. Usually, these steps will restore the ability to create new records. The issue may persist in rare cases, following the exported data beyond the attempted restoration process. If this occurs in your case, you may have to either create a second database for additional data or recreate the database entirely.

For our example, we will refer to a database named "MyAddressBook."

Follow the steps to rebuild the database that correspond to the version of software you are using.

AppleWorks 5 and ClarisWorks 5

  1. Open the affected database.

  2. Choose Save As from the File menu. A dialog box appears.

  3. At the top of the dialog box, use the pop-up menu to select the location where you will be saving the file. For simplicity, you may choose Desktop.

  4. Near the middle of the dialog box, the text "Save As" appears. Below is a pop-up menu indicating the file type, which is most likely AppleWorks. Choose DBF from the File Type pop-up menu.

  5. Below the pop-up menu appears the file name "MyAddressBook." Add a suffix of your choice to the file name. The suffix is to prevent overwriting the original file by generating a new copy. For simplicity, you may add the suffix ".dbf."

  6. Click Save.

  7. Close the affected database. If you are prompted to save changes, click Don't Save.

  8. Choose New from the File menu. A New Document window appears.

  9. Choose to open a new database document.

  10. Create fields with the exact same names in the exact same order as the original database. Field names, for example, might be "name," "address," and "city/state/zip" for an address book. After creating fields, click Done.

  11. Give the new database a name that distinguishes it from the original. Choose Save from the File menu. For simplicity, name the file "Myaddressbookv2." Click Save. Now, you should have a new database containing one empty record with the same fields as the original.

  12. Choose Insert from the File menu. Using the dialog box that appears, navigate to the location where you saved the file MyAddressBook.dbf. Click once on the file name to select it, then click Insert.

  13. Now you should see all your original data inserted into the new records. Normally, this will leave one blank record at the top of your database. You may delete the blank record by select it with the pointer then choosing Delete Record from the Edit menu. You may now save the new copy of your database.

AppleWorks 6

  1. Open the affected database.

  2. Choose Save As from the File menu. A dialog box appears.

  3. At the top of the dialog box, use the pop-up menu to select the location where you will be saving the file. For simplicity, you may choose Desktop.

  4. Near the bottom of the dialog box is a pop-up menu labeled File Format. The pop-up menu most likely says AppleWorks. Choose ASCII Text from the pop-up menu.

  5. Above the File Format menu appears the Name field, which in our example would contain "MyAddressBook." Add a suffix of your choice to the file name. The suffix is to prevent overwriting the original file by generating a new copy. For simplicity, you may add the suffix ".txt."

  6. Click Save.

  7. Close the affected database. If you are prompted to save changes, click Don't Save.

  8. Choose New from the File menu. A New Document window appears.

  9. Choose to open a new database document.

  10. Create fields with the exact same names in the exact same order as the original database. Field names, for example, might be "name," "address," and "city/state/zip" for an address book. After creating fields, click Done.

  11. Give the new database a name that distinguishes it from the original. Choose Save from the File menu. For simplicity, name the file "Myaddressbookv2." Click Save. Now, you should have a new database containing one empty record with the same fields as the original.

  12. Choose Insert from the File menu. In the dialog box that appears, navigate to the location where you saved the file MyAddressBook.txt. Choose All Available from the File Format pop-up menu. Click once on the file name to select it, then click Insert.

  13. Now you should see all your original data inserted into the new records. Normally, this will leave one blank record at the top of your database. You may delete the blank record by selecting it with the pointer then choosing Delete Record from the Edit menu. You may now save the new copy of your database.


Last Modified: Feb 20, 2012
  • Last Modified: Feb 20, 2012
  • Article: TA25361
  • Views:

    411

Additional Product Support Information