Archived - Mac OS X: Resolving login issues with Active Directory plug-in

This article has been archived and is no longer updated by Apple.

You can resolve some Active Directory Plug-in login issues, in which the computer becomes unresponsive ("hangs") at the blue progress bar, by changing the startup parameters for automount.

Warning: If you are unfamiliar with command-line interface and manual configuration in general, you should be cautious or seek assistance. Due to the advanced nature of this procedure, the complimentary support included with new Apple products does not cover this procedure. However, fee-based support is available through Apple Professional Services (http://www.apple.com/services/). If you do not follow these steps precisely, the script may not work, which could prevent the computer from starting up normally.

  1. Make sure you are logged in with an administrator account.
  2. Open Terminal (/Applications/Utilities).
  3. Create a backup of the current NFS Startup script with this command on a single line:
    sudo cp /System/Library/StartupItems/NFS/NFS /System/Library/StartupItems/NFS/NFS.bak
    
  4. Open the NFS Startup Item script for editing with pico by using this command:

    sudo pico /System/Library/StartupItems/NFS/NFS

  5. To locate the section of the script that starts automount, press Control-W, type "automounter", and press Return.
  6. Under the section "Start the automounter," change the line that reads:

    automount -m /Network -nsl -mnt ${AUTOMOUNTDIR}

    to read:

    automount -1 -m /Network -nsl -mnt ${AUTOMOUNTDIR}

  7. Change the line that reads:

    automount -m /automount/Servers -fstab -mnt /private/Network/Servers \\

    to read:

    automount -1 -m /automount/Servers -fstab -mnt /private/Network/Servers \\

  8. Save the file (Control-O, Return), and exit pico (Control-X).
  9. Reboot.
Last Modified: Feb 20, 2012
  • Last Modified: Feb 20, 2012
  • Article: TA24179
  • Views:

    452

Additional Product Support Information