Languages

Archived - AppleShare: Platforms and Mac OS Releases Supported

This article explains which versions of AppleShare are supported with which computers and version of the Mac OS.

Note: Supported means users can expect technical assistance from Apple and all issues will be prioritized along with other development efforts.
This article has been archived and is no longer updated by Apple.
Note: AppleShare IP is not supported on any Apple computer released after 2001-02-01.
Supported Platforms
AppleShare Version
Computers
AppleShare 3.0.1Macintosh computers with a Motorola 68000, 68020, or 68030 processor. System 7.0 through System 7.5.1
AppleShare 4.0All users should update to AppleShare 4.0.1
AppleShare 4.0.1/4.0.2All Motorola 68040-based computers, except Quadra 660AV and Quadra 840AV. (See Notes 1 and 2)
AppleShare 4.0.2PowerPC-based computers with clock speeds less than or equal to 80 MHz (except Power Macintosh 6100/66 and 7100/80). (See Note 3)
AppleShare 4.1All NuBus PowerPC-based computers available through 1995-04 (not Power Macintosh 7200, 7500, 8500, or 9500 computers).
AppleShare 4.2All NuBus PowerPC-based computers (not Power Macintosh 7200, 7500, 8500, or 9500 computers).
All users should update to AppleShare 4.2.1
AppleShare 4.2.1Works with PCI- and NuBus-based Workgroup Servers and Power Macintosh computers. AppleShare 4.2.1 is compatible with Open Transport on PCI-based Power Macintosh 7200, 7500, 8500, and 9500 computers. AppleShare 4.2.1 will not run on any computer with a Motorola 68000-family microprocessor.
AppleShare IP 5.0Any Apple Power Macintosh or Apple Workgroup Server with a PowerPC 601, 604, or 604e processor.

Not supported on Power Macintosh computers with 603 or 603e processors. Not supported on non-Apple computers.
AppleShare IP 5.0.3Any Apple Power Macintosh or Apple Workgroup Server with a PowerPC 601, 604, 604e, or G3 processor.

Not supported on Power Macintosh computers with 603 or 603e processors. Not supported on non-Apple computers.
AppleShare IP 6.0, 6.1, 6.1.1, 6.2Any Apple Power Macintosh or Apple Workgroup Server with a PowerPC 601, 604, 604e, or G3 processor. Also supported on the Power Macintosh 6500 series.

Not supported on Power Macintosh computers with 603 or 603e (except for the Power Macintosh 6500). Not supported on non-Apple computers. All users should update to ASIP 6.1.1; ASIP 6.2 is recommended.
AppleShare IP 6.3, 6.3.1, AppleShare IP Agent Update 6.3.2, AppleShare IP 9.0.4 UpdateAny Apple Power Macintosh computer, iMac, or Macintosh Server with a PowerPC 601, 604, 604e, G3, or single G4 microprocessor, or a Power Macintosh 6500 series computer with a 603e microprocessor.

Not supported on dual-processor Power Mac G4 computers or Power Macintosh computers with 603 or 603e (except for the Power Macintosh 6500). Not supported on non-Apple computers.
AppleShare IP 6.3.3Any Apple Power Macintosh computer, iMac, or Macintosh Server released prior to 2001-07-18 with a PowerPC 601, 604, 604e, G3, or G4 microprocessor(s), or a Power Macintosh 6500 series computer with a 603e microprocessor.

Not supported on Power Macintosh computers with 603 or 603e (except for the Power Macintosh 6500). Not supported on non-Apple computers. (See Notes 6, 7.)
AppleShare IP 6.3.3 v1.2Macintosh Server G4 (QuickSilver) with AppleShare IP
(See Note 7.)
AppleShare IP 6.3. 3 v1.3Macintosh Server G4 (QuickSilver 2002) with AppleShare IP
(See Note 7.)

Supported Mac OS Releases
AppleShare Software Version
System Software Version
AppleShare 3.0.1System 7.0 or later. System 7.1 is recommended
AppleShare 4.0.1/4.0.2System 7.0.1 (with System 7 Tune-Up 1.1.1) through System 7.5.3 with Classic AppleTalk only. It is not compatible with Open Transport networking. System 7.1 is recommended.
AppleShare 4.1System 7.5.1 only
AppleShare 4.2System 7.5.1 only
(ALL users advised to update to AppleShare 4.2.1.)
AppleShare 4.2.1System 7.5.3 through Mac OS 7.6. This release is compatible with Open Transport networking.
AppleShare IP 5.0Mac OS 7.6, and Mac OS 7.6.1 only on computers that cannot run Mac OS 7.6, such as the Power Macintosh 7300/7350/8600/9600/9650 computers.
AppleShare IP 5.0.3Mac OS 8.0 and Mac OS 8.1; Mac OS 8.1 is recommended.
AppleShare IP 6.0Mac OS 8.1 with OpenDoc 1.2.1.
AppleShare IP 6.1 and 6.1.1Mac OS 8.1 minimum, Mac OS 8.5 or 8.5.1 recommended. OpenDoc 1.2.1 required.
AppleShare IP 6.2Mac OS 8.6 with OpenDoc 1.2.1 required.
AppleShare IP 6.3Mac OS 9.0 (OpenDoc not required)
AppleShare IP 6.3.1Mac OS 9.0.3, Mac OS 9.0.4 (OpenDoc not required)
AppleShare IP Agent Update 6.3.2, AppleShare IP 9.0.4 UpdateMac OS 9.0.4 (OpenDoc not required. See Note 5.)
AppleShare IP 6.3.3Mac OS 9.1 (OpenDoc not required. See Note 7.)

Note: Not supported with Mac OS 9.2.
AppleShare IP 6.3.3 v1.2Mac OS 9.2.1 or 9.2.2 (See Note 7.)
AppleShare IP 6.3.3 v1.3Mac OS 9.2.2 (See Note 7.)


AppleShare Client and Mac OS Releases
System Software
Recommended AppleShare Client
System 7.5 and earlier AppleShare Client 3.5
System 7.5.1 through 7.5.2 AppleShare Client 3.6.5
System 7.5.3 through 7.5.5 AppleShare Client 3.7.4 with Open Transport 1.1.2
Mac OS 7.6 through 8.0 AppleShare Client 3.8.3
Mac OS 8.1 through 9.0.4 AppleShare Client 3.8.6. (See Note 4)
Mac OS 9.1 AppleShare Client 3.8.8
Mac OS 9.2.1 AppleShare Client 3.9



Notes:
    1. From a functional standpoint, AppleShare 4.0.1 is identical to AppleShare 4.0.2 for 68040-based Macintosh computers. There is no need to upgrade AppleShare 4.0.1 to AppleShare 4.0.2. The only differences between these versions are the version number itself, and that AppleShare 4.0.2 was available in a complete retail package, while AppleShare 4.0.1 is available as a tune-up only requiring installation over an existing copy of AppleShare 4.0.
    2. If you have a Workgroup Server 95, do not upgrade to System 7.5 or later. A Workgroup Server 95 with A/UX only works with System 7.0.1 and System 7 Tune-Up 1.1.1.
    3. AppleShare 4.0.2 for Power Macintosh is no longer sold separately.
    4. AppleShare Client 3.8.6 requires Keychain, part of Mac OS 9, to automatically connect to server volumes at system startup time. Mac OS 8.1 through 8.6 users who rely on this feature may wish to use AppleShare Client 3.8.3 instead. Before doing so, please see article 25038: "Mac OS 8.6: Cannot Save AppleShare Log-On Password" for known limitations and other alternatives.
    5. Macintosh computers with Mac OS 9.0.4 and Mac OS ROM 4.6 and later require the ASIP Agent Update 6.3.2.
    6. AppleShare IP 6.3.3 provides compatibility for dual-processor Power Mac G4 computers but does not provide multiprocessing performance enhancement.
    7. AppleShare IP 6.3.3 is supported only on Mac OS 9.1. The Power Mac G4 (QuickSilver) and Power Mac G4 (QuickSilver 2002) computers require minimums of Mac OS 9.2.1 and 9.2.2, respectively. They require minimums of AppleShare IP 6.3.3 v1.2 and 6.3.3 v1.3, respectively. The only changes in v1.2 and v1.3 were made in the Installer Scripts, so they will install on newer computers with versions of Mac OS 9.2.x installed. The appropriate version of AppleShare IP is currently available to education customers with purchase of a new Macintosh Server G4 with AppleShare IP bundle. This software is not sold separately, and non-education customers do not have this option.


Updates for AppleShare are available from Apple Software Updates (http://www.apple.com/swupdates/).
Last Modified: Feb 17, 2012
  • Last Modified: Feb 17, 2012
  • Article: TA21622
  • Views:

    1694

Additional Product Support Information