iMovie (2013): Work with multiple libraries

Work with multiple libraries

You can think of a library as the place to store all your stuff: a collection of one or more events. An event is a grouping of footage based on the date and time the clips were recorded, as well as the projects you create with them. Most of the time, you have only one iMovie library, but there are situations in which you might want to have more than one. For example, you might want to back up your current project or create an archive of your events and projects on a separate (external) hard disk. Or you might want to free up storage space on your Mac by moving iMovie events to another hard disk. Or you might want to edit a project on another Mac.

iMovie allows you to create additional library files in different locations on your internal hard disk or on different hard disks. You can access and work on any library at any time from within iMovie. And you can move and copy clips and events between libraries.

Create a new library

  1. Choose File > Open Library > New.

  2. In the Save dialog that appears, type a name for the new library, and navigate to the location where you want to save it.

    The default location is the Movies folder in your home folder.

  3. Click Save.

    A new library is created in the location you chose, and a new, empty event with today’s date is created.

Show or hide the Libraries list

You select libraries and events in the Libraries list.

To show the Libraries list: Click the Show button Figure. Show button. on the left side of the toolbar.

To hide the Libraries list: Click the Hide button Figure. Hide button. on the left side of the toolbar.

You can also choose Window > Hide Libraries (or press Shift-Command-1).

Copy or move projects, events, or clips between libraries or hard disks

  1. Connect a hard disk that contains the target library to your computer, or copy the target library to your computer.

  2. Choose File > Open Library, and choose an option from the submenu.

    You can choose from recently opened libraries at the top of the submenu, locate an existing library on your computer, or create a new library.

  3. The selected library is opened in the Libraries list, with the first event selected and its contents displayed in the browser.

  4. In the Libraries list, select the event that contains the item you want to move or copy.

  5. In the browser, select the item you want to move or copy.

    Note:   To select multiple items, hold down the Command key as you click the items you want to select, or drag a selection rectangle around the items.
  6. Do one of the following:

    • To move items between events or libraries: Drag the clip or project to another event or library.

    • To copy items between events or libraries: Option-drag the clip or project to another event or library by first starting to drag and then holding down the Option key as you drag.

Move video clips, projects, or events to the Trash

You can delete unwanted clips or projects from an event, and you can delete an entire event in order to free up space on your hard disk.

  1. In the Libraries list, do one of the following:

    • To delete an event: Select the event you want to delete.

    • To delete clips or projects in an event: Select the event that contains the items you want to delete and then select the clips or projects you want to delete in the browser.

    Note:   To select multiple items, hold down the Command key as you click the items you want to select, or drag a selection rectangle around the items.
  2. Choose File > Move to Trash.

    If a clip you’re deleting is in use anywhere else in your library, it is not deleted.

    Note:   Selecting a clip and pressing Delete marks it as rejected. For more information, see Mark clips as favorite or rejected.
Last Modified: Nov 3, 2013
Helpful?
Yes
No
  • Last Modified: Nov 3, 2013
  • Article: PH14745
  • Views:

    null

Additional Product Support Information