Languages

Archived - AirPort Extreme Card: Compatible Macs

The AirPort Extreme Card works with the computers listed below and with Mac OS X 10.2.3 or later.

Warning: The AirPort Extreme Card is for use only with the Macs listed below. Attempting to install it in a Mac that is not on this list may damage the Mac and/or the card. For a list of Macs that require the earlier AirPort Card, see, AirPort Card: Compatible Macs.

This article has been archived and is no longer updated by Apple.

AirPort Extreme Card


When sold separately, the AirPort Extreme Card (Figure 1) requires one of these Macs:

  • Power Mac G5
  • Power Mac G4 (FW 800)
  • PowerBook G4 (12-inch)
  • PowerBook G4 (12-inch DVI)
  • PowerBook G4 (15-inch FW800)
  • iMac - see this article instead.
  • iBook G4
  • eMac (ATI Graphics) (See Note)
  • eMac (USB 2.0)

These Macs always come with the AirPort Extreme card built in:

  • PowerBook G4 (17-inch)
  • PowerBook G4 (17-inch 1.33GHz)

Note:

An eMac (ATI Graphics) computer without a SuperDrive may be able to start up in Mac OS 9. If the computer is started up in Mac OS 9, you cannot use the AirPort Extreme Card. To regain use of the AirPort Extreme Card, start the computer up in Mac OS X 10.2.3 or later.

Last Modified: Nov 29, 2011
Helpful?
Yes
No
  • Last Modified: Nov 29, 2011
  • Article: HT3024
  • Views:

    14903
  • Rating:
    • 100.0

    (1 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked