Languages

Logic Pro/Express 8 and 9: Tips on troubleshooting project files

On rare occasions, you may find that a project file behaves in unexpected ways. Learn how to prevent potential issues with your projects, as well as how to troubleshoot unexpected issues that may occur.

Prevention

One of the best ways to protect against issues with your projects is to save versions as you work. One strategy is to start each session by saving a version of the project with the current date as part of the name. You can save these versions of the project in the same project folder to avoid duplicating the assets. If for example you are working on a project named MyProject, and the current date is March 1, 2008 (2008-03-01), you could start your session by choosing File > Save As... and naming the new file MyProject 03_01_08. Each day that you work on the project, save a new version of the project with that day's date appended to the project name.

Logic also automatically keeps a backup history of the past 10 saved versions of a file. These backups are stored in a folder named "Project File backups" in your project folder. However, you can more easily find a version of your project that predates any issues by manually saving new versions as described above. Note that Logic creates a set of 10 versions for each project name within the project folder, so when you choose File > Save As... a new set of backups will be created, as shown here:

Use only validated Audio Plug-ins

A practice you can adopt that may help keep your project files from developing issues is to avoid using Audio Unit plug-ins that do not pass the validation test in the Audio Units Manager. Plug-ins that do not pass the validation test are automatically disabled in Logic.  In some cases it is possible to force Logic to use disabled plugins in the Audio Units Manager, but you should avoid this.

To confirm you are only using plug-ins that have passed validation, choose Logic Pro< (or Logic Express) > Preferences > Audio Units Manager… Click Disable Failed Audio Units at the lower-left of the window. If you have any plug-ins that do not pass the validation test, check the manufacturer website for updated versions.

Troubleshooting

If you do encounter issues with a project, try these steps:

  1. Open Logic without an audio driver: hold down the Control key when Logic begins to open.  A dialog appears, asking to launch the Core Audio driver. Click No.
  2. Open the project file.
  3. Choose Edit > Delete Undo History.
    Note: This will remove any saved undo steps.
  4. Choose Options > Project Information...

    Click Reorganize Memory. If any warnings about unused blocks appear, click Delete in the warning dialog, and click Reorganize Memory again, until there are no more messages.

  5. Save the project with a different name.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information.

Last Modified: May 13, 2014
Helpful?
Yes
No
  • Last Modified: May 13, 2014
  • Article: HT200152
  • Views:

    2135
  • Rating:
    • 20.0

    (1 Responses)

Additional Product Support Information

Start a Discussion
in Apple Support Communities
See all questions on this article See all questions I have asked