Alert when using iTunes Store on Snow Leopard developer release

When trying to use the iTunes Store in iTunes 9 on Mac OS X v10.6, the following alert may appear: 

"iTunes requires Safari 4.0.3 or later to be installed to use the iTunes Store within iTunes. Use Software Update to download and install the latest version of Safari."

This alert may continue to appear even though you run Software Update and it states "Your software is up to date."

This article has been archived and is no longer updated by Apple.

You will receive this message if you are using a developer release of Mac OS X v10.6 Snow Leopard. You must install the public release of Snow Leopard to resolve the issue.

To check which build of Mac OS X v10.6 you are using, click the Apple () menu, and choose About This Mac. Then, click the 10.6 version number one time to display the Mac OS build number.

On Mac OS X v10.6, the build number will consist of both letters and numbers. The build will start with "10A", followed by a 3 digit number. If the 3 digit number is lower than 432, then you are using a developer or Beta (pre-release) version of Mac OS X v10.6.

 

Last Modified:
Helpful?

Additional Product Support Information

Start a Discussion

in Apple Support Communities
See all questions on this article See all questions I have asked
United States (English)