Mac OS X: "Cannot use this version" alert appears when opening application

In some cases, when opening an application an alert message may appear: "You cannot use this version of the application <application name> with this version of Mac OS X."  The application does not open.

 

 

This article has been archived and is no longer updated by Apple.

The application you are trying to open must be updated in order to be used with the version of Mac OS X currently on your computer. Open Software Update to see if an update for the application you are trying to use is available.

 

 

Last Modified:
Helpful?

Additional Product Support Information

Start a Discussion

in Apple Support Communities
See all questions on this article See all questions I have asked
United States (English)