MacBook Pro (15-inch, Mid 2010) and MacBook Pro (17-inch, Mid 2010): World of Warcraft introductory movie does not play

When you run the 3rd-party application World of Warcraft for the first time with automatic graphics switching enabled, the screen may appear black.  Alternatively, you may notice that the introductory movie does not play. 

This issue only occurs when you run World of Warcraft for the first time (or if you have moved the WTF folder) and when the automatic graphics switching option is enabled in the Energy Saver System Preferences pane; this option is enabled by default.

Download and install the MacBook Pro Software Update 1.3 to resolve this issue.  You can also choose Software Update from the Apple () menu to install the update with Software Update.

Learn more

Read more about the automatic graphics switching feature.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information.

Last Modified:
Helpful?

Additional Product Support Information

Start a Discussion

in Apple Support Communities
See all questions on this article See all questions I have asked
United States (English)